gnome-menus.spec
author dc144907
Tue, 25 Jul 2006 17:10:00 +0000
changeset 7757 75600432f5f7
parent 7746 a3e6c2c2ad89
child 7867 45a649562cb1
permissions -rw-r--r--
Comment out very broken patches to allow the nightly build to progress.

#
# spec file for package gnome-menus
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:			gnome-menus
License:		LGPL
Group:			System/GUI/GNOME
Version:		2.15.90
Release:		3
Distribution:		Java Desktop System
Vendor:			Sun Microsystems, Inc.
Summary:		Implementation of Desktop Menu Specification for GNOME
Source:			http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.15/%{name}-%{version}.tar.bz2
Patch1:                 gnome-menus-01-alacarte-nodisplay-terminal.diff
Patch2:                 gnome-menus-02-quickstart.diff
Patch3:                 gnome-menus-03-application-submenu-rename.diff
Patch4:                 gnome-menus-04-preferences.diff
URL:			http://www.gnome.org
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
Docdir:			%{_defaultdocdir}/%{name}
Autoreqprov:		on
Prereq:                 /sbin/ldconfig
Prereq:                 GConf

%define gnome_vfs_version 2.8.2
%define pygtk2_version 2.7.0
%define python_version 2.4

Requires: pygtk2 >= %{pygtk2_version}
BuildRequires: pygtk2 >= %{pygtk2_version}
BuildRequires: gnome-vfs >= %{gnome_common_version}
BuildRequires: intltool

%description
This package implements the freedesktop.org desktop menu specification for the GNOME
desktop. Also contained in this package, are the menu layout configuration files, .directory
and assorted menu utility programs.

%package devel
Summary:      Implementation of Desktop Menu Specification for GNOME
Group:        System/Libraries/GNOME
Autoreqprov:  on
Requires:     %name = %version
Requires:     gnome-vfs-devel >= %{gnome_vfs_version}

%description devel
This package implements the freedesktop.org desktop menu specification for the GNOME
desktop. Also contained in this package, are the menu layout configuration files, .directory
and assorted menu utility programs.

%prep
%setup -q
##FIXME: Needs engineer rework: %patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf
./configure --prefix=%{_prefix}			\
	    --sysconfdir=%{_sysconfdir}		\
            --mandir=%{_mandir}
make -j $CPUS \
    pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
    pythondir=%{_libdir}/python%{python_version}/vendor-packages

%install
make DESTDIR=$RPM_BUILD_ROOT install \
    pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
    pythondir=%{_libdir}/python%{python_version}/vendor-packages
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.pyc" -exec rm -f {} ';'
# FIXME: Giga-hack part 1 of 2 follows...
# file /etc/xdg/menus/applications.menu conflicts with desktop-data-SLES
# Only on SuSE Linux !!
%ifos linux
mv $RPM_BUILD_ROOT%{_sysconfdir}/xdg/menus/applications.menu \
   $RPM_BUILD_ROOT%{_sysconfdir}/xdg/menus/applications.menu.new
%endif

%post
/sbin/ldconfig
# FIXME: Giga-hack part 2 of 2 follows...
# file /etc/xdg/menus/applications.menu conflicts with desktop-data-SLES
MENU=/etc/xdg/menus/applications.menu
cp $MENU $MENU.SuSE
cp $MENU.new $MENU

%postun
/sbin/ldconfig

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%{_bindir}/*
%{_libdir}/libgnome-menu.so.*
%{_datadir}/desktop-directories/*
%config %{_sysconfdir}/xdg/menus/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/applications/*.desktop
%{_datadir}/gnome-menus
%{_libdir}/python2.4/

%files devel
%defattr(-, root, root)
%{_libdir}/pkgconfig/*
%{_libdir}/libgnome-menu.so
%{_includedir}/gnome-menus/*

%changelog
* Mon Jul 24 2006 - [email protected]
- Bump to 2.15.90.

* Wed May 03 2006 - [email protected]
- Remove Accessibility submenu from preferences
* Fri Apr 28 2006 - [email protected]
- Add patch to rename some submenus, like
  Universal Access, and Developer Tools.

* Fri Apr 28 2006 - [email protected]
- Add quickstart.menu, along with ability to edit
  in the simple menu editor.

* Fri Apr 21 2006 - [email protected]
- Add alacarte patch which adds exec in terminal
  and no display options needed for the menu editor.

* Thu Apr 13 2006 - [email protected]
- Bump to 2.14.0.

* Fri Jan 21 2006 - [email protected]
- Bump to 2.13.5.

* Thu Oct 27 2005 - [email protected]
- move python stuff from site-packages to vendor-packages

* Sat Sep 17 2005 - [email protected]
- Bump to 2.12.0

* Wed Aug 24 2005 - [email protected]
- remove upstream patch

* Mon Aug 15 2005 - [email protected]
- Bump to 2.11.91.

* Fri May 13 2005 - [email protected]
- Add unisntalled-pc files since they are needed on Solaris to build.

* Tue May 10 2005 - [email protected] 
- Initial spec file for gnome-menus