file-roller.spec
author dc144907
Tue, 03 Jan 2006 09:08:06 +0000
changeset 6464 7f0a1deef016
parent 6299 4b3aea37c890
child 6538 b87bbb060d7a
permissions -rw-r--r--
* librsvg.spec: Bump to 2.13.3. * eel.spec: Bump to 2.13.3. * nautilus.spec: Bump to 2.13.3. * gnopernicus.spec: Bump to 1.0.0. * libmusicbrainz.spec: Bump to 2.1.2. * speex.spec: Bump to 1.1.11.1. * gucharmap.spec: Bump to 1.5.0. * gnome-applets.spec: Bump to 2.13.1. * file-roller.spec: Bump to 2.13.3. * gcalctool.spec: Bump to 5.7.18. * gnome-python.spec: Bump to 2.12.3. * gimp.spec: Bump to 2.3.6.

#
# spec file for package file-roller
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         file-roller
License:      GPL
Group:        System/GUI/GNOME
Version:      2.13.3
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      An archive manager for GNOME
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.13/%{name}-%{version}.tar.bz2
Source1:      file-roller.1.gz
Patch1:       file-roller-01-rm-jar-association.diff
Patch2:       file-roller-02-move-menuitem.diff
Patch3:       file-roller-03-zip-command.diff
Patch4:       file-roller-04-rename-contents.diff

URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}
Autoreqprov:  on
Prereq:       GConf

%define scrollkeeper_version 0.3.14
%define nautilus_version 2.6.1

BuildRequires: scrollkeeper >= %{scrollkeeper_version}
BuildRequires: nautilus-devel >= %{nautilus_version}
Requires: nautilus >= %{nautilus_version}

%description
File Roller is an archive manager for the GNOME environment.  This means that
you can : create and modify archives; view the content of an archive; view a
file contained in the archive; extract files from the archive.
File Roller is only a front-end (a graphical interface) to archiving programs
like tar and zip. The supported file types are -

 * Tar archives uncompressed (.tar) or compressed with
 * gzip (.tar.gz , .tgz)
 * bzip (.tar.bz , .tbz)
 * bzip2 (.tar.bz2 , .tbz2)
 * compress (.tar.Z , .taz)
 * lzop (.tar.lzo , .tzo)
 * Zip archives (.zip)
 * Jar archives (.jar , .ear , .war)
 * Lha archives (.lzh)
 * Rar archives (.rar)
 * Single files compressed with gzip, bzip, bzip2, compress, lzop

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS
autoheader
automake -a -c -f
autoconf

#FIXME: Disable scrollkeeper for now.
CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
    --prefix=%{_prefix} \
    --sysconfdir=%{_sysconfdir} \
    --disable-scrollkeeper
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make DESTDIR=$RPM_BUILD_ROOT install
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/


rm $RPM_BUILD_ROOT%{_libdir}/bonobo/libfile-roller-component.a
rm $RPM_BUILD_ROOT%{_libdir}/bonobo/libfile-roller-component.la
rm $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-1.0/libnautilus-fileroller.a
rm $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-1.0/libnautilus-fileroller.la

%clean
rm -rf $RPM_BUILD_ROOT

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="file-roller.schemas"
 for S in $SCHEMAS; do
  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%files
%defattr(-, root, root)
%doc AUTHORS NEWS README COPYING
%{_sysconfdir}/gconf/schemas/*.schemas
%{_bindir}/file-roller
%{_libdir}/bonobo/libfile-roller-component.so*
%{_libdir}/bonobo/servers/*.server
%{_libdir}/nautilus/extensions-1.0/libnautilus-fileroller.so
%{_datadir}/application-registry/*.applications
%{_datadir}/applications/*.desktop
%{_datadir}/file-roller
%{_datadir}/gnome/help/file-roller
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/mime-info/*
%{_datadir}/omf/file-roller
%{_datadir}/pixmaps/*.png
%{_mandir}/man1/file-roller.1.gz

%changelog
* Tue Jan 03 2006 - [email protected]
- Bump to 2.13.3.

* Tue Nov 29 2005 - [email protected]
- remove javahelp stuff

* Tue Nov 29 2005 - [email protected]
- Bump to 2.12.2.

* Tue Oct 11 2005 - [email protected]
- Bump to 2.12.1

* Sat Sep 17 2005 - [email protected]
- Bump to 2.12.0

* Mon Sep 05 2005 - [email protected]
- Bump to 2.11.92.

* Mon Aug 15 2005 - [email protected]
- Bump to 2.11.91.

* Fri May 20 2005 - [email protected]
- Bump to 2.10.3

* Tue Mar 15 2005 - [email protected]
- add patch for 6238712

* Wed Mar 02 2005 - [email protected]
- Add patch so that renaming archive contents, prompts for an
  overwrite if the file/directory already exists.

* Tue Jan 25 2005 - [email protected]
- Update docs with Linux specific tarball from [email protected].

* Fri Jan 14 2005 - [email protected]
- Updated l10n help tarball for cinnabar-linux
                                                                                
* Thu Oct 28 2004 - [email protected]
- Updated l10n help tarball and added pt_BR

* Mon Oct 18 2004 - [email protected]
- file-roller-09-extract-password.diff added
* Fri Sep 10 2004 - [email protected]
- Added patch file-roller-08-fix-dnd-crash.diff to fix the desktop icon
  dnd crash. Fixes bugtraq #5098546.

* Mon Aug 30 2004 - [email protected]
- Add file-roller-07-g11n-potfiles.diff

* Wed Aug 25 2004 - [email protected]
- Added l10n help contents

* Fri Aug 20 2004 - [email protected]
- Integrate updated docs tarball from [email protected].

* Thu Aug 05 2004 - [email protected]
- Incorporate new docs tarball from [email protected].

* Tue Jul 27 2004 - [email protected]
- Fix the file extraction for .zip/.jar.

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to file-roller-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- ported to rpm4
                                                                                
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Mon Jul 05 2004 - [email protected]
- Added patch file-roller-05-add-folder-option.diff to add the feature of 
  folder addition in an archive.

* Wed Jun 09 2004 - [email protected]
- Modified patch file-roller-04-set-path-gtar.diff to use putenv instead of
  setenv

* Wed Jun 09 2004 - [email protected]
- Added patch file-roller-04-set-path-gtar.diff to /usr/sfw/bin so that
  gtar is picked up instead of tar

* Fri May 28 2004 - [email protected]
- Incorporate new docs tarball from [email protected].

* Fri May 14 2004 - [email protected]
- Don't show the password in plain text (file-roller-03-password-invisible.diff)

* Wed May 12 2004 - [email protected]
- Updated l10n content to file-roller-l10n-po-1.1.tar.bz2

* Tue May 04 2004 - [email protected]
- Bump to 2.6.1

* Tue Apr 27 2004 - [email protected]
- Move the position of "Archive Manager" from "System Tools"
  to "Accessories" in panel menu.

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Tue Apr 13 2004 - [email protected]
- upgraded tarball
* Thu Apr 01 2004 - [email protected]
- javahelp conversion

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to file-roller-l10n-po-1.0.tar.bz2

* Tue Mar 16 2004 - [email protected]
- Remove validation of archive check since the patch is 
  wrong.

* Tue Mar 16 2004 - [email protected]
- Bump to 2.5.7 and remove localized documentation
  tarball as it no longer makes sense. Remove the menu
  patch and l10n patches.

* Wed Feb 25 2004 - [email protected]
- change tar jxvf to bzcat | tar xf - 
- use proper path macros instead of hardcoded paths

* Wed Dec 17 2003 - [email protected]
- Bump to 2.5.4, re-apply patches 01/02
- Add l10n and patch 03
- Add libtoolize/automake etc...

* Wed Dec 17 2003 - [email protected]
- Bump to 2.5.0

* Fri Oct 31 2003 - [email protected]
- Remove the Sun Supported keyword from the 
  desktop file.

* Mon Oct 13 2003 - [email protected]
- tarball upgrade

* Fri Sep 26 2003 - <[email protected]>
- integrate Sun docs

* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la

* Thu Aug 07 2003 - [email protected]
- Update tarball, bump version, reset release.

* Wed Jul 30 2003 - Laszlo [email protected]
- added file-roller-02-validate-new-archive.diff

* Tue May 13 2002 - [email protected]
- initial package for GNOME 2.2