zenity.spec
author dc144907
Mon, 21 Aug 2006 10:48:46 +0000
changeset 7939 8154247887e3
parent 7878 2bb7a2c1914f
child 8006 edfc798053bb
permissions -rw-r--r--
2006-08-21 Damien Carbery <[email protected]> * sound-juicer.spec: Bump to 2.15.5.1. * gnome-nettool.spec: Bump to 2.15.92. * zenity.spec: Bump to 2.15.92. * vte.spec: Bump to 0.13.6. * gnome-utils.spec: Bump to 2.15.93.

#
# spec file for package zenity
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         zenity
License:      LGPL
Group:        System/GUI/GNOME
Version:      2.15.92
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Show graphical dialog boxes from scripts
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.15/%{name}-%{version}.tar.bz2
Source1:      zenity.1.gz
Source2:      gdialog.1.gz
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on

%define gtk2_version 2.3.1
%define libgnomecanvas_version 2.4.0
%define GConf_version 2.4.0.1
%define libglade_version 2.3.1
%define popt_version 1.6.4
%define scrollkeeper_version 0.3.12

Requires:	gtk2 >= %{gtk2_version}
Requires:	libgnomecanvas >= %{libgnomecanvas_version}
Requires:	GConf >= %{GConf_version}
Requires:	libglade >= %{libglade_version}
BuildRequires:  gtk2-devel >= %{gtk2_version}
BuildRequires:  libgnomecanvas-devel >= %{libgnomecanvas_version}
BuildRequires:  GConf-devel >= %{GConf_version}
BuildRequires:  libglade-devel >= %{libglade_version}
BuildRequires:  popt-devel >= %{popt_version}
BuildRequires:  scrollkeeper >= %{scrollkeeper_version}

%description
Show graphical dialog boxes from the commandline or through scripts. Zenity is a 
predecessor to dialog.

%prep
%setup -q

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
intltoolize --copy --force
aclocal $ACLOCAL_FLAGS 
automake -a -c -f
autoconf
CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
	--prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir} \
	--mandir=%{_mandir} \
	--localstatedir=%{_localstatedir} \
	--disable-scrollkeeper
make -j $CPUS

%install
make -i install DESTDIR=$RPM_BUILD_ROOT
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man1
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/


#Remove some scrollkeeper files before packaging
rm -rf $RPM_BUILD_ROOT/%{_prefix}/var

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, root)
%{_bindir}/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/omf/zenity
%{_datadir}/zenity/*
%{_datadir}/gnome/help
%{_mandir}/man1/*

%changelog
* Mon Aug 21 2006 - [email protected]
- Bump to 2.15.92.
* Tue Aug 08 2006 - [email protected]
- Bump to 2.15.91.
* Mon Jul 31 2006 - [email protected]
- Bump to 2.15.90.
* Sun Jul 23 2006 - [email protected]
- Bump to 2.15.2
* Mon Jul 10 2006 - [email protected]
- Bump to 2.14.2.
* Tue Apr 11 2006 - [email protected]
- Bump to 2.14.1.
* Tue Mar 14 2006 - [email protected]
- Bump to 2.14.0.
* Tue Jan 17 2006 - [email protected]
- Bump to 2.13.5
* Mon Jan 16 2006 - [email protected]
- Call intltoolize to build correctly.
* Sun Jan 15 2006 - [email protected]
- Bump to 2.13.4
* Tue Dec 20 2005 - [email protected]
- Bump to 2.13.3
* Tue Nov 29 2005 - laca.com
- remove javahelp stuff
* Tue Oct 11 2005 - [email protected]
- Bump to 2.12.1
* Sat Sep 17 2005 - [email protected]
- Bump to 2.12.0
* Mon Sep 05 2005 - [email protected]
- Bump to 2.11.92.
* Tue Aug 16 2005 - [email protected]
- Bump to 2.11.91.
* Fri Jul 01 2005 - [email protected]
- Add pkgconfig patch
* Wed Jun 08 2005 - [email protected]
- Fix build. remove scrollkeeper files before packageing
* Tue May 25 2005 - [email protected]
- Fix build.
* Thu May 12 2005 - [email protected]
- Bump to 2.10.0
* Thu Mar 31 2005 - [email protected]
- Updated docs tarball (zenity-docs-0.3linux) from [email protected].
* Fri Jan 14 2005 - [email protected]
- Updated l10n help tarball for cinnabar-linux
* Thu Oct 28 2004 - [email protected]
- Updated l10n help tarball and added pt_BR
* Tue Aug 24 2004 - [email protected]
- fixed man page file list issue
* Fri Aug 20 2004 - [email protected]
- Integrated updated docs tarball from [email protected].
* Thu Aug 05 2004 - [email protected]
- Integrated docs tarball from [email protected]
* Thu Jul 08 2004 - [email protected]
- Updated l10n content to zenity-l10n-po-1.2.tar.bz2
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds
* Wed Jun  2 2004 - [email protected]
- Added %SOURCE1 to install l10n messages
* Wed May 12 2004 - [email protected]
- Updated l10n content to zenity-l10n-po-1.1.tar.bz2
* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris
* Thu Apr 01 2004 - [email protected]
- Javahelp conversion
* Mon Mar 29 2004 - [email protected]
- Updated l10n content to zenity-l10n-po-1.0.tar.bz2
* Tue Mar 23 2004 - [email protected]
- Bump to 2.6.0
* Wed Mar 17 2004 - [email protected]
- re-autotoolize to pick up fixed glib-gettext macros needed on Solaris
* Tue Mar 15 2004 - [email protected]
- Remove man page patch since we do this 
  with %files.
* Tue Feb 24 2004 - [email protected]
- Update tarball to 2.5.2
* Wed Dec 17 2003 - [email protected]
- Update tarball to 1.7
* Mon Oct 13 2003 - [email protected]
- Update tarball
* Mon Aug 11 2003 - [email protected]
- Update tarball
* Fri Jul 25 2003 - [email protected]
- Requires scrollkeeper for postinstall. Add a dependency
* Tue Jul 01 2003 - [email protected]
- Initial Sun release