Solaris/SUNWgnome-games.spec
author laca
Mon, 23 Aug 2004 03:26:11 +0000
changeset 3669 83ac9ef5f846
parent 3348 26eb685038fa
child 4122 0c938071234a
permissions -rw-r--r--
2004-08-23 Laszlo Peter <[email protected]> Fixing Solaris integration bug 5090060: * SUNWgnome-a11y-libs.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-base-libs.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-calculator.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-camera.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-cd-burner.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-common-devel.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-component.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-config.spec: fix dependencies: don't depend on -devel pkgs * SUNWgnome-dialog.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-file-mgr.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-games.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-im-client.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-im-switcher.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-img-editor.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-img-viewer.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-libs.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-media-player.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-pdf-viewer.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-print.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-project.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-ps-viewer.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-remote-desktop.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-session.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-sys-suspend.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-terminal.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-text-editor.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-ui-designer.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWgnome-vfs.spec: s/SUNWpl5u/SUNWperl584usr/ * SUNWopenh323.spec: s/SUNWpl5u/SUNWperl584usr/

#
# spec file for package SUNWgnome-games
#
# includes module(s): gnome-games
#
# Copyright (c) 2004 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include Solaris.inc

%define makeinstall make install DESTDIR=$RPM_BUILD_ROOT
%use gnome_games = gnome-games.spec

Name:                    SUNWgnome-games
Summary:                 GNOME Games
Version:                 2.6.0
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
BuildRequires: SUNWgnome-javahelp-convert
# FIXME: Uncomment these lines when branch for Cinnabar/Metropolis.
# BuildRequires: SUNWscpu
# Requires: SUNWscpu
Requires: SUNWgnome-libs
Requires: SUNWgnome-base-libs

%package share
Summary:                 GNOME Games - platform independent files, /usr/share
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: SUNWperl584usr

%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}

%package root
Summary:                 GNOME Games - platform dependent files, / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWgnome-libs

%package devel
Summary:                 GNOME Games - developer files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc

%prep
rm -rf %name-%version
mkdir %name-%version
%gnome_games.prep -d %name-%version

%build
export PKG_CONFIG_PATH=%{_pkg_config_path}
export MSGFMT="/usr/bin/msgfmt"
export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
export PERL5LIB=%{_prefix}/perl5/site_perl/5.6.1/sun4-solaris-64int
export CFLAGS="%optflags -I%{_includedir}"
export RPM_OPT_FLAGS="$CFLAGS"

%gnome_games.build -d %name-%version

%install
%gnome_games.install -d %name-%version
export GCONF_CONFIG_SOURCE=xml::$RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults
for S in $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas/*.schemas; do
  %{_bindir}/gconftool-2 --makefile-install-rule $S >/dev/null
done
chmod -R a+rX $RPM_BUILD_ROOT/%{_sysconfdir}

for f in apps/?gconf.xml \
         schemas/?gconf.xml \
         schemas/apps/?gconf.xml \
    ; do
  test ! -s $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/$f && \
    rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/$f
done

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, other)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*.so*
%{_libdir}/gnome-stones/objects/lib*.so*
%{_libexecdir}/gnome-poetry

%files share
%defattr (-, root, other)
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/applications
%{_datadir}/gnect
%{_datadir}/gnibbles
%{_datadir}/gnobots2
%{_datadir}/gnome-stones
%{_datadir}/gnome/help/*/C
%{_datadir}/gnome/javahelp/*/C
%{_datadir}/mime-info
%{_datadir}/omf/*/*-C.omf
%{_datadir}/pixmaps
%{_datadir}/sounds
%{_datadir}/gnome-stonesrc

%files l10n
%defattr (-, root, other)
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/locale

%files root
%attr(0755, root, sys) %dir %{_sysconfdir}
%defattr (-, root, other)
%{_sysconfdir}/sound
%{_sysconfdir}/gconf
%defattr(0755, root, sys)

%files devel
%defattr (-, root, other)
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/gdkcardimage

%changelog
* Mon Aug 23 2004 - [email protected]
- s/SUNWpl5u/SUNWperl584usr/
* Sat Jun 26 2004  [email protected]
- Changed install location to /usr/...
* Wed Jun  2 2004 - [email protected]
- Added %{_datadir}/locale to install l10n messages
* Thu May 27 2004 - [email protected]
- Comment out SUNWcspu lines. Will uncomment when Metropolis branch created.
* Wed May 26 2004 - [email protected]
- Add SUNWcspu (with libucb.so and scandir) to Requires and BuildRequires.
  configure was breaking because of its absense.
* Mon May 10 2004 - [email protected]
- Putting back %{_sysconfig}/gconf into packaging which got 
  accidently simplified away in Laca's last change.  Now the
  games work again.
* Tue Apr 20 2004 - [email protected]
- simlify %files
- add javahelp
* Thu Apr 08 2004 - [email protected]
- added missing %defattr
* Fri Mar 26 2004 - [email protected]
- Created,