base-specs/libgnomeui.spec
author dcarbery
Tue, 06 Mar 2007 14:26:40 +0000
changeset 9457 8a53f65d1f5b
parent 9400 f3c0f4f1c2ee
child 9522 eee0e85e99af
permissions -rw-r--r--
2007-03-06 Damien Carbery <[email protected]> * base-specs/tango-icon-theme.spec: Bump to 0.8.0. * base-specs/icon-naming-utils.spec: Bump to 0.8.2. * base-specs/evolution-webcal.spec: Bump to 2.9.92. * base-specs/libwnck.spec, base-specs/gnome-desktop.spec, base-specs/libgnomeui.spec, base-specs/file-roller.spec, base-specs/libgnomeprint.spec, base-specs/libgnomeprintui.spec, base-specs/eog.spec, base-specs/zenity.spec: Bump to 2.17.92. * base-specs/libIDL.spec: Bump to 0.8.8. * base-specs/bug-buddy.spec: Bump to 2.17.4. * base-specs/ORBit2.spec: Bump to 2.14.7.

#
# spec file for package libgnomeui 
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: alo
#
Name:         libgnomeui 
License:      LGPL
Group:        System/Libraries/GNOME
Version:      2.17.92
Release:      3
Distribution: Java Desktop System
Vendor:	      Sun Microsystems, Inc.
Summary:      GNOME User Interface Library  
Source:       http://ftp.gnome.org/pub/GNOME/sources/libgnomeui/2.17/libgnomeui-%{version}.tar.bz2
# date:2004-10-28 bugzilla:129668 owner:padraig type:bug
Patch1:       libgnomeui-01-icon-a11y.diff
# date:2006-09-14 bugster:6463604 owner:harrylu type:branding
Patch2:       libgnomeui-02-crash-no-bugbuddy.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define gtk_doc_version 1.1
%define gtk2_version 2.4.0
%define gail_version 1.5.7
%define libbonoboui_version 2.6.0
%define libglade_version 2.3.6
%define libbonobo_version 2.6.0
%define libgnome_version 2.6.0
%define gnome_keyring_version 0.2.0

Requires: gtk2 >= %{gtk2_version}
Requires: libbonoboui >= %{libbonoboui_version}
Requires: libglade >= %{libglade_version}
Requires: gnome-keyring >= %{gnome_keyring_version}
Requires: gail >= %{gail_version}
BuildRequires: gtk2-devel >= %{gtk2_version}
BuildRequires: libbonoboui-devel >= %{libbonoboui_version}
BuildRequires: libglade-devel >= %{libglade_version}
BuildRequires: gnome-keyring-devel >= %{gnome_keyring_version}
BuildRequires: gail-devel >= %{gail_version}
BuildRequires: gtk-doc >= %{gtk_doc_version}

%description
libgnomeui is the GNOME User Interface Library, containing many widgets and 
convenient API used to developer GNOME applications that is not in GTK+ 
eg. About Dialog, Session Manager support

%package devel
Summary:      GNOME User Interface Development Library
Group:        Development/Libraries/GNOME
Requires:     %{name} = %{version}
Requires:     libgnome-devel >= %{libgnome_version}
Requires:     libbonoboui-devel >= %{libbonoboui_version}

%description devel
libgnomeui is the GNOME User Interface Library, containing many widgets and 
convenient API used to developer GNOME applications that is not in GTK+ 
eg. About Dialog, Session Manager support

%prep
%setup -q
%patch1 -p1
%patch2 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS -I .
autoconf
autoheader
automake -a -c -f

CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}		\
	    --datadir=%{_datadir}       \
	    --sysconfdir=%{_sysconfdir}	\
	    --mandir=%{_mandir}		\
	    --libexecdir=%{_libexecdir}	\
	    %{gtk_doc_option}
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
rm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/filesystems/*.a
rm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/filesystems/*.la
rm $RPM_BUILD_ROOT%{_libdir}/libglade/*/*.a
rm $RPM_BUILD_ROOT%{_libdir}/libglade/*/*.la
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la


%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%{_datadir}/locale/*/LC_MESSAGES/libgnomeui-2.0.mo
%{_datadir}/pixmaps/*.png
%{_libexecdir}/*
%{_libdir}/libglade/2.0/libgnome*so*
%{_libdir}/lib*.so.*
%{_libdir}/gtk-2.0/2.4.0/filesystems/*.so

%files devel
%{_libdir}/pkgconfig/*.pc
%{_includedir}/libgnomeui-2.0/libgnomeui/*.h
%{_includedir}/libgnomeui-2.0/*.h
%{_libdir}/lib*.so
%{_datadir}/gtk-doc/html/libgnomeui
%{_mandir}/man3/*

%changelog
* Tue Mar 06 2005 - [email protected]
- Bump to 2.17.92.
* Tue Feb 13 2007 - [email protected]
- Bump to 2.17.91.
* Mon Jan 22 2007 - [email protected]
- Bump to 2.17.90.
* Tue Jan 09 2007 - [email protected]
- Bump to 2.17.1.
* Thu Dec 07 2006 - [email protected]
- Bump to 2.17.0. Change patch2 to -p1 while reworking the patch contents.
* Fri Nov  3 2006 - [email protected]
- use %gtk_doc_option in configure so that it can be disabled using
  --without-gtk-doc
* Thu Oct 05 2006 - [email protected]
- Bump to 2.16.1. Remove upstream patch, 03-hang-on-mutex.
* Wed Sep 27 2006 - [email protected]
- Add libgnomeui-03-hang-on-mutex.diff to fix 6475663.
* Wed Sep 13 2006 - [email protected]
- Add libgnomeui-02-crash-no-bugbuddy.diff to fix 6463604.
* Mon Sep 04 2006 - [email protected]
- Bump to 2.16.0.
- Remove upstream patch, 02-hidden.
* Tue Aug 08 2006 - [email protected]
- Bump to 2.15.91.
* Mon Jul 24 2006 - [email protected]
- Bump to 2.15.90.
* Fri Jul 21 2006 - [email protected]
- Bump to 2.15.2.
* Mon May 29 2006 - [email protected]
- Add patch, 02-hidden, to remove G_GNUC_INTERNAL to build.
* Tue Apr 11 2006 - [email protected]
- Bump to 2.14.1.
* Mon Mar 13 2006 - [email protected]
- Bump to 2.14.0.
* Tue Feb 28 2006 - [email protected]
- Bump to 2.13.90.
* Thu Jan 26 2006 - [email protected]
- Bump to 2.13.3
* Tue Jan 17 2006 - [email protected]
- Bump to 2.13.2
* Wed Dec 21 2005 - [email protected]
- Bump to 2.13.0
* Thu Sep 15 2005 - [email protected]
- Bump to 2.12.0
* Wed Aug 24 2005 - [email protected]
- merge/remove patches
* Mon Aug 15 2005 - [email protected]
- Bump to 2.11.2.
* Wed Aug 03 2005 - [email protected]
- remove upstream patch (cancel-rename.diff)
* Wed Jun 15 2005 - [email protected]
- Add more libs to LDADD so that it builds with the new pkgconfig
* Fri May 13 2005 - [email protected]
- Added patch libgnomeui-10-cancel-rename.diff, fixes
  nautilus crash for rename operation in smb.
  Fixes bug#6264644.
* Fri May 06 2005 - [email protected]
- Bump to 2.10.0
* Wed Mar 16 2005 - [email protected]
- Added patch libgnomeui-09-disconnect-close.diff. Don't connect the close
  signal in the authentication dialog. Fixes bug #6237403
* Thu Dec 23 2004 - [email protected]
- Added libgnomeui-08-disable-crash-dialog.diff to make
  --disable-crash-dialog option work. Fixes bug #6210518.
* Fri Dec 17 2004 - [email protected]
- Bump to 2.6.2, so that we pick up a bunch of file chooser
  fixes.
* Fri Nov 12 2004 - [email protected]
- Add patch libgnomeui-08-a11y-children.diff. Fixes bug #5080627
* Fri Nov 5 2004 - [email protected]
- Added patch libgnomeui-07-sftp.diff.
  Fixes bug# 5088520
* Thu Oct 28 2004 - [email protected]
- Modified patch libgnomeui-06 so that the selected icon have 
  SPI_STATE_FOCUSED
* Tue Oct 19 2004 - [email protected]
- Added patch libgnomeui-06 to make the icon list accessible.
* Tue Oct 5 2004 - [email protected]
- Added patch libgnomeui-05-file-chooser.diff to
  canonicalize the URI before looking it up in the 
  folder's hash table. Fixes Bug #5103163.
* Tue Sep 14 2004 - [email protected]
- Added patch libgnomeui-04-druid-theming.diff to make
  'Add a printer' dialog theme compliant.
  Fixes bug #5035846.
* Wed Aug 18 2004 - [email protected]
- added --enable-gtk-doc
* Wed Jul 28 2004 - [email protected]
- Bump to 2.6.1.1
* Wed Jul 28 2004 - [email protected]
- Add patch to unfocus the widgets on the previous page
  of the GnomeDruid widget. Patch from Eric Zhao.
* Thu Jul 08 2004 - [email protected]
- Updated l10n content to libgnomeui-l10n-po-1.2.tar.bz2
* Thu Jul 08 2004 - [email protected]
- ported to rpm4
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds
* Thu Jun 24 2004 - [email protected]
- Updated libgnomeui-01-g11n-i18n-ui.diff to i18n Filesystem in gtkdialog.
  bugzilla #144529
* Thu Jun 17 2004 - [email protected]
- Added libgnomeui-03-mount-crashed-gedit.diff. The patch is taken from
  HEAD (also included in 2.6.1.1 tarball release). bugzilla id#139063.
  Bugtraq id 5055273. Since we are at Beta, so have to keep this patch
  for the time being and uprev after Beta, this patch can then be removed.
* Tue May 25 2004 - [email protected]
- Added libgnomeui-02-g11n-potfiles.diff
* Wed May 12 2004 - [email protected]
- Updated l10n content to libgnomeui-l10n-po-1.1.tar.bz2
* Wed May 05 2004 - [email protected]
- Add missing gtk file selector plug-in to %files.
  Add gtk2 to requirements
* Wed May 04 2004 - [email protected]
- Remove auth manager patch, it was wrong and rejected in
  bugzilla.
* Mon Mar 29 2004 - [email protected]
- Updated l10n content to libgnomeui-l10n-po-1.0.tar.bz2
* Mon Mar 22 2004 - [email protected]
- Added libgnomeui-02-g11n-i18n-ui.diff to fix 4995208
* Mon Mar 22 2004 - [email protected]
- Bump to 2.6.0 and remove broken file entry patch that doesn't
  fix anything.
* Sun Feb 15 2004 - [email protected]
- Add --libexecdir to the configure options so we get the correct path
  on Solaris
* Mon Feb 02 2004 - [email protected]
- Bump to 2.5.3
- Add ACLOCAL_FLAGS env to aclocal invocation
* Thu Jan 08 2004 - [email protected]
- Update to 2.5.2 to make nautilus build
* Mon Dec 15 2003 - [email protected]
- Update to 2.5.1
* Mon Oct 13 2003 - [email protected]
- added auth manager patch (moved from nautilus)
* Thu Oct 09 2003 - [email protected]
- Updated for 2.4
* Thu Sep 25 2003 - [email protected]
- Fix icon theming for icons with full paths
* Thu Aug 14 2003 - <[email protected]>
- move lib*.so to -devel, remove *.a, *.la
* Thu Aug 07 2003 - [email protected]
- Remove the evil activate signal on file entry 
  browse ok button callback. Stops browse dialog
  being displayed twice, when user selects stuff.
* Thu Aug 07 2003 - [email protected]
- Update tarball, bump version, reset release.
* Thu Jul 10 2003 - [email protected]
- Added .po tarball
* Tue May 13 2003 - [email protected]
- Initial Sun release.