SUNWgnome-cd-burner.spec
author laca
Sat, 29 Sep 2007 04:38:49 +0000
changeset 10572 8cdee8cd9c9c
parent 9397 b16e349d18c5
child 10962 1d37f46aa3ac
child 11370 338c15c66cee
permissions -rw-r--r--
2007-09-29 Laszlo (Laca) Peter <[email protected]> More indiana build changes * SUNWPython.spec: add option to build with FOX X libs * SUNWbrltty.spec: add option to build with FOX instead of Nevada X * SUNWdbus-bindings.spec: convert to new style multi-ISA build; delete SUNWxwrtl dep * SUNWdbus.spec: convert to new style multi-ISA build; delete SUNWxwrtl dep * SUNWfirefox.spec: delete Nevada X deps; disable developer guide dep if sun branding is not requested * SUNWgnome-a11y-dasher.spec: delete Nevada X deps; delete some unneeded env vars * SUNWgnome-a11y-libs.spec: disable java access bridge if build without java support * SUNWgnome-a11y-speech.spec: disable packaging java stuff if the --without-java option is used * SUNWgnome-applets.spec: delete Nevada X deps; make xorg-xkb dep dependent upon nevada X build * SUNWgnome-config.spec: convert to new style multi-ISA build * SUNWgnome-desktop-prefs.spec: add support to build on FOX instead of Nevada X; disable emacs support * SUNWgnome-dialog.spec: delete Nevada X dep * SUNWgnome-file-mgr.spec: delete Nevada X dep * SUNWgnome-img-editor.spec: delete Nevada X dep * SUNWgnome-img-organizer.spec: delete Nevada X dep * SUNWgnome-img-viewer.spec: delete Nevada X dep * SUNWgnome-libs.spec: delete Nevada X dep * SUNWgnome-media-mp3.spec: delete some unneeded env vars * SUNWgnome-media.spec: delete SUNWxwrtl dep * SUNWgnome-panel.spec: delete Nevada X deps; make xorg-xkb dep dependent upon nevada X build; delete some unneeded env vars * SUNWgnome-python-libs.spec: delete some unnecessary env vars * SUNWgnome-remote-desktop.spec: disable building the java client when --without-java is used; delete unneeded env variables * SUNWgnome-session.spec: delete Nevada X deps; delete some unneeded env vars * SUNWgnome-terminal.spec: delete Nevada X deps; delete some unneeded env vars * SUNWgnome-themes.spec: disable building blueprint when the --without-blueprint option is used; disable building sun-gdm-themes when --with-sun-branding is not used * SUNWgnome-utils.spec: delete Nevada X deps; delete some unneeded env vars * SUNWlibrsvg.spec: delete Nevada X dep * SUNWprint-monitor.spec: delete SUNWxwrtl dependency, twice... * base-specs/GConf.spec: convert to new style multi-ISA build * base-specs/ORBit2.spec: convert to new style multi-ISA build * base-specs/dbus-glib.spec: convert to new style multi-ISA build * base-specs/dbus-python.spec: convert to new style multi-ISA build * base-specs/dbus.spec: convert to new style multi-ISA build * base-specs/firefox.spec: do not add developer guide bookmark when sun branding is not requested * base-specs/glib2.spec: add support for building with GNU libiconv * base-specs/gnome-backgrounds.spec: do not install sun branded desktop wallpapers when sun branding is not requested * base-specs/gnome-desktop.spec: disable the jds branding patch when jds branding is not requested * base-specs/gnome-icon-theme.spec: do not install sun java icon when sun branding is not requested * base-specs/gnome-speech.spec: disable java stuff if the --without-java option is used * base-specs/libIDL.spec: convert to new style multi-ISA build * base-specs/libbonobo.spec: convert to new style multi-ISA build * base-specs/metacity.spec: disable tjds patch when tjds support is not requested * cron-script.sh: add --with-sun-branding option

#
# spec file for package SUNWgnome-cd-burner
#
# includes module(s): gnome-cd-burner
#
# Copyright 2007 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: stephen
#
%include Solaris.inc

%define makeinstall make install DESTDIR=$RPM_BUILD_ROOT
%use cd_burner = nautilus-cd-burner.spec

Name:                    SUNWgnome-cd-burner
Summary:                 GNOME CD burner
Version:                 %{default_pkg_version}
Source:                  %{name}-manpages-0.1.tar.gz
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWgnome-libs
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-file-mgr
Requires: %name-root
Requires: SUNWgnome-config
Requires: SUNWgnome-vfs
Requires: SUNWlibC
Requires: SUNWlibms
Requires: SUNWlibmsr
Requires: SUNWmlib
Requires: SUNWhal
BuildRequires: SUNWgnome-libs-devel
BuildRequires: SUNWgnome-base-libs-devel
BuildRequires: SUNWgnome-file-mgr-devel
BuildRequires: SUNWgnome-config-devel
BuildRequires: SUNWgnome-vfs-devel

%package root
Summary:                 %{summary} - / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWgnome-libs
Requires: SUNWpostrun-root
Requires: SUNWgnome-config

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: %name

%prep
rm -rf %name-%version
mkdir %name-%version
%cd_burner.prep -d %name-%version
cd %{_builddir}/%name-%version
gzcat %SOURCE0 | tar xf -

%build
export PKG_CONFIG_PATH=%{_pkg_config_path}
export CFLAGS="%optflags -I%{_includedir}"
export RPM_OPT_FLAGS="$CFLAGS"
%if %cc_is_gcc
%else
export CXX="${CXX} -norunpath"
%endif
export CXXFLAGS="%cxx_optflags -lCrun"
export LDFLAGS="%_ldflags"

%cd_burner.build -d %name-%version

%install
%cd_burner.install -d %name-%version
chmod -R a+rX $RPM_BUILD_ROOT/%{_sysconfdir}
rm -rf $RPM_BUILD_ROOT%{_mandir}
cd %{_builddir}/%name-%version/sun-manpages
make install DESTDIR=$RPM_BUILD_ROOT
# Remove .la files. There are no .a files installed
rm $RPM_BUILD_ROOT%{_libdir}/*.la

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%post root
( echo 'test -x /usr/bin/gconftool-2 || {';
  echo '  echo "ERROR: gconftool-2 not found"';
  echo '  exit 1';
  echo '}';
  echo 'umask 0022';
  echo 'GCONF_CONFIG_SOURCE=xml:merged:/etc/gconf/gconf.xml.defaults';
  echo 'export GCONF_CONFIG_SOURCE';
  echo '/usr/bin/gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/*.schemas'
) | $BASEDIR/var/lib/postrun/postrun -u -c JDS_wait

%preun root
test -x $BASEDIR/var/lib/postrun/postrun || exit 0
( echo 'test -x $PKG_INSTALL_ROOT/usr/bin/gconftool-2 || {';
  echo '  echo "WARNING: gconftool-2 not found; not uninstalling gconf schemas"';
  echo '  exit 0';
  echo '}';
  echo 'umask 0022';
  echo 'GCONF_CONFIG_SOURCE=xml:merged:$BASEDIR/etc/gconf/gconf.xml.defaults';
  echo 'GCONF_BACKEND_DIR=$PKG_INSTALL_ROOT/usr/lib/GConf/2';
  echo 'LD_LIBRARY_PATH=$PKG_INSTALL_ROOT/usr/lib';
  echo 'export GCONF_CONFIG_SOURCE GCONF_BACKEND_DIR LD_LIBRARY_PATH';
  echo 'SDIR=$BASEDIR%{_sysconfdir}/gconf/schemas';
  echo 'schemas="$SDIR/nautilus-cd-burner.schemas"';
  echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $schemas'
) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/gnome-vfs-2.0/modules/lib*.so*
%{_libdir}/nautilus/extensions-1.0/lib*.so*
%{_libdir}/lib*.so*
%{_libexecdir}/mapping-daemon
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/nautilus-cd-burner
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/nautilus-cd-burner.desktop
%{_datadir}/applications/nautilus-cd-burner-open-iso.desktop
%attr (-, root, other) %{_datadir}/icons
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*

%files root
%defattr (-, root, sys)
%dir %attr(0755, root, sys) %{_sysconfdir}
%{_sysconfdir}/gconf/schemas/nautilus-cd-burner.schemas
%dir %{_sysconfdir}/gnome-vfs-2.0
%{_sysconfdir}/gnome-vfs-2.0/modules

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%endif

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*

%changelog
* Fri Dec 15 2006 - [email protected]
- Added l10n package. Fixes 6314057.
* Fri Oct 20 2006 - [email protected]
- Remove SUNWhalh BuildRequires because header files are in SUNWhea in snv_51.
* Mon Oct 16 2006 - [email protected]
- Remove the '-rf' from the 'rm *.la *.a' lines so that any changes to the
  module source will be seen as a build error and action can be taken.
* Mon Sep 18 2006 - [email protected]
- Add SUNWhalh BuildRequires.
* Fri Sep 01 2006 - [email protected]
- New Manpage tarball
* Wed Aug 16 2006 - [email protected]
- Change 'icons' line in %files to pick up files.
* Sat Aug 12 2006 - [email protected]
- delete some unnecessary env variables
* Sat Aug 12 2006 - [email protected]
- change datadir/icons permissions back to root:other since it's a stable
  interface and wasn't supposed to be changed
* Fri Aug 11 2006 - [email protected]
- Change SUNWhal-devel ref to SUNWhal as the former does not exist.
* Tue Aug 08 2006 - [email protected]
- Add BuildRequires SUNWhal/-devel after check-deps.pl run.
* Wed Thu 26 2006 - [email protected]
- Update pkging for new tarball, including removing l10n package as no files 
  installed there.
* Fri Jul 14 2006 - [email protected]
- update %post/%postun/etc scripts to support diskless client setup,
  part of 6448317
* Thu Jun 29 2006 - [email protected]
- update postrun scripts
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Thu May 25 2006 - [email protected]
- use post/preun scripts to install schemas into the merged gconf files
* Wed May 10 2006 - [email protected]
- merge -share pkg(s) into the base pkg(s)
* Mon Feb 20 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Sun Jan 22 2006 - [email protected]
- Add nautilus-cd-burner.desktop.
* Fri Sep 30 2005 - [email protected]
- Delete empty %gconf.xml files. Remove .la files.
* Mon Jul 11 2005 - [email protected]
- update CXXFLAGS
- added devel subpkg
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Thu Sep 09 2004 - [email protected]
- Added nautilus-cd-burner.1 manpage
* Mon Aug 23 2004 - [email protected]
- s/SUNWpl5u/SUNWperl584usr/
* Sat Jun 26 2004  [email protected]
- Changed install location to /usr/...
* Wed Jun 23 2004 - [email protected]
- Remove 'devel' package because no files assigned to it.
* Wed Jun  2 2004 - [email protected]
- Added %{_datadir}/locale to install l10n messages
* Tue May 11 2004 - [email protected]
- add SUNWgnome-file-mgr dependency
* Mon May 03 2004 - [email protected]
- fix directory permissions
* Thu Apr 15 2004 - [email protected]
- Created