gnome-system-tools.spec
author dc144907
Mon, 15 Aug 2005 17:10:52 +0000
changeset 5529 9133a916e53a
parent 5518 235b0b4aa324
child 6016 b54189f766bc
permissions -rw-r--r--
* *.spec: More bumping to latest versions for 2.11 work.

#
# spec file for package gnome-system-tools
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

Name:		gnome-system-tools
License:	GPL
Group:		System/GUI/GNOME
Version:	1.3.2
Release:	1
Distribution:	Java Desktop System
Vendor:		Sun Microsystems, Inc.
Summary:	GNOME System Tools
Source:		http://ftp.gnome.org/pub/GNOME/sources/%{name}/1.3/%{name}-%{version}.tar.bz2
URL:		http://www.gnome.org
BuildRoot:	%{_tmppath}/%{name}-%{version}-build
Docdir:		%{_defaultdocdir}/%{name}
Autoreqprov:	on
Prereq:         GConf

%define libgnomeui_version 2.9.0
%define GConf_version 2.2.0
%define system_tools_backends_version 1.2.0
%define nautilus_version 2.9.3

Requires:	libgnomeui >= %{libgnomeui_version}
Requires:	GConf >= %{GConf_version}
Requires:	system-tools-backends >= %{system_tools_backends_version}
Requires:	nautilus >= %{nautilus_version}
BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}
BuildRequires:  GConf-devel >= %{GConf_version}
BuildRequires:	system-tools-backends >= %{system_tools_backends_version}
BuildRequires:	nautilus-devel >= %{nautilus_version}
BuildRequires:  intltool

%description
These tools are intended to simplify the tasks of configuring a Unix system
for workstations. They are not intended for configuring Unix servers.

Configuring different Unix systems is different; every Unix system has
different ways of being administrated. The GNOME System Tools aspire to
unify these systems.

Each one of the GNOME System Tools is split in two parts: a backend (which
is typically written in Perl) and a user interface frontend (which is
typically written in C or Python).

The backends are written in a way that should allow us to quickly adapt
them to various different flavors of Unix; the backend probes your system
and parses the existing system files. When the user has finished editing
the system settings, the configuration is written back as patches to the
system files.

This means that the GNOME System Tools use whatever configuration files are
available on your system, and you can still edit those files by hand or
with other configuration tools without conflicts or data loss.

%prep
%setup -q


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
	--prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir} \
	--mandir=%{_mandir}
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make -i install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
rm $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-1.0/libnautilus-gst-shares.la
rm $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-1.0/libnautilus-gst-shares.a

%clean
rm -rf $RPM_BUILD_ROOT

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="gnome-system-tools.schemas"
for S in $SCHEMAS; do
        gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%files
%defattr (-, root, root)
%{_bindir}/*
%{_libdir}/nautilus/extensions-1.0/libnautilus-gst-shares.so
%{_libdir}/pkgconfig/
%{_datadir}/applications/
%{_datadir}/gnome-system-tools/
%{_datadir}/gnome/help/
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/omf/
%{_sysconfdir}/gconf/schemas/*

%changelog
* Mon Aug 15 2005 - [email protected]
- Bump to 1.3.2.

* Tue May 24 2005 - [email protected]
- Initial spec