apoc-config.spec
author dermotm
Mon, 06 Sep 2004 10:13:24 +0000
changeset 3858 a0a00bd9bb27
parent 3856 6197938f0c07
child 4002 a095b252e7ea
permissions -rwxr-xr-x
Incremented release numbers for build 18

#
# Copyright (c) 2004 Sun Microsystems Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%define t_suffix -build18
%{?nightly:%define t_suffix -%(TZ=GMT date +%Y%m%d)}
%define PLATFORM unxlngi5

Name:           apoc-config
Group:          Applications/Internet 
Version:        1.1
Release:        20
Distribution:   Cinnabar
Vendor:         Sun Microsystems Inc.
License:        Sun Microsystems Binary Code License (BCL)
URL:            http://staroffice-doc.germany.sun.com/Projects/Apoc
Autoreqprov:    on
Packager:       Klaus Ruehl <[email protected]>
Summary:        Configuration wizard for APOC daemon
Requires:		apoc
BuildRoot:      %{_builddir}/apoc/%{PLATFORM}/class/apocd_configuration_pkg
Source:		apoc-cb%{t_suffix}.tar.bz2
BuildRequires:	ant

%description 
Configuration wizard for APOC daemon
Property of Sun Microsystems Inc., 2004

%post
if [ ! -r /usr/bin/apoc-config ]; then
   ln -s /usr/bin/consolehelper /usr/bin/apoc-config
fi
echo
echo "Use the '"apoc-config"' script to startup the wizard."
echo "The script can be found at '"/usr/bin"'."
echo

%postun
if [ $1 = 0 ]; then
   rm /usr/bin/apoc-config
fi

%files 
%attr(0644,root,root) /etc/X11/sysconfig/apoc.desktop
%attr(0644,root,root) /etc/security/console.apps/apoc-config
%attr(0755,root,root) /etc/pam.d/apoc-config
%attr(0755,root,root) /usr/sbin/apoc-config
%defattr(0755, root, root)
/usr/share/lib/apoc/ConfigurationWizard.class
/usr/share/lib/apoc/com

%prep
%setup -n apoc

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

export JAVA_HOME=/usr/java/j2sdk1.4.2_05
export PATH=${JAVA_HOME}/bin:$PATH
make -j $CPUS PLATFORM=%{PLATFORM} %{name}

%clean
rm -rf $RPM_BUILD_ROOT

%changelog
* Mon Sep 06 2004 - [email protected]
- new tarball for build 18

* Wed Sep 01 2004 - [email protected]
- new tarball for build 17b

* Fri Jul 23 2004 - [email protected]
- adapted source tarball name for build 15

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Tue Jul 06 2004 - [email protected]
- Change to use nightly tarballs.