control-center.spec
author dermotm
Mon, 06 Sep 2004 10:13:24 +0000
changeset 3858 a0a00bd9bb27
parent 3846 9ab79af72b15
child 3895 caf5571f7b66
permissions -rw-r--r--
Incremented release numbers for build 18

Name:         control-center
License:      GPL
Group:        System/GUI/GNOME
Version:      2.6.1
Release:      28
Distribution: Cinnabar
Vendor:       Sun Microsystems, Inc.
Summary:      The GNOME control center for GNOME 2.6
Source:       http://ftp.gnome.org/pub/GNOME/sources/control-center/2.6/control-center-%{version}.tar.bz2
Source1:      control-center-l10n-po-1.3.tar.bz2
Source2:      gnome-accessibility-keyboard-properties.1.gz
Source3:      gnome-background-properties.1.gz
Source4:      gnome-control-center.1.gz
Source5:      gnome-default-applications-properties.1.gz
Source6:      gnome-file-types-properties.1.gz
Source7:      gnome-keybinding-properties.1.gz
Source8:      gnome-keyboard-properties.1.gz
Source9:      gnome-mouse-properties.1.gz
Source10:     gnome-network-preferences.1.gz
Source11:     gnome-font-properties.1.gz
Source12:     gnome-settings-daemon.1.gz
Source13:     gnome-sound-properties.1.gz
Source14:     gnome-ui-properties.1.gz
Source15:     gnome-desktop-prefs.1.gz
Source16:     gnome-theme-manager.1.gz
Source17:     gnome-window-properties.1.gz
Source18:     backgrounds.xml
Patch1:       control-center-01-menu-icon-reorder.diff
Patch2:       control-center-02-keybindings-close.diff
Patch3:	      control-center-03-help-links.diff
Patch4:       control-center-04-ctrl-alt-del.diff
Patch5:       control-center-05-solaris-forte-build.diff
Patch6:       control-center-06-g11n-schemas.diff
Patch7:       control-center-07-g11n-potfiles.diff
Patch8:       control-center-08-application-browser.diff
Patch9:       control-center-09-fontview-performance.diff
Patch10:      control-center-10-file-types-hang.diff
Patch11:      control-center-11-accessible-names.diff
Patch12:      control-center-12-gsd-not-session-managed.diff
Patch13:      control-center-13-customize-system-bell.diff
Patch14:      control-center-14-keyboard-layout.diff
Patch15:      control-center-15-add-wallpaper-dialog.diff
Patch16:      control-center-16-solaris-tar-command.diff

URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/control-center2
Autoreqprov:  on
Prereq:       /sbin/ldconfig
Prereq:       scrollkeeper

%define libgnomeui_version 2.6.0
%define esound_version 0.2.33
%define gnome_desktop_version 2.6.1
%define metacity_version 2.8.0
%define nautilus_version 2.6.1
%define fontilus_version 2.4.0
%define libxklavier_version 1.0.2

BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: esound-devel >= %{esound_version}
BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
BuildRequires: metacity >= %{metacity_version}
BuildRequires: nautilus-devel >= %{nautilus_version}
BuildRequires: libxklavier-devel >= %{libxklavier_version}

Requires: libgnomeui >= %{libgnomeui_version}
Requires: esound >= %{esound_version}
Requires: gnome-desktop >= %{gnome_desktop_version}
Requires: nautilus >= %{nautilus_version}
Requires: libxklavier >= %{libxklavier_version}

Obsoletes:      fontilus < %{fontilus_version}
Provides:       fontilus = %{fontilus_version}

%description
This package contains the new control-center for the GNOME desktop.

%package devel
Summary:       Development files for the GNOME control center for GNOME 2.6
Group:         Development/Libraries/GNOME
Requires:      %name = %version-%release

%description devel
This package contains the files need for development of GNOME control center capplets

%prep
%setup -q
bzcat %SOURCE1 | tar xvf -
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
%patch11 -p1
%patch12 -p1
%patch13 -p1
%patch14 -p1
%patch15 -p1
%ifos solaris
%patch16 -p1
%endif

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

LC_ALL=
LANG=
export LC_ALL LANG
libtoolize --force
aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros -I .
autoheader
automake -a -c -f
autoconf
CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
    --prefix=%{_prefix} \
    --libexecdir=%{_libexecdir} \
    --sysconfdir=%{_sysconfdir}
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make DESTDIR=$RPM_BUILD_ROOT install
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL       
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE4 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE5 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE6 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE7 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE8 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE9 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE10 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE11 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE12 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE13 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE14 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE15 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE16 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE17 $RPM_BUILD_ROOT%{_mandir}/man1
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
rm $RPM_BUILD_ROOT%{_libdir}/bonobo/*.a
rm $RPM_BUILD_ROOT%{_libdir}/bonobo/*.la
rm $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/*.a
rm $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/*.la
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la
rm $RPM_BUILD_ROOT%{_libdir}/window-manager-settings/*.a
rm $RPM_BUILD_ROOT%{_libdir}/window-manager-settings/*.la
                                                                               
cp %SOURCE18 $RPM_BUILD_ROOT%{_datadir}/gnome-background-properties

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig
scrollkeeper-update -q
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="apps_gnome_settings_daemon_default_editor.schemas apps_gnome_settings_daemon_screensaver.schemas desktop_gnome_font_rendering.schemas desktop_gnome_peripherals_keyboard_xkb.schemas apps_gnome_settings_daemon_keybindings.schemas"
for S in $SCHEMAS; do
        gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done
%{_bindir}/update-mime-database %{_datadir}/mime

%postun
/sbin/ldconfig
scrollkeeper-update -q
%{_bindir}/update-mime-database %{_datadir}/mime

%files
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog NEWS README
%defattr (-, root, root)
%{_prefix}/bin/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/pixmaps/*
%{_datadir}/idl/*.idl
%{_datadir}/control-center-2.0
%{_sysconfdir}/gconf/schemas/*.schemas
%{_sysconfdir}/gnome-vfs-2.0/modules/*
%{_datadir}/gnome-2.0/ui/*.xml
%{_datadir}/gnome/vfolders/*
%{_datadir}/gnome/cursor-fonts/*
%{_datadir}/application-registry/*
%{_datadir}/applications/*
%{_datadir}/icons/gnome/48x48/apps/*
%{_datadir}/mime-info/*
%{_datadir}/gnome-background-properties
%{_libdir}/*.so*
%{_libdir}/bonobo/servers/*
%{_libdir}/bonobo/*.so
%{_libdir}/window-manager-settings/*.so*
%{_libdir}/gnome-vfs-2.0/modules/*.so*
%{_libexecdir}
%{_mandir}/man1/*

%files devel
%{_includedir}/gnome-window-settings-2.0/*.h
%{_libdir}/pkgconfig/*.pc



%changelog
* Thu Aug 26 2004 - [email protected]
- Modified Patch control-center-03-help-links.diff to provide help
  link to Assistive Technology.

* Thu Aug 19 2004 - [email protected]
- Added patch control-center-16-solaris-tar-command.diff to
  fix problem of directory option for Solaris tar.

* Fri Aug 06 2004 - [email protected]
- Updated control-center-07-g11n-potfiles.diff

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to control-center-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- ported to rpm4/suse9.1, packaged missing files, added new devel pkg

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Fri Jun 25 2004 - [email protected]
- Get the backgrounds.xml file in DATADIR/gnome-background-properities
  The Add Wallpaper file selector dialog will open $HOME/Document/Pictures
  or $HOME/Documents if pictures dir does not exist

* Mon Jun 14 2004 - [email protected]
  Added control-center-14-customize-system-bell.diff and
  control-center-15-keyboard-layout.diff to fix bugs 5046592 and 5046596
  respectively.

* Tue Jun 8 2004 - [email protected]
- Added the missing %{_sysconfdir}/gnome-vfs-2.0/modules/*

* Mon May 31 2004 - [email protected]
* Add control-center-12-accessible-names.diff. Backport of fix for
  bugzilla - bug #142402.

* Tue May 25 2004 - [email protected]
- Changed name of control-center-10-potfiles.diff to 
  control-center-10-g11n-potfiles.diff to comply with g11n naming standard.
  Patch control-center-10-g11n-potfiles.diff replaced 
  control-center-10-potfiles.diff

* Mon May 24 2004 -  [email protected]
- Added control-center-11-file-types-hang.diff to fix the file types capplet 
  hang when the requested icon file is not found. Bug #5028020.
  Uploaded the patch in bugzilla - bug #142894.

* Fri May 21 2004 -  [email protected]
- restore 09-potfiles.diff as 10-potfiles.diff.

* Fri May 21 2004 -  [email protected]
- Fixed bug 5050932: gnome-font-viewer takes too long time to view CJK fonts
  Added patch control-center-09-fontview-performance.diff and hope it can go
  upstream, see http://bugzilla.gnome.org/show_bug.cgi?id=142878, 

* Fri May 21 2004 -  [email protected]
- Fixed bug 5050926: Can't launch gnome-font-viewer in nautilus.
  Updated the spec file to include those files under /usr/lib/gnome-vfs-2.0/modules,
  /usr/share/application-registry and /usr/share/mime-info directory

* Fri May 14 2004 - [email protected]
- Modified patch control-center-03-help-links.diff to 
  remove obsolete stuff.
  Removed patch control-center-09-window-properties-help.diff.

* Wed May 12 2004 - [email protected]
- Updated l10n content to control-center-l10n-po-1.1.tar.bz2

* Tue May 04 2004 - [email protected]
- Added patch control-center-09-window-properties-help.diff to
  s/wgos*.xml/user-guide.xml.

* Mon Apr 26 2004 - [email protected]
- Bump to 2.6.1

* Wed Apr 21 2004 - [email protected]
- Appended "desktop_gnome_peripherals_keyboard_xkb.schemas" file for
  schemas list.

* Fri Apr 16 2004 - [email protected]
- Set the correct browser in command entry box.

* Tue Apr 6 2004 - [email protected]
- Bump to 2.6.0.3, and merge a bunch of the menu/title patches
  into one easy maintainable one. Patch the forte build issue
  on linux as well - we shouldn't special case this.

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to control-center-l10n-po-1.0.tar.bz2

* Thu Mar  4 2004 - [email protected]
- Added control-center-09-g11n-schemas.diff to localize schemas.in
- Added control-center-10-g11n-potfiles.diff to fix 4957377

* Thu Feb 26 2004 - [email protected]
- add libexecdir to pick up missing files

* Thu Feb 26 2004 - [email protected]
- Update Distro, l10n to 0.8

* Tue Feb 24 2004 - [email protected]
- define correct auto*-jds and libtool-jds versions

* Tue Feb 24 2004 - [email protected]
- set and export ACLOCAL_FLAGS on linux to
  pick up necessary JDS_CBE  aclocal macros.

* Fri Feb 20 2004 - [email protected]
- Added build dependencies on jds CBE auto* tools
  and set PATH to pick up their location on linux

* Wed Feb 18 2004 - [email protected]
- Bump to 2.5.3

* Wed Dec 17 2003 - [email protected]
- Bump to 2.5.0

* Fri Oct 31 2003 - [email protected]
- Remove the Sun Support keywords since
  we're moving away from the Extras menu.

* Tue Oct 21 2003 - [email protected]
- Add nautilus dependancy

* Mon Oct 19 2003 - [email protected]
- New tarball, bump version, reset release

* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la

* Tue Aug 05 2003 - [email protected]
- Close keybindings capplet on escape

* Tue Aug 05 2003 - [email protected]
- Add some metacity docs.

* Sat Aug 02 2003 - [email protected]
- Now we can theme X cursors

* Sat Aug 02 2003 - [email protected]
- Don't install gnomecc.desktop

* Fri Aug 01 2003 - [email protected]
- Add menu categorization cluepackets. Or something.

* Thu Jul 24 2003 - [email protected]
- Hide the password entry

* Tue Jul 22 2003 - [email protected]
- Change the window titles

* Mon Jul 21 2003 - [email protected]
- Reorder desktop preferences menu

* Thu Jul 17 2003 - [email protected]
- gnome-keybindings-properties uses the panel keys which are essential
  obsolete in the current release of GNOME. So replace these keys
  with the appropriate one that are appropriate in metacity.

* Thu Jul 17 2003 - [email protected]
- s/Files types and programs/File Associations

* Thu Jul 17 2003 - [email protected]
- Make sure the window icon lookup uses icon themes

* Tue Jul 15 2003 - [email protected]
- Backported the option to open the fonts folder from the fonts control panel.

* Wed Jul 09 2003 - [email protected]
- Added gnome-keyboard-layout to control centre.

* Fri Jul 03 2003 - [email protected]
- Add correct location for new sound icon and 
  add a theme icon.

* Fri Jul 03 2003 - [email protected]
- Install the .directory things

* Mon Jun 30 2003 - [email protected]
- add display properties capplet

* Fri Jun 27 2003 - [email protected]
- bump the version on the control center tarball

* Wed Jun 25 2003 - [email protected]
- add control-center-01-theme-failsafe.diff

* Wed May 14 2003 - [email protected]
- initial release