gnome-media.spec
author dermotm
Mon, 06 Sep 2004 10:13:24 +0000
changeset 3858 a0a00bd9bb27
parent 3846 9ab79af72b15
child 3936 b42d44bb4785
permissions -rw-r--r--
Incremented release numbers for build 18

Name:         gnome-media
Summary:      GNOME Multimedia
Group:        System/GUI/GNOME
Version:      2.6.1
Release:      22
Distribution: Cinnabar
Vendor:       Sun Microsystems, Inc.
License:      GPL
Source:       http://ftp.gnome.org/pub/GNOME/sources/gnome-media/2.6/gnome-media-%{version}.tar.bz2
Source1:      gnome-media-l10n-po-1.3.tar.bz2
Source2:      gnome-media_docs-0.6.tar.bz2
Source3:      cddb-slave2-properties.1.gz
Source4:      gnome-cd.1.gz
Source5:      gnome-sound-recorder.1.gz
Source6:      gnome-media-l10n-online-help-ci.tar.bz2
Patch1:       gnome-media-01-g11n-potfiles.diff
Patch2:       gnome-media-02-window-title.diff
Patch3:       gnome-media-03-menu-entry.diff
Patch4:       gnome-media-04-cddb-help-filename-update.diff
Patch5:       gnome-media-05-solaris.diff
Patch6:       gnome-media-06-destroy-cache.diff
Patch7:       gnome-media-07-set-audio-port.diff
Patch8:       gnome-media-08-g11n-configure.diff
Patch9:       gnome-media-09-cdda.diff
Patch10:      gnome-media-10-l10n-online-help.diff

URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_docdir}
Autoreqprov:  on
Prereq:       /sbin/ldconfig
Prereq:       scrollkeeper

%define 	gstreamer_version 		0.8.1
%define 	gstreamer_devel_version 	0.8.1
%define 	gstreamer_plugins_version 	0.8.1
%define 	gstreamer_plugins_devel_version	0.8.1
%define		scrollkeeper_version		0.3.14
%define         libgnomeui_version              2.6.0

Requires: 	gstreamer >= %{gstreamer_version}
Requires: 	gstreamer-plugins >= %{gstreamer_plugins_version}
Requires:	scrollkeeper >= %{scrollkeeper_version}
Requires:       libgnomeui >= %{libgnomeui_version}
BuildRequires:  gstreamer-devel >= %{gstreamer_devel_version}
BuildRequires: 	gstreamer-plugins-devel => %{gstreamer_plugins_devel_version}
BuildRequires:	scrollkeeper >= %{scrollkeeper_version}
BuildRequires:  javahelp-convert
BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}

%description
This package contains some multimedia programs for GNOME.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1

bzcat %SOURCE1 | tar xf -
bzcat %SOURCE2 | tar xf -
bzcat %SOURCE6 | tar xf -

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

%ifos solaris
glib-gettextize -f
%endif
libtoolize --force
aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}		\
	    --libexecdir=%{_libexecdir}	\
	    --sysconfdir=%{_sysconfdir} \
	    --disable-esdtest
# workaround gnome-cd/.deps/$(CDROM_HOST)-cdrom.Po
case "`uname -s`" in
*FreeBSD*)
        CDROM_HOST=freebsd
        ;;
*Linux*)
        CDROM_HOST=linux
        ;;
*SunOS*)
        CDROM_HOST=solaris
        ;;
esac
echo '# dummy' > ./gnome-cd/.deps/$CDROM_HOST-cdrom.Po

make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 
make DESTDIR=$RPM_BUILD_ROOT install
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL 
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE4 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE5 $RPM_BUILD_ROOT%{_mandir}/man1 

#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/

javahelp-convert-install $RPM_BUILD_ROOT gnome-cd gnome-cd.xml
javahelp-convert-install $RPM_BUILD_ROOT gnome-sound-recorder gnome-sound-recorder.xml
javahelp-convert-install $RPM_BUILD_ROOT gnome-volume-control gnome-volume-control.xml
javahelp-convert-install $RPM_BUILD_ROOT gstreamer-properties gstreamer-properties.xml

chmod 644 $RPM_BUILD_ROOT%{_datadir}/gnome/help/gnome-cd/*/*.xml
chmod 644 $RPM_BUILD_ROOT%{_datadir}/gnome/help/gnome-sound-recorder/*/*.xml

#Clean up unpackaged files
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*la

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="CDDB-Slave2.schemas gnome-cd.schemas gnome-audio-profiles.schemas gnome-sound-recorder.schemas"
for S in $SCHEMAS; do
 gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done
for i in zh_CN zh_TW ko_KR ja_JP de_DE es_ES fr_FR it_IT sv_SE ; do
        langtag=$i
        [ ${i:0:2} == "zh" ] || langtag=${i:0:2}
        for j in gnome-cd grecord ; do
                [ -e  %{_datadir}/omf/gnome-media/$j-$langtag.omf ] && \
                env LANG=$i LC_ALL=$i scrollkeeper-install -q %{_datadir}/omf/gnome-media/$j-$langtag.omf
        done
done
scrollkeeper-update -q

%postun
/sbin/ldconfig
for i in zh_CN zh_TW ko_KR ja_JP de_DE es_ES fr_FR it_IT sv_SE ; do
        langtag=$i
        [ ${i:0:2} == "zh" ] || langtag=${i:0:2}
        for j in gnome-cd grecord ; do
                [ -e  %{_datadir}/omf/gnome-media/$j-$langtag.omf ] && \
                env LANG=$i LC_ALL=$i scrollkeeper-uninstall -q %{_datadir}/omf/gnome-media/$j-$langtag.omf
        done
done
scrollkeeper-update -q

%files
%defattr (-, root, root)
%{_bindir}/*
%{_libexecdir}/*
%{_libdir}/*.so.*
%{_libdir}/bonobo/servers/*
%{_libdir}/pkgconfig/*
%{_libdir}/libglade/*
%{_includedir}/* 
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/control-center-2.0/capplets/*
%{_datadir}/omf/gnome-media/*
%{_datadir}/gnome/help/*
%{_datadir}/gnome/javahelp/*
%{_datadir}/idl/*
%{_datadir}/pixmaps/*
%{_sysconfdir}/gconf/schemas/*.schemas
%{_datadir}/applications/gnome-cd.desktop
%{_datadir}/applications/gnome-sound-recorder.desktop
%{_datadir}/applications/gnome-volume-control.desktop
%{_datadir}/applications/gstreamer-properties.desktop
%{_datadir}/applications/reclevel.desktop
%{_datadir}/applications/vumeter.desktop
%{_datadir}/gnome-media/*
%{_datadir}/gnome-sound-recorder/*
%{_datadir}/gstreamer-properties/*
%{_mandir}/man1/*

%changelog
* Thu Sep 02 2004 - [email protected]
- Remove patch gnome-media-10-disable-solaris-record.diff to enable record 
  button is Solaris. Since now we have source element for Solaris

* Wed Aug 25 2004 - [email protected]
- Added l10n help contents with patch

* Fri Aug 20 2004 - [email protected]
- Integrated updated docs tarball from [email protected]

* Sun Aug 16 2004  [email protected]
- change .../gnome-cd/*/*.xml permissions to 0644 for Solaris integration error
- change .../gnome-sound-recorder/*/*.xml permissions to 0644 for Solaris integration error

* Thu Aug 05 2004 - [email protected]
- Integrated docs 0.5 tarball from [email protected]

* Fri Jul 30 2004 - [email protected]
- Added patch 10 to disable the record button on Solaris.

* Fri Jul 23 2004 - [email protected]
- Patch to make gnome-cd play in machines where there is no audio cable.
  Fixes bug #5061178

* Tue Jul 13 2004 - [email protected]
- Ported to rpm4 and updated dependency versions

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gnome-media-l10n-po-1.2.tar.bz2

* Wed Jul  7 2004 - [email protected]
- Add gnome-media-08-g11n-configure.diff to install .mo into _datadir/locale.
  bugzilla 145087.

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Mon Jun 15 2004 - [email protected]
- Bumping to 2.6.1 made patch gnome-media-04-add-gst-cflags-ldflags.diff
  unnecessary, so removed.  This fixed bug 5061791.

* Fri Jun 11 2004 - [email protected]
- Integrated docs 0.4 tarball from [email protected]

* Wed Jun 09 2004 - [email protected]
- Added patch 08, to set the audio port, so that the user need not set it
  through sdtaudicontrol whenever he wants to use gnome-cd

* Tue Jun 8 2004 - [email protected]
- Added patch 07, so that gnome-cd doesn't crash when a CD is reinserted on
  a Solaris x86 system. Fix is fine for Linux as well. Fixes bugtraq bug
  #5057711

* Fri May 28 2004 - [email protected]
- Added patch 06, so that gnome-sound-recorder works for most formats
  on Solaris.  This is needed due to a limitation in esdsink (default 
  on Solaris).  osssink (default on Linux) can handle all rates/formats,
  but esdsink can not.

* Wed May 12 2004 - [email protected]
- Updated l10n content to gnome-media-l10n-po-1.1.tar.bz2

* Fri May 07 2004 - [email protected]
- Add --disable-esdtest since this fails on Solaris due to the
  way we are building gnome-media and configure picks up the
  gstreamer *.la files from pkg-config, which can't be used by
  configure.

* Fri May 07 2004 - [email protected]
- Bump to 2.6.1

* Tue Apr 27 2004 - [email protected]
- Added gnome-media-05-cddb-help-filename-update.diff to fix the help 
  for cddb-slave2-properties dialog.

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Thu Apr 01 2004 - [email protected]
- javahelp conversion

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to gnome-media-l10n-po-1.0.tar.bz2

* Wed Mar 24 2004 - <[email protected]>
- Bump to 2.6.0, and remove record scheduler, 
  grecord configure, audio schemas, gnome volume 
  desktop, gst mixer array and grecord prompt
  overwrite [needs to be rewritten] patches.

* Fri Mar 05 2004 - <[email protected]>
- pass in ACLOCAL_FLAGS to aclocal

* Wed Mar 03 2004 - <[email protected]>
- Add libgnomeui dependency

* Fri Feb 13 2004 - <[email protected]>
- Patch 08, patch 09

* Wed Feb 11 2004 - <[email protected]>
- Bump to 2.5.2, l10n to 0.7, docs 0.2
  Re-apply patchs 01->05
  Remove original patch 06
  Add new patch 06 to build gnome-sound-recorder

* Wed Dec 17 2003 - <[email protected]>
- Bump to 2.5.1

* Fri Oct 31 2003 - <[email protected]>
- Remove and rename patches to remove the Sun Settings 
  desktop keyword, since we're killing Extras menu.

* Mon Oct 20 2003 - <[email protected]>
- Forward port fix to #4880305 from wipro for QS.
  patch: gnome-media-07-fix-saving-zero-bytes-data.diff

* Mon Oct 13 2003 - <[email protected]>
- updated to version 2.4.0
- Removed gnome-media-01-window-icon.diff,
  gnome-media-07-gnome-cd-notification.diff,
  gnome-media-08-recorder-gst-state.diff - all merged upstream

* Fri Sep 26 2003 - <[email protected]>
- integrate Sun docs

* Tue Sep 23 2003 - <[email protected]>
- add patch from [email protected].
  Fixes BT# 4882371. gnome-media-08-recorder-gst-state.diff

* Fri Sep 19 2003 - <[email protected]>
- add patch from [email protected]. Fixes BT#4913405
  gnome-media-07-gnome-cd-notification.diff

- add patch nautilus-media-06-record-scheduler.diff.
  Fixes BT# 4904323

* Thu Aug 14 2003 - <[email protected]>
- remove lib*.so, *.a, *.la

* Thu Aug 07 2003 - <[email protected]>
- post install uses scrollkeeper so make it a dependency

* Wed Aug 06 2003 - <[email protected]>
- Prompt before you overwrite a filename.

* Tue Aug 05 2003 - <[email protected]>
- New tarball, bump version, reset release.

* Fri Aug 01 2003 - <[email protected]>
- Add supported menu categories

* Tue Jul 21 2003 - <[email protected]>
- New mixer icon

* Wed Jul 09 2003 - <[email protected]>
- add in sun po files

* Wed May 14 2003 - [email protected]
- Initial Sun Release