metacity.spec
author dermotm
Mon, 06 Sep 2004 10:13:24 +0000
changeset 3858 a0a00bd9bb27
parent 3846 9ab79af72b15
child 3895 caf5571f7b66
permissions -rw-r--r--
Incremented release numbers for build 18

Name:         metacity
License:      GPL
Group:        System/GUI/GNOME
Version:      2.8.0
Release:      20
Distribution: Cinnabar
Vendor:       Sun Microsystems, Inc.
Summary:      GNOME Window Manager
Source:       http://ftp.gnome.org/pub/GNOME/sources/metacity/2.6/metacity-%{version}.tar.bz2
Source1:      metacity-l10n-po-1.3.tar.bz2
Source2:      metacity.1.gz
Source3:      metacity-theme-viewer.1.gz
Patch1:       metacity-01-default-theme.diff
Patch2:       metacity-02-ctrl-esc-mod4-r.diff
Patch3:       metacity-03-ctrl-alt-del.diff
Patch4:       metacity-04-sunpowerswitch-key.diff
Patch5:       metacity-05-bigstruts.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/doc
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define intltool_version 0.30
%define GConf_version 2.6.1
%define pkgconfig_version 0.15.0
%define libglade_version 2.3.6

Requires: GConf >= %{GConf_version}
Requires: libglade >= %{libglade_version}
BuildRequires: intltool >= %{intltool_version}
BuildRequires: pkgconfig >= %{pkgconfig_version}
BuildRequires: GConf >= %{GConf_version}
BuildRequires: libglade >= %{libglade_version}

%description
Metacity is the window manager for the GNOME Desktop.

%prep
%setup -q
%patch1 -p0
%patch2 -p0
%patch3 -p0
%patch4 -p1
%patch5 -p1
bzcat %SOURCE1 | tar xf -

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
autoheader
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}		\
	    --mandir=%{_mandir}		\
            --libexecdir=%{_libexecdir} \
	    --sysconfdir=%{_sysconfdir}
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make DESTDIR=$RPM_BUILD_ROOT install
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/man1
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la
                                                                                                                                                             
%post
/sbin/ldconfig
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="metacity.schemas"
for S in $SCHEMAS; do
	gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%postun
/sbin/ldconfig

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, root)
%{_bindir}/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_sysconfdir}/gconf/schemas/metacity.schemas
%{_libexecdir}/*
%{_libdir}/*.so*
%{_libdir}/pkgconfig/*.pc
%{_includedir}/metacity-1/metacity-private
%{_datadir}/gnome/wm-properties/metacity.desktop
%{_datadir}/metacity
%{_datadir}/pixmaps/metacity-properties.png
%{_datadir}/themes/*/metacity-1/*
%{_mandir}/man1/*

%changelog
* Mon Aug 16 2004 - [email protected]
- Added patch metacity-05-bigstruts.diff for bugzilla #144126.

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to metacity-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- ported to rpm4

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed May 12 2004 - [email protected]
- Updated l10n content to metacity-l10n-po-1.1.tar.bz2

* Wed May 12 2004 - [email protected]
- Do aclocal, autoheader, autoconf and automake before doing a configure.

* Fri Apr 30 2004 - [email protected]
- Added patch metacity-04-sunpowerswitch-key.diff to bind SunPowerSwitch
  key to gnome-sys-suspend for Solaris.

* Wed Apr 07 2004 - [email protected]
- Updated to 2.8.0

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to metacity-l10n-po-1.0.tar.bz2

* Tue Feb 24 2004 - <[email protected]> 2.7.0-1
- Update to 2.7.0

* Thu Feb 12 2004 - <[email protected]>
- add "-p0" strip argument to patch commands

* Tue Dec 16 2003 - <[email protected]> 2.6.3-1
- Update to 2.6.3

* Thu Oct 16 2003 - <[email protected]> 2.6.2-1
- Update to 2.6.2

* Thu Oct 09 2003 - <[email protected]> 2.6.1-1
- Update to 2.6.1
- Remove panel keybindings patches - they're in 2.6.x

* Fri Aug 01 2003 - <[email protected]> 2.4.55-1
- Update to 2.4.55

* Thu Jul 31 2003 - <[email protected]> 2.4.34-11
- Add patch to fix workspace names not retained after
  logging out.

* Thu Jul 17 2003 - <[email protected]>
- Combined the esc-ctrl patch with Mod4 (window) R key
  patch.

* Thu Jul 10 2003 - <[email protected]>
- Added .po tarball

* Thu Jul 03 2003 - <[email protected]>
- redo default window border theme patch

* Wed Jul 02 2003 - <[email protected]>
- add metacity-04-ctrl-escape.diff

* Wed Jul 02 2003 - <[email protected]>
- new version of metacity-01-panel-keybindings.diff

* Fri May 30 2003 - <[email protected]>
- Backport panel keybindings patches.

* Tue May 13 2003 - <[email protected]>
- initial release