SUNWperl-authen-pam.spec
author davelam
Fri, 08 Aug 2008 01:12:57 +0000
branchgnome-2-22
changeset 12493 a4d9be4ee8a3
parent 12475 87c12796cb9f
child 13489 fc8a2bd90b3f
permissions -rw-r--r--
2008-08-08 Dave Lin <[email protected]> * SUNWlibgsf: Correct the dependency as below to fix the integration issues(CR6734966) Requires: SUNWlibms BuildRequires: SUNWlibm

#
# spec file for package SUNWperl-authen-pam
#
# includes module(s): 
#
# Copyright (c) 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: padraig
#
%include Solaris.inc
Name:                    SUNWperl-authen-pam
Summary:                 Authen-PAM PERL module
Version:                 5.8.4
%define tarball_version 0.16
Source:                  http://www.cpan.org/modules/by-module/Authen/Authen-PAM-%{tarball_version}.tar.gz
#owner:padraig date:2006-04-10 type:bug state:upstream
Patch1:                  authen-pam-01-solaris.diff
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
SUNW_Copyright:          %{name}.copyright

%define perl_version 5.8.4
%ifarch sparc
%define perl_dir sun4-solaris-64int
%else
%define perl_dir i86pc-solaris-64int 
%endif
%include default-depend.inc

%prep
%setup -q            -c -n %name-%version
cd Authen-PAM-%{tarball_version}
%patch1 -p1

%build
cd Authen-PAM-%{tarball_version}
autoconf
perl Makefile.PL \
    PREFIX=$RPM_BUILD_ROOT%{_prefix} \
    INSTALLSITELIB=$RPM_BUILD_ROOT%{_prefix}/perl5/vendor_perl/%{perl_version} \
    INSTALLSITEARCH=$RPM_BUILD_ROOT%{_prefix}/perl5/vendor_perl/%{perl_version}/%{perl_dir} \
    INSTALLSITEMAN1DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
    INSTALLSITEMAN3DIR=$RPM_BUILD_ROOT%{_mandir}/man3 \
    INSTALLMAN1DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
    INSTALLMAN3DIR=$RPM_BUILD_ROOT%{_mandir}/man3
make CC=$CC CCCDLFLAGS="%picflags" OPTIMIZE="%optflags" LD=$CC

%install
rm -rf $RPM_BUILD_ROOT
cd Authen-PAM-%{tarball_version}
make install

rm -rf $RPM_BUILD_ROOT%{_prefix}/lib

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr(0755, root, bin) %{_prefix}/perl5
%dir %attr(0755, root, bin) %{_prefix}/perl5/vendor_perl
%dir %attr(0755, root, bin) %{_prefix}/perl5/vendor_perl/%{perl_version}
%dir %attr(0755, root, bin) %{_prefix}/perl5/vendor_perl/%{perl_version}/%{perl_dir}/Authen
%{_prefix}/perl5/vendor_perl/%{perl_version}/%{perl_dir}/Authen/*
%if %is_s10
%dir %attr(0755, root, other) %{_prefix}/perl5/vendor_perl/%{perl_version}/%{perl_dir}/auto
%{_prefix}/perl5/vendor_perl/%{perl_version}/%{perl_dir}/auto/*
%else
%{_prefix}/perl5/vendor_perl/%{perl_version}/%{perl_dir}/auto
%endif
%dir %attr(0755, root, sys) %{_datadir}
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/man3
%{_mandir}/man3/*

%changelog
* Thu Jul 17 2008 - [email protected]
- s/authen_pam_version/tarball_version/ to be consistent with other spec files.
* Tue Jan 30 2007 - [email protected]
- Fix typo s/Autoconf/autoconf/.
* Sun Jan 28 2007 - [email protected]
- update %file so that dir attributes work on both s10 and nevada
* Mon Apr 10 2006 - [email protected]
- Initial spec file