SUNWcups-manager.spec
author davelam
Mon, 15 Mar 2010 02:59:51 +0000
branchgnome-2-28
changeset 18663 a66b3e99c95a
parent 18528 b0aa43403b1b
permissions -rw-r--r--
Nevada b136

#
# spec file for package SUNWcups-manager
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner gheet
#

%include Solaris.inc 

%use scp = system-config-printer.spec

Name:                    SUNWcups-manager
License:  		 GPL v2
Summary:                 Print Manager for CUPS
Version:                 %{default_pkg_version}
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
Requires:                SUNWdbus-python26
Requires:                SUNWPython26
Requires:                SUNWpycups
Requires:                SUNWcupsu
BuildRequires:           SUNWgnome-desktop-prefs
BuildRequires:           SUNWcupsu

%include default-depend.inc

%package root
Summary:		 %{summary} - / filesystem
SUNW_BaseDir:		 /
%include default-depend.inc
Requires: SUNWPython26

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%prep
rm -rf %name-%version
mkdir -p %name-%version
%scp.prep -d %name-%version

%build
%scp.build -d %name-%version

%install
%scp.install -d %name-%version

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/*
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/%{scp.name}/icons/*
%{_datadir}/%{scp.name}/*.glade
%doc -d %scp.name-%{scp.version} AUTHORS README NEWS
%doc(bzip2) -d %scp.name-%{scp.version} COPYING ChangeLog
%dir %attr (0755, root, other) %{_datadir}/doc

%files root
%defattr (-, root, sys)
%attr (0755, root, sys) %dir %{_sysconfdir}
%attr(0755, root, bin) %dir %{_sysconfdir}/dbus-1
%attr(0755, root, bin) %dir %{_sysconfdir}/dbus-1/system.d
%{_sysconfdir}/dbus-1/system.d/*

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%endif

%changelog
* Tue Dec 09 2008 - [email protected]
- Add l10n package.
* Thu Dec 04 2008 - [email protected]
- Add BuildRequires on SUNWgnome-desktop-prefs(desktop-file-install)
* Tues Nov 18 2008 - [email protected]
- Initial version.