SUNWsun-gdm-themes.spec
author chrisk
Thu, 19 Nov 2009 17:53:32 +0000
changeset 16997 a6e3983792f9
parent 16960 6f34f03c7d11
child 17043 390eeb50bef6
permissions -rw-r--r--
2009-11-19 Christian Kelly <[email protected]> * SUNWsun-gdm-themes.spec: Fix directory permissions.

#
# spec file for package SUNWsun-gdm-themes
#
# includes module(s): sun-gdm-themes
#
# Copyright 2009 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner erwannc
#
%include Solaris.inc
%include base.inc

%use themes = sun-gdm-themes.spec

Name:                    SUNWsun-gdm-themes
Summary:                 Sun branded GNOME login manager themes
Version:                 %{themes.version}
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
BuildRequires: SUNWgtk2
BuildRequires: SUNWgtk2-devel

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%prep
rm -rf %name-%version
mkdir %name-%version

mkdir %name-%version/%{base_arch}
%themes.prep -d %name-%version/%{base_arch}

%build
export PKG_CONFIG=/usr/bin/pkg-config
PKG_CONFIG_DISABLE_UNINSTALLED=
unset PKG_CONFIG_DISABLE_UNINSTALLED

%themes.build -d %name-%version/%{base_arch}

%install
rm -rf $RPM_BUILD_ROOT

%themes.install -d %name-%version/%{base_arch}

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT


%files
%defattr (-, root, root)
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/gdm/themes/*

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%endif


%changelog
* Thu Nov 19 2009 - [email protected]
- Fix directory permissions.