base-specs/gail.spec
author dcarbery
Wed, 11 Jul 2007 11:15:39 +0000
changeset 10178 a7f02aa69081
parent 10004 749465fa8400
child 10184 9e2210ee7f2b
permissions -rw-r--r--
2007-07-11 Damien Carbery <[email protected]> * SUNWevolution.spec: Add a new schemas file to %files. * SUNWgnome-img-viewer.spec: Add eog-image-collection.png and thumbnail-frame.png to %files. * base-specs/evolution-exchange.spec: Add patch 01-pretty-function to fix build error 455858. * patches/evolution-exchange-01-pretty-function.diff: Added to fix 455858. * base-specs/pygtk2.spec: Bump to 2.10.5. Remove obsolete patch, 02-gtk-tooltips. * patches/pygtk2-02-gtk-tooltips.diff: Removed, obsolete. * base-specs/libwnck.spec: Remove upstream patch, 02-group-windows. * patches/libwnck-02-group-windows.diff: Removed, upstream. * base-specs/at-spi.spec, base-specs/libgail-gnome.spec, base-specs/gail.spec: Bump to 1.19.5. * base-specs/eel.spec: Bump to 2.19.5. * base-specs/libgnomecanvas.spec: Bump to 2.19.0.

#
# spec file for package gail
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: padraig
#
Name:         gail
License:      LGPL
Group:        System/Libraries/GNOME
Version:      1.19.5
Release:      202
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      GNOME Accessibility Implementation Library
URL:          http://www.gnome.org
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/1.19/%{name}-%{version}.tar.bz2
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/doc
AutoReqProv:  on
Prereq:       /sbin/ldconfig

%define libgnomecanvas_version 2.6.0
%define gtk2_version 2.4.0
%define atk_version 1.7

Requires: atk >= %{atk_version}
Requires: gtk2 >= %{gtk2_version}
Requires: libgnomecanvas >= %{libgnomecanvas_version}

BuildRequires: gtk2-devel >= %{gtk2_version}
BuildRequires: atk-devel >= %{atk_version}
BuildRequires: libgnomecanvas-devel >= %{libgnomecanvas_version}

%description
GNOME Accessibility Implementation Library is a set of accessibility interfaces for the GTK+ widgets.

%package devel
Summary:      GNOME Accessibility Implementation Development Library
Group:        Development/Library/GNOME
Requires:     %{name} = %{version}
Requires:     gtk2-devel >= %{gtk2_version}
Requires:     libgnomecanvas-devel >= %{libgnomecanvas_version}

%description devel
GNOME Accessibility Implementation Library is a set of accessibility interfaces for the GTK+ widgets.

%prep
%setup -q

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS
gtkdocize
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}		\
	    --sysconfdir=%{_sysconfdir} \
	    %{gtk_doc_option}
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
rm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
rm $RPM_BUILD_ROOT%{_libdir}/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr(-, root, root)
%{_libdir}/*.so.*
%{_libdir}/gtk-2.0/modules/*.so

%files devel
%defattr(-, root, root)
%{_datadir}/gtk-doc/html/gail-libgail-util
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%{_includedir}/*
%{_datadir}/locale/*/*/*.mo
%{_mandir}/man3/*

%changelog
* Wed Jul 11 2007 - [email protected]
- Bump to 1.19.5.
* Wed Jun 06 2007 - [email protected]
- Bump to 1.19.3.
* Thu May 10 2007 - [email protected]
- Bump to 1.19.1.
* Mon Mar 12 2007 - [email protected]
- Bump to 1.18.0.
* Tue Feb 13 2007 - [email protected]
- Bump to 1.17.0.
* Mon Jan 22 2007 - [email protected]
- Bump to 1.10.1.
* Tue Jan 09 2007 - [email protected]
- Bump to 1.10.0.
* Tue Dec 19 2006 - [email protected]
- Bump to 1.9.4.
* Fri Nov  3 2006 - [email protected]
- use %gtk_doc_option in configure so that it can be disabled using
  --without-gtk-doc
* Mon Oct 02 2006 - [email protected]
- Bump to 1.9.3.
* Tue Aug 22 2006 - [email protected]
- Bump to 1.9.2.
* Thu Aug 10 2006 - [email protected]
- Remove unneeded patch gail-01-combo-fix.diff
* Tue Jul 25 2006 - [email protected]
- Bump to 1.9.1.
* Thu Jul 20 2006 - [email protected]
- Bump to 1.9.0. Remove upstream patch gail-02-button-label.diff.
* Mon May 22 2006 - [email protected]
- Added gail-02-button-label.diff.
* Mon Mar 13 2006 - [email protected]
- Bump to 1.8.11.
* Wed Feb 21 2006 - [email protected]
- Bump to 1.8.10.
* Tue Feb 14 2006 - [email protected]
- Bump to 1.8.9.
* Wed Nov 30 2005 - [email protected]
- Remove upstream patch, 02-garbage-collect-6278812.diff.
* Tue Nov 29 2005 - [email protected]
- Bump to 1.8.8.
* Tue Sep 05 2005 - [email protected]
- Remove upstream patch, gail-02-model-row-deleted-fix.diff. Reorder remaining.
* Mon Sep 05 2005 - [email protected]
- Bump to 1.8.5.
* Thu Aug 11 2005 - [email protected]
- Now enable gtk-docs.
* Fri Jun 03 2005 - [email protected]
- Added gail-03-garbage-collect-6278812.diff, bug 6278812, 6272286,
* Thu May 19 2005 - [email protected]
- Revised gail-02-model-row-deleted-fix.diff, bug #6272286.
* Tue May 17 2005 - [email protected]
- Added gail-02-model-row-deleted-fix.diff, bug #6271379 and #6271386.
* Thu Apr 28 2005 - [email protected]
- Revved to 1.8.4, to get fix for #6215709.
- Removed obsolete g10n-alllinguas patch, l10n-configure.sh does 
  this for us now.
* Mon Apr 18 2005 - [email protected]
- Revved to 1.8.3, removed redundant patches 
  gail-07-focus-check.diff, gail-06-notebookpage-enabled.diff,
  gail-05-delete-tab.diff, gail-04-item-showing.diff,
  gail-03-menu-select.diff.  Reworked patch
  gail-02-g10n-alllinguas.diff.
* Tue Apr 05 2005 - [email protected]
- Add gail-07-focus-check.diff for bug #6236825.
* Wed Mar 09 2005 - [email protected]
- Add gail-06-notebookpage-enabled.diff for bug #6221758.
* Thu Nov 24 2004 - [email protected]
- Add gail-05-delete-tab.diff for bug #6199344.
* Tue Oct 26 2004 - [email protected]
- Add gail-04-item-showing.diff for bugzilla #156143.
* Fri Oct 22 2004 - [email protected]
- Rename gail-04-g11n-alllinguas.diff to gail-02-g11n-alllinguas.diff
- Add gail-03-menu-select.diff for bug #6176892
* Mon Sep 27 2004 - [email protected]
- Bump to 1.8.0; rework gail-01-combo-fix.diff patch;
  remove gail-02-metacity-fix.diff and gail-03-canvas-item-fix.diff patches. 
* Mon Sep 20 2004 - [email protected]
- Added gail-04-g11n-alllinguas.diff to add hu for all linguas
* Tue Sep 07 2004 - [email protected]
- Added patch gail-03-canvas-item-fix.diff for bug 5064514
* Thu Aug 05 2004 - [email protected]
- Added patch gail-02-metacity-fix.diff for bug 5082567
* Thu Jul 22 2004 - [email protected]
- Added patch gail-01-combo-fix.diff for bugzilla #136657.
* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gail-l10n-po-1.2.tar.bz2
* Wed Jul 07 2004 - [email protected]
- ported to rpm4
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds
* Tue Jun 08 2004 - <[email protected]>
- Bump to 1.6.6
* Tue May 25 2004 - <[email protected]>
- Bump to 1.6.5
* Fri May 14 2004 - <[email protected]>
- Bump to 1.6.4
* Wed May 12 2004 - [email protected]
- Updated l10n content to gail-l10n-po-1.1.tar.bz2
* Mon Apr 26 2004 - <[email protected]>
- Bump to 1.6.3
* Mon Apr 19 2004 - <[email protected]>
- Bump to 1.6.2
* Wed Apr 07 2004 - <[email protected]>
- Bump to 1.6.1
* Wed Mar 31 2004 - [email protected]
- replace tar jxf with the more solaris friendly
  bzcat piped through tar
* Mon Mar 29 2004 - [email protected]
- Adding gail-l10n-po-1.0.tar.bz2 l10n content
* Tue Mar 23 2004 - <[email protected]>
- Bump to 1.6.0, update gtk+ dependency.
* Thu Mar 11 2004 - <[email protected]>
- Reset release to 1.
* Wed Mar 10 2004 - [email protected]
- Bump to 1.5.7
* Mon Feb 23 2004 - [email protected]
- bump to 1.5.5, remerge patch
* Fri Feb 06 2004 - [email protected]
- bump to 1.5.4 to fix automake mess
* Fri Feb 06 2004 - [email protected]
- added a uninatalled-pc.in file for Wells build.
- autotoolize
* Tue Dec 16 2003 - [email protected]
- bump to 1.5.2
* Thu Oct 9 2003 - [email protected]
- tarball upgrade
* Thu Aug 14 2003 - <[email protected]>
- move lib*.so to -devel, remove *.a, *.la
* Tue Aug 08 2003 - [email protected]
- added libtoolize and friends + patch to fix the build
* Tue May 13 2003 - [email protected]
- initial Sun release