evince.spec
author darrenk
Mon, 29 May 2006 16:40:25 +0000
changeset 7333 a95e5affafd6
parent 7158 475d2b89a844
child 7373 284aa636d250
permissions -rw-r--r--
2006-05-29 Darren Kenny <[email protected]> * patches/evince-02-gs-sfw.diff: Temporary patch for bug#6430428 - real fix is to move gs to /usr/bin as per bug#6431474. * evince.spec: add evince-02-gs-sfw patch

#
# spec file for package evince
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         evince
License:      GPL
Group:        System/GUI/GNOME
Version:      0.5.2
Release:      2
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Document viewer
Source:       http://ftp.gnome.org/pub/GNOME/sources/evince/0.5/%{name}-%{version}.tar.bz2
Patch1:	      evince-01-menu-entry.diff
Patch2:	      evince-02-gs-sfw.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on

%define gtk2_version 2.6.0
%define libgnomeui_version 2.6.0
%define dbus_version 0.33
%define poppler_version 0.4.0
%define libgnomeprintui_version 2.5.1

Requires:	gtk2 >= %{gtk2_version}
Requires:	libgnomeui >= %{libgnomeui_version}
Requires:	dbus >= %{dbus_version}
Requires:	poppler >= %{poppler_version}
Requires:       libgnomeprintui >= %{libgnomeprintui_version}
BuildRequires:  gtk2-devel >= %{gtk2_version}
BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}
BuildRequires:  dbus-devel >= %{dbus_version}
BuildRequires:  poppler-devel >= %{poppler_version}
BuildRequires:  libgnomeprintui-devel >= %{libgnomeprintui_version}

%description
Evince is a document viewer capable of displaying multiple and single page document formats like PDF and Postscript.

%prep
%setup -q
%patch1 -p1
%patch2 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS 
automake -a -c -f
autoconf
CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
	--prefix=%{_prefix} \
        --libexecdir=%{_libexecdir} \
	--sysconfdir=%{_sysconfdir} \
	--mandir=%{_mandir}
make -j $CPUS

%install
make -i install DESTDIR=$RPM_BUILD_ROOT
rm $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-1.0/*.a
rm $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-1.0/*.la

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="evince.schemas evince-thumbnailer.schemas"
for S in $SCHEMAS; do
        gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, root)
%{_bindir}/*
%{_libdir}/nautilus/extensions-1.0/*.so*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/applications/*
%{_datadir}/evince/*
%{_datadir}/gnome/help/*
%{_datadir}/omf/*
%{_sysconfdir}/gconf/schemas/*

%changelog
* Fri Apr 28 2006 - [email protected]
- Add patch to install into Office submenu
  with 'Evince Document Viewer'.

* Tue Mar 14 2006 - [email protected]
- Bump to 0.5.2.

* Fri Jan 20 2006 - [email protected]
- Bump to 0.5.0.

* Tue Nov 08 2005 - [email protected]
- Show the .desktop file entry for the moment.

* Fri Sep 30 2005 - [email protected]
- Bump to 0.4.0

* Wed Aug 24 2005 - [email protected]
- Add libgnomeprintui dependency.

* Tue Aug 16 2005 - [email protected]
- New spec file for evince