control-center.spec
author dc144907
Mon, 10 Apr 2006 18:32:16 +0000
changeset 7038 ab44c695d35e
parent 6970 7565d6146b31
child 7215 1c5d92657813
permissions -rw-r--r--
2006-04-10 Damien Carbery <[email protected]> * gnome-screensaver.spec: Bump 2.14.1. * gnopernicus.spec: Bump 1.0.4. * nautilus-cd-burner.spec: Bump 2.14.1. * deskbar-applet.spec: Bump 2.14.1. * control-center.spec: Bump 2.14.1. * gtkhtml.spec: Bump 3.10.1. * evolution-data-server.spec: Bump 1.6.1. * evolution-exchange.spec: Bump 2.6.1. * evolution.spec: Bump 2.6.1. * libsoup.spec: Bump 2.2.92.

#
# spec file for package control-center.
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

Name:         control-center
License:      GPL
Group:        System/GUI/GNOME
Version:      2.14.1
Release:      1
Distribution: Java Desktop System, Release 3
Vendor:       Sun Microsystems, Inc.
Summary:      The GNOME control center for GNOME
Source:       http://ftp.gnome.org/pub/GNOME/sources/control-center/2.14/control-center-%{version}.tar.bz2
Source1:      gnome-font-viewer.1.gz
Source2:      gnome-accessibility-keyboard-properties.1.gz
Source3:      gnome-background-properties.1.gz
Source4:      gnome-control-center.1.gz
Source5:      gnome-default-applications-properties.1.gz
Source6:      gnome-file-types-properties.1.gz
Source7:      gnome-keybinding-properties.1.gz
Source8:      gnome-keyboard-properties.1.gz
Source9:      gnome-mouse-properties.1.gz
Source10:     gnome-network-preferences.1.gz
Source11:     gnome-font-properties.1.gz
Source12:     gnome-settings-daemon.1.gz
Source13:     gnome-sound-properties.1.gz
Source14:     gnome-ui-properties.1.gz
Source15:     gnome-desktop-prefs.1.gz
Source16:     gnome-theme-manager.1.gz
Source17:     gnome-window-properties.1.gz
Source19:     gnome-at-properties.1.gz
Patch1:       control-center-01-keybindings-close.diff
Patch2:       control-center-02-ctrl-alt-del.diff
Patch3:	      control-center-03-gsd-not-session-managed.diff
Patch4:       control-center-04-keyboard-layout.diff
Patch5:       control-center-05-add-wallpaper-dialog.diff
Patch6:       control-center-06-xkb-workaround.diff
Patch7:       control-center-07-logout-shortcut.diff
Patch8:       control-center-08-custom-keybinding.diff
Patch9:       control-center-09-keybinding-caps-lock.diff
Patch10:      control-center-10-volume-control.diff
Patch11:      control-center-11-homefolder-keybindings.diff
Patch12:      control-center-12-anykey-grab.diff
Patch13:      control-center-13-wall.diff
Patch14:      control-center-14-no-xkb-dialog.diff
Patch15:      control-center-15-layout-deletion.diff
Patch16:      control-center-16-background-crash.diff
Patch17:      control-center-17-xkb-check-remote-login.diff
Patch18:      control-center-18-fix-keyboard-dialog.diff
Patch19:      control-center-19-mouse-dialog.diff
Patch20:      control-center-20-disable-gnome-screensaver.diff

URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/control-center2
Autoreqprov:  on
Prereq:       /sbin/ldconfig
Prereq:       GConf

%define libgnomeui_version 2.6.0
%define esound_version 0.2.33
%define gnome_desktop_version 2.6.1
%define metacity_version 2.8.0
%define nautilus_version 2.6.1
%define fontilus_version 2.4.0
%define acme_version 2.4.2
%define libxklavier_version 1.0.2
%define desktop_file_utils_version 0.10
%define xft_version 2.1.7

BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: esound-devel >= %{esound_version}
BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
BuildRequires: metacity >= %{metacity_version}
BuildRequires: nautilus-devel >= %{nautilus_version}
BuildRequires: libxklavier-devel >= %{libxklavier_version}
BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
BuildRequires: automake >= 1.9
BuildRequires: evolution-data-server-devel
BuildRequires: gstreamer-plugins-devel

Requires: gst-plugins-base
Requires: libgnomeui >= %{libgnomeui_version}
Requires: esound >= %{esound_version}
Requires: gnome-desktop >= %{gnome_desktop_version}
Requires: nautilus >= %{nautilus_version}
Requires: libxklavier >= %{libxklavier_version}
Requires: evolution-data-server

Obsoletes:      fontilus < %{fontilus_version}
Provides:       fontilus = %{fontilus_version}
Obsoletes:	acme < %{acme_version}
Provides:	acme = %{acme_version}

%description
This package contains the new control-center for the GNOME desktop.

%package devel
Summary:       Development files for the GNOME control center for GNOME 2.6
Group:         Development/Libraries/GNOME
Requires:      %name = %version-%release

%description devel
This package contains the files need for development of GNOME control center capplets

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
%patch11 -p1
%patch12 -p1
%ifos solaris
%patch13 -p1
%endif
%patch14 -p1
%patch15 -p1
%patch16 -p1
%patch17 -p1
%patch18 -p1
##FIXME: Do we still need this patch? %patch19 -p1
%patch20 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

LC_ALL=
LANG=
export LC_ALL LANG
gnome-doc-common
gnome-doc-prepare --force
libtoolize --force
glib-gettextize -f
intltoolize --force --copy
aclocal $ACLOCAL_FLAGS -I .
autoheader
automake -a -c -f
autoconf
CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
    --prefix=%{_prefix} \
    --libexecdir=%{_libexecdir} \
    --sysconfdir=%{_sysconfdir} \
    --disable-scrollkeeper \
    --enable-aboutme \
    --disable-hal
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make DESTDIR=$RPM_BUILD_ROOT install
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL       
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE4 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE5 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE6 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE7 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE8 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE9 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE10 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE11 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE12 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE13 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE14 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE15 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE16 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE17 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE19 $RPM_BUILD_ROOT%{_mandir}/man1
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la
rm $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/*.a
rm $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/*.la
rm $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-1.0/*.la
rm $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-1.0/*.a
rm $RPM_BUILD_ROOT%{_libdir}/window-manager-settings/*.a
rm $RPM_BUILD_ROOT%{_libdir}/window-manager-settings/*.la
                                                                               
%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="apps_gnome_settings_daemon_default_editor.schemas apps_gnome_settings_daemon_screensaver.schemas desktop_gnome_font_rendering.schemas desktop_gnome_peripherals_keyboard_xkb.schemas apps_gnome_settings_daemon_keybindings.schemas"
for S in $SCHEMAS; do
        gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%postun
/sbin/ldconfig

%files
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog NEWS README
%defattr (-, root, root)
%{_prefix}/bin/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/pixmaps/*
%{_datadir}/idl/*.idl
%{_datadir}/control-center-2.0/*
%{_sysconfdir}/gconf/schemas/*.schemas
%{_sysconfdir}/gnome-vfs-2.0/modules/*
%{_datadir}/gnome/vfolders/*
%{_datadir}/gnome/cursor-fonts/*
%{_datadir}/gnome/help/*
%{_datadir}/omf
%{_datadir}/applications/*
%{_datadir}/icons/hicolor/*
%{_datadir}/gnome-background-properties
%{_datadir}/gnome-default-applications
%{_libdir}/*.so.*
%{_libdir}/bonobo/servers/*
%{_libdir}/gnome-vfs-2.0/modules/*.so*
%{_libdir}/nautilus/extensions-1.0/*.so
%{_libdir}/window-manager-settings/*.so
%{_libexecdir}/gnome-settings-daemon
%{_mandir}/man1/*

%files devel
%{_includedir}/gnome-window-settings-2.0/*.h
%{_libdir}/pkgconfig/*.pc
%{_libdir}/*.so

%changelog
* Mon Apr 10 2006 - [email protected]
- Bump to 2.14.1.

* Tue Mar 14 2006 - [email protected]
- Remove registration of settings daemon per display patch,
  as it's now upstream, #94049.

* Mon Mar 13 2006 - [email protected]
- Bump to 2.14.0.

* Tue Feb 28 2006 - [email protected]
- Bump to 2.13.93.

* Tue Feb 15 2006 - [email protected]
- Remove no apply button patch, since it was reverted upstream.

* Tue Feb 14 2006 - [email protected]
- Bump to 2.13.92.

* Fri Feb  3 2006 - [email protected]
- Bump to 2.13.91.
- Remove patch 23-no-es-help as #329331 fixed.

* Tue Jan 31 2006 - [email protected]
- Add patch, 23-no-es-help, to fix #329331.

* Tue Jan 31 2006 - [email protected]
- Add no apply button patch because of braindead maintainer and bump to
  2.13.90

* Fri Jan 20 2006 - [email protected]
- Bump to 2.13.5.1.
- Remove 'mkdir m4' call - fixed in 2.13.5.1.

* Wed Jan 18 2006 - [email protected]
- Call glib-gettextize instead of commenting out the po directory from the
  Makefile.am subdirs.  Now build with GStreamer 0.10.

* Wed Jan 18 2006 - [email protected]
- Add patch to fix 327563 (void function returning value), 22-void-return.diff
- Delete 'po' dir ref to stop configure infinite loop: 23-stop-infinite-po-loop.
- Create 'm4' as require by gnome-doc-prepare.

* Mon Jan 16 2006 - [email protected]
- Bump to 2.13.5

* Sun Jan 15 2006 - [email protected]
- Bump to 2.13.4

* Tue Dec 20 2005 - [email protected]
- Bump to 2.13.3
- Remove upstream patch, -22-about-me.diff.

* Tue Nov 15 2005 - [email protected]
- Patch code so about-me applet can build, and turn on --enable-aboutme
  at configure time.

* Wed Nov 09 2005 - [email protected]
- Disable gnome-screensaver temporarily. Fixes #6346174.

* Thu Oct 13 2005 - [email protected]
- Remove upstream patch, control-center-19-xcursor.diff.

* Tue Oct 11 2005 - [email protected]
- Bump to 2.12.1

* Wed Sep 21 2005 - [email protected]
- Add patch 19 so that if xcursor is not present, the configure doesn't
  bomb out.  The HAVE_XCURSOR stuff is #ifdef'ed in the code so this
  should just build okay without xcursor support.  Better than not
  building at all. 

* Sat Sep 17 2005 - [email protected]
- Bump to 2.12.0

* Thu Aug 25 2005 - [email protected]
- Bump to 2.11.92
- add help to %files

* Thu Aug 25 2005 - [email protected]
- Add automake build dependency, as it will fail for earlier automake.

* Mon Aug 15 2005 - [email protected]
- remove patches read-alert-dialog.diff (reported in bugzilla #172090) and
  menu-reorder.diff. Renumber patches.

* Mon Aug 15 2005 - [email protected]
- Bump to 2.11.91.
* Thu Aug 04 2005 - [email protected]
- patches 37, 38, 40 merged by Wipro; renamed 37, 38, 39, 40 to
  17, 18, 19, 20.

* Fri Jul 22 2005 - [email protected]
- Updated control-center-13-anykey-grab.diff to fix the gnome-setting-daemon
  crash on gnome-2.10 Linux.

* Tue Jun 14 2005 - [email protected]
- Remove backgrounds.xml and backgrounds-linux.xml as they are now in a patch.

* Mon Jun 06 2005 - [email protected]
- Added patches/control-center-40-xkb-check-remote-login.diff to
  make gnome-settings-daemon and the keyboard capplet check for 
  remote login before activating the XKB extension.
  Fixes bug #6271501.

* Thu Jun 02 2005 - [email protected]
- Added patch 16 to remove Wall from Makefile.am files.

* Thu May 26 2005 - [email protected]
- Add patch control-center-39-background-crash.diff to fix 
  crash when background properties capplet is closed with
  with the WM's X button option. Fixes #6275902 

* Sat May 21 2005 - [email protected]
- Add patch control-center-38-layout-deletion.diff from Leena.
  Fixes the issue of deleting all the keyboard layouts #6272904
 
* Fri May 13 2005 - [email protected]
- Redoing patches for gnome-2.10

* Fri Apr 29 2005 - [email protected]
- Added control-center-36-https-default-browser.diff to make the default browser
  settings apply for https also.
  Fixes #6262124.
 
* Thu Mar 31 2005 - [email protected]
- Added control-center-35-g11n-filename.diff to avoid segv with filename.
  Fixes 6247833

* Thu Mar 31 2005 - [email protected]
- Added control-center-34-read-alert-dialog.diff patch to make screen reader read the
  sticky key alert dialog. Fixes bug #6240627.

* Mon Mar 07 2005 - [email protected]
- Added patch control-center-32-homefolder-keybindings.diff. Makes the shortcut for  
  home folder go to home directory of user instead of computer:///
  Fixes bug #6231348. 

* Fri Feb 25 2005 - [email protected]
- Added patch control-center-31-dnd-non-image.diff. Prevents from adding non image 
  files to the desktop background capplet when dnd from nautilus. Fixes bug #6227064

* Fri Feb 21 2005 - [email protected]
- Added patch control-center-30-remove-warning-dialog.diff.
  Remove the warning dialog. Fixes bug #6215642

* Fri Feb 11 2005 - [email protected]
- Added patch control-center-29-default-browser.diff. Fixes the issue of changing the default browser. Fixes bug#6217648.

* Tue Jan 25 2005 - [email protected]
- Add patch control-center-28-a11y-issues.diff. Fixed a11y issues in keyboard
  accessibility capplet.
  Fixes #5028065

* Mon Dec 20 2004 - [email protected]
- Added Obsoletes/Provides for acme which has been merged into
  control-center in 2.6. Fixes 6211773.

* Thu Dec 09 2004 - [email protected]
- Add patch  control-center-27-settings-daemon-per-display.diff
  Starts g-s-d per display. fixes 4886754, 6195818. bugzilla id 94049

* Wed Dec 08 2004 - [email protected]
- Modified patch control-center-09-fontview-performance.diff
  The gettexted string shouldn't be freed.

* Tue Dec 07 2004 - [email protected]
- Add patch control-center-26-window-props.diff to fix bug #6191372.

* Wed Nov 10 2004 - [email protected]
- Added patch control-center-25-volume-control.diff to control sound 
  using keyboard shortcut keys. Fixes Bug #6173921.

* Tue Nov 09 2004 - [email protected]
- Add patch to fix keybinding capplet behave right when caps lock 
  is on. Fixes #6180767

* Thu Nov 04 2004 - [email protected]
- Added control-center-23-g11n-potfiles.diff to update POTFILES.in 

* Thu Oct 28 2004 - [email protected]
- Add gnome-at-properties.1, gnome-font-viewer.1 man pages

* Tue Oct 19 2004 - [email protected]
- Forward port a patch from GNOME 2.0 to add custom keyboard
  shortcuts. Fixes #4878555

* Tue Oct 19 2004 - [email protected]
- Removing control-center-21-sun-volume-keys.diff as it should get added only for
  sparc. 

* Tue Oct 19 2004 - [email protected]
- Added control-center-21-sun-volume-keys.diff to associate the proper
  entries for the sunkeys (volume up, down and mute) to control volume.
  Fixes the Bug #6173921.   

* Mon Oct 18 2004 - [email protected]
- Added control-center-20-build-typing-break.diff to check for correct
  screensaver library on solaris which is required to build typing-break.
  Fixes bug #5083708.

* Wed Oct 06 2004 - [email protected]
- Added control-center-19-logout-shortcut.diff Patch to remove the
  "/apps/gnome_settings_daemon/keybindings/power" and use
  "/apps/metacity/global_keybindings/logout" in the capplet.
  Fixes bug #5101706.

* Fri Sep 24 2004 - [email protected]
- Added control-center-17-g11n-potfiles.diff

* Sat Sep 11 2004 - [email protected]
- Move Solaris specific LDFLAGS to the Solaris spec file

* Fri Sep 10 2004 - [email protected]
- Set LDFLAGS so Xrandr and Xrender can be found.

* Thu Aug 26 2004 - [email protected]
- Modified Patch control-center-03-help-links.diff to provide help
  link to Assistive Technology.

* Thu Aug 19 2004 - [email protected]
- Added patch control-center-16-solaris-tar-command.diff to
  fix problem of directory option for Solaris tar.

* Fri Aug 06 2004 - [email protected]
- Updated control-center-07-g11n-potfiles.diff

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to control-center-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- ported to rpm4/suse9.1, packaged missing files, added new devel pkg

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Fri Jun 25 2004 - [email protected]
- Get the backgrounds.xml file in DATADIR/gnome-background-properities
  The Add Wallpaper file selector dialog will open $HOME/Document/Pictures
  or $HOME/Documents if pictures dir does not exist

* Mon Jun 14 2004 - [email protected]
  Added control-center-14-customize-system-bell.diff and
  control-center-15-keyboard-layout.diff to fix bugs 5046592 and 5046596
  respectively.

* Tue Jun 8 2004 - [email protected]
- Added the missing %{_sysconfdir}/gnome-vfs-2.0/modules/*

* Mon May 31 2004 - [email protected]
* Add control-center-12-accessible-names.diff. Backport of fix for
  bugzilla - bug #142402.

* Tue May 25 2004 - [email protected]
- Changed name of control-center-10-potfiles.diff to 
  control-center-10-g11n-potfiles.diff to comply with g11n naming standard.
  Patch control-center-10-g11n-potfiles.diff replaced 
  control-center-10-potfiles.diff

* Mon May 24 2004 -  [email protected]
- Added control-center-11-file-types-hang.diff to fix the file types capplet 
  hang when the requested icon file is not found. Bug #5028020.
  Uploaded the patch in bugzilla - bug #142894.

* Fri May 21 2004 -  [email protected]
- restore 09-potfiles.diff as 10-potfiles.diff.

* Fri May 21 2004 -  [email protected]
- Fixed bug 5050932: gnome-font-viewer takes too long time to view CJK fonts
  Added patch control-center-09-fontview-performance.diff and hope it can go
  upstream, see http://bugzilla.gnome.org/show_bug.cgi?id=142878, 

* Fri May 21 2004 -  [email protected]
- Fixed bug 5050926: Can't launch gnome-font-viewer in nautilus.
  Updated the spec file to include those files under /usr/lib/gnome-vfs-2.0/modules,
  /usr/share/application-registry and /usr/share/mime-info directory

* Fri May 14 2004 - [email protected]
- Modified patch control-center-03-help-links.diff to 
  remove obsolete stuff.
  Removed patch control-center-09-window-properties-help.diff.

* Wed May 12 2004 - [email protected]
- Updated l10n content to control-center-l10n-po-1.1.tar.bz2

* Tue May 04 2004 - [email protected]
- Added patch control-center-09-window-properties-help.diff to
  s/wgos*.xml/user-guide.xml.

* Mon Apr 26 2004 - [email protected]
- Bump to 2.6.1

* Wed Apr 21 2004 - [email protected]
- Appended "desktop_gnome_peripherals_keyboard_xkb.schemas" file for
  schemas list.

* Fri Apr 16 2004 - [email protected]
- Set the correct browser in command entry box.

* Tue Apr 6 2004 - [email protected]
- Bump to 2.6.0.3, and merge a bunch of the menu/title patches
  into one easy maintainable one. Patch the forte build issue
  on linux as well - we shouldn't special case this.

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to control-center-l10n-po-1.0.tar.bz2

* Thu Mar  4 2004 - [email protected]
- Added control-center-09-g11n-schemas.diff to localize schemas.in
- Added control-center-10-g11n-potfiles.diff to fix 4957377

* Thu Feb 26 2004 - [email protected]
- add libexecdir to pick up missing files

* Thu Feb 26 2004 - [email protected]
- Update Distro, l10n to 0.8

* Tue Feb 24 2004 - [email protected]
- define correct auto*-jds and libtool-jds versions

* Tue Feb 24 2004 - [email protected]
- set and export ACLOCAL_FLAGS on linux to
  pick up necessary JDS_CBE  aclocal macros.

* Fri Feb 20 2004 - [email protected]
- Added build dependencies on jds CBE auto* tools
  and set PATH to pick up their location on linux

* Wed Feb 18 2004 - [email protected]
- Bump to 2.5.3

* Wed Dec 17 2003 - [email protected]
- Bump to 2.5.0

* Fri Oct 31 2003 - [email protected]
- Remove the Sun Support keywords since
  we're moving away from the Extras menu.

* Tue Oct 21 2003 - [email protected]
- Add nautilus dependancy

* Mon Oct 19 2003 - [email protected]
- New tarball, bump version, reset release

* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la

* Tue Aug 05 2003 - [email protected]
- Close keybindings capplet on escape

* Tue Aug 05 2003 - [email protected]
- Add some metacity docs.

* Sat Aug 02 2003 - [email protected]
- Now we can theme X cursors

* Sat Aug 02 2003 - [email protected]
- Don't install gnomecc.desktop

* Fri Aug 01 2003 - [email protected]
- Add menu categorization cluepackets. Or something.

* Thu Jul 24 2003 - [email protected]
- Hide the password entry

* Tue Jul 22 2003 - [email protected]
- Change the window titles

* Mon Jul 21 2003 - [email protected]
- Reorder desktop preferences menu

* Thu Jul 17 2003 - [email protected]
- gnome-keybindings-properties uses the panel keys which are essential
  obsolete in the current release of GNOME. So replace these keys
  with the appropriate one that are appropriate in metacity.

* Thu Jul 17 2003 - [email protected]
- s/Files types and programs/File Associations

* Thu Jul 17 2003 - [email protected]
- Make sure the window icon lookup uses icon themes

* Tue Jul 15 2003 - [email protected]
- Backported the option to open the fonts folder from the fonts control panel.

* Wed Jul 09 2003 - [email protected]
- Added gnome-keyboard-layout to control centre.

* Fri Jul 03 2003 - [email protected]
- Add correct location for new sound icon and 
  add a theme icon.

* Fri Jul 03 2003 - [email protected]
- Install the .directory things

* Mon Jun 30 2003 - [email protected]
- add display properties capplet

* Fri Jun 27 2003 - [email protected]
- bump the version on the control center tarball

* Wed Jun 25 2003 - [email protected]
- add control-center-01-theme-failsafe.diff

* Wed May 14 2003 - [email protected]
- initial release