evolution-data-server.spec
author dc144907
Mon, 10 Apr 2006 18:32:16 +0000
changeset 7038 ab44c695d35e
parent 6999 c8ffea0d1cf3
child 7071 57a7c947d6c5
permissions -rw-r--r--
2006-04-10 Damien Carbery <[email protected]> * gnome-screensaver.spec: Bump 2.14.1. * gnopernicus.spec: Bump 1.0.4. * nautilus-cd-burner.spec: Bump 2.14.1. * deskbar-applet.spec: Bump 2.14.1. * control-center.spec: Bump 2.14.1. * gtkhtml.spec: Bump 3.10.1. * evolution-data-server.spec: Bump 1.6.1. * evolution-exchange.spec: Bump 2.6.1. * evolution.spec: Bump 2.6.1. * libsoup.spec: Bump 2.2.92.

# spec file for package evolution-data-server
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         evolution-data-server
License:      GPL
Group:        System/Libraries/GNOME
Version:      1.6.1
Release:      2
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Backend Library for Evolution
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/1.6/%{name}-%{version}.tar.bz2
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/evolution-data-server
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define api_version 1.2
%define base_version 1.6

%define libbonobo_version 2.4.2
%define gnome_vfs_version 2.4
%define libgnome_version 2.4
%define GConf_version 2.4
%define libsoup_version 2.2.3
%define gtk_doc_version 1.1
%define openldap2_version 2.1.4

Requires:       libbonobo >= %{libbonobo_version}
Requires:       gnome-vfs >= %{gnome_vfs_version}
Requires:       libgnome >= %{libgnome_version}
Requires:       GConf >= %{GConf_version}
Requires:       libsoup >= %{libsoup_version}
Requires:       openldap2-client >= %{openldap2_version}

BuildRequires:  libbonobo-devel >= %{libbonobo_version}
BuildRequires:  gnome-vfs-devel >= %{gnome_vfs_version}
BuildRequires:  libgnome-devel >= %{libgnome_version}
BuildRequires:  GConf-devel >= %{GConf_version}
BuildRequires:  libsoup-devel >= %{libsoup_version}
BuildRequires:  openldap2-devel >= %{openldap2_version}
BuildRequires:  gtk-doc >= %{gtk_doc_version}
BuildRequires:  bison
BuildRequires:  heimdal-devel

%description
evolution-data-server is the backend library for Evolution, providing
support for calendar and addressbook.

%package devel
Summary:      Development Backend Library for Evolution
Group:        Development/Libraries/GNOME
Autoreqprov:  on
Requires:     %name = %version
BuildRequires:  libbonobo-devel >= %{libbonobo_version}
BuildRequires:  gnome-vfs-devel >= %{gnome_vfs_version}
BuildRequires:  libgnome-devel >= %{libgnome_version}
BuildRequires:  GConf-devel >= %{GConf_version}
BuildRequires:  openldap2-devel >= %{openldap2_version}
BuildRequires:  libsoup-devel >= %{libsoup_version}

%description devel
evolution-data-server is the backend library for Evolution, providing
support for calendar and addressbook.

%prep
%setup -q

%build

%ifos linux
%define ldap_option --with-openldap=%{_prefix}
%define krb5_option --with-krb5=%{_prefix}
%define firefox_prefix /usr
%else
%define ldap_option --with-sunldap=%{_prefix}
%define krb5_option --with-krb5=no
%define firefox_prefix /usr/sfw
%endif

export LDFLAGS="$LDFLAGS -R%{_libdir}/mozilla"
export CFLAGS="$CFLAGS $RPM_OPT_FLAGS"

aclocal $ACLOCAL_FLAGS
libtoolize --force
glib-gettextize --force --copy
intltoolize --force --automake
autoheader
automake -a -f -c --gnu
autoconf
./configure --prefix=%{_prefix}						\
	    --libexecdir=%{_libexecdir}					\
	    --sysconfdir=%{_sysconfdir}					\
	    --enable-nss=yes						\
	    --enable-smime=yes						\
	    --enable-nntp=yes						\
	    --with-nss-includes=%{firefox_prefix}/include/firefox/nss	\
	    --with-nss-libs=%{firefox_prefix}/lib/firefox		\
	    --with-nspr-includes=%{firefox_prefix}/include/firefox/nspr	\
	    --with-nspr-libs=%{firefox_prefix}/lib/firefox		\
	    %ldap_option						\
	    --with-krb4=%{_prefix}					\
	    %krb5_option

make

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make -i install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr (-, root, root)
%doc AUTHORS COPYING ChangeLog NEWS README
%{_libdir}/*.so.*
%{_libdir}/evolution-data-server-%{api_version}/extensions/*.so
%{_libdir}/evolution-data-server-%{api_version}/camel-providers/*.so
%{_libdir}/evolution-data-server-%{api_version}/camel-providers/*urls
%{_libdir}/bonobo/servers/*
%{_libexecdir}/*
%{_datadir}/evolution-data-server-%{base_version}/*
%{_datadir}/pixmaps/evolution-data-server-%{base_version}/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo

%files devel
%defattr (-, root, root)
%{_libdir}/*.so
%{_includedir}/evolution-data-server-%{base_version}/*
%{_libdir}/pkgconfig/*.pc
%{_datadir}/gtk-doc/*
%{_datadir}/idl/*

%changelog
* Mon Apr 10 2006 - [email protected]
- Bump to 1.6.1.

* Tue Apr 04 2006 - [email protected]
- Remove .a/.la files in linux spec.

* Thu Mar 30 2006 - [email protected]
- Alter "remove *.a/*.la files part" to SUNWevolution-data-server.spec

* Mon Mar 13 2006 - [email protected]
- Bump to 1.6.0.

* Tue Feb 28 2006 - [email protected]
- Bump to 1.5.92.

* Tue Feb 14 2006 - [email protected]
- Bump to 1.5.91.

* Mon Jan 30 2006 - [email protected]
- Bump to 1.5.90.

* Thu Jan 19 2006 - [email protected]
- Bump to 1.5.5.

* Wed Jan 04 2006 - [email protected]
- Bump to 1.5.4.

* Wed Dec 21 2005 - [email protected]
- Correct Source filed.
- Remove upstreamed patch evolution-data-server-6341837.diff.
- Remove upstreamed patch evolution-data-server-6359639.diff.

* Fri Dec 19 2005 - [email protected]
- Bump to 1.5.3.

- Bump to 1.4.2.1.
* Fri Dec 09 2005 - [email protected]
- Add the patch evolution-data-server-6359639.diff

* Fri Dec 02 2005 - [email protected]
- Bump to 1.4.2.1.
- Add the patch evolution-data-server-6341837.diff

* Thu Dec 01 2005 - [email protected]
- Remove upstream patch, patches/evolution-data-server-01-6340601.diff.

* Tue Nov 29 2005 - [email protected]
- Bump to 1.4.2.

* Wed Nov 23 2005 - [email protected]
- Add patch evolution-data-server-01-6340601.diff.

* Fri Oct 21 2005 - [email protected]
- Use firefox nss/nspr lib instead of mozilla's.

* Wed Oct 12 2005 - [email protected]
- change --with-ldap to --with-sunldap.

* Tue Oct 11 2005 - [email protected]
- Bump to 1.4.1.1.

* Mon Oct 10 2005 - [email protected]
- Bump to 1.4.1.
- Move obsolete patches:
  evolution-data-server-01-libgobject.diff,
  evolution-data-server-02-pretty_function.diff.
- Move upstreamed patches:
  evolution-data-server-03-lock-helper.diff.

* Thu Sep 15 2005 - [email protected]
- Add define krb5_option, disable Kerberos 5 on Solaris.

* Thu Sep 8 2005 - [email protected]
- Add krb5_prefix define and enable Kerberos 5.
- Fix CFLAGS problem.
 
* Wed Sep 7 2005 - [email protected]
- Bump to 1.4.0.

* Tue Sep 6 2005 - [email protected]
- Call configure instead of autogen.sh because autogen.sh not in 1.3.8 tarball.
  Remove some ver nums from %files because there is no consistency.
  Remove patch3 and reorder.

* Tue Sep  6 2005 - [email protected]
- Move patch evolution-data-server-04-ldap-ssl.diff and Source1 
  evolution-data-server-ldap-ssl-patch.tar to SUNWgnutls.spec.

* Fri Sep 2 2005 - [email protected]
- Add option --enable-nntp=yes to support news groups.
- Use SUN LDAP on solaris with %ldap_option.
- Add Source1 Patch4 to support SUN LDAP
- Use ./autogen.sh to replace libtoolize aclocal automake autoconf ./configure 
  steps, because we need build code that checked out from community HEAD.
- Temporarily disable Kerberos for header files are not installed on Nevada.

* Tue Aug 30 2005 - [email protected]
- Redefine major_version to 1.2 so that %files section can use while patch 03 
  redefines it to 1.2.

* Tue Aug 30 2005 - [email protected]
- Bump to 1.3.8

* Mon Aug 15 2005 - [email protected]
- Bump to 1.3.7.

* Thu Jul 28 2005 - [email protected]
- Rename --with-openldap configure option to --with-ldap as a result of Jerry's
  patch from Jul 27. Also remove '%ifos' code around this option.

* Wed Jul 27 2005 - [email protected]
- Add patch from Jerry Pu ([email protected]) to support LDAP on Solaris.

* Thu Jul 14 2005 - [email protected]
- Add 5 patches to build on Solaris.

* Wed Jun 15 2005 - [email protected]
- Bump to 1.2.3

* Tue May 10 2005 - [email protected]
- Bump to 1.2.2

* Tue Nov 23 2004 - [email protected]
- Bump to 1.0.2

* Thu Jun 17 2004 - [email protected]
- rpm4´ified

* Thu Jun 17 2004 - [email protected]
- Bump to 0.0.94.1

* Tue Jun 08 2004 - [email protected]
- Bump to 0.0.94

* Fri May 21 2004 - [email protected]
- Bump to 0.0.93

* Tue Apr 20 2004 - [email protected]
- Bump to 0.0.92

* Mon Apr 19 2004 - [email protected]
- Initial spec file for evolution-data-server 0.0.91