evolution-exchange.spec
author dc144907
Mon, 10 Apr 2006 18:32:16 +0000
changeset 7038 ab44c695d35e
parent 6999 c8ffea0d1cf3
child 7339 4a059bb81d5e
permissions -rw-r--r--
2006-04-10 Damien Carbery <[email protected]> * gnome-screensaver.spec: Bump 2.14.1. * gnopernicus.spec: Bump 1.0.4. * nautilus-cd-burner.spec: Bump 2.14.1. * deskbar-applet.spec: Bump 2.14.1. * control-center.spec: Bump 2.14.1. * gtkhtml.spec: Bump 3.10.1. * evolution-data-server.spec: Bump 1.6.1. * evolution-exchange.spec: Bump 2.6.1. * evolution.spec: Bump 2.6.1. * libsoup.spec: Bump 2.2.92.

#
# spec file for package evolution-exchange
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

Name:         evolution-exchange
License:      GPL
Group:        System/Libraries/GNOME
Version:      2.6.1
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Evolution connector for Microsoft Exchange
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.6/%{name}-%{version}.tar.bz2
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/ximian-connector
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define evolution_version 2.2
%define libgnomeui_version 2.10.0
%define libglade_version 2.5.0
%define libsoup_version 2.2.3
%define GConf_version 2.10.0
%define openldap2_version 2.2.6
%define gtk_doc_version 1.3
%define oxygen2_version 1.4

Requires:       evolution >= %{evolution_version}
Requires:       libgnomeui >= %{libgnomeui_version}
Requires:       libglade >= %{libglade_version}
Requires:       libsoup >= %{libsoup_version}
Requires:       GConf >= %{GConf_version}
Requires:       openldap2-client >= %{openldap2_version}

BuildRequires:  evolution-devel >= %{evolution_version}
BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}
BuildRequires:  libglade-devel >= %{libglade_version}
BuildRequires:  libsoup-devel >= %{libsoup_version}
BuildRequires:  GConf-devel >= %{GConf_version}
BuildRequires:  openldap2-devel >= %{openldap2_version}
BuildRequires:  gtk-doc >= %{gtk_doc_version}

Obsoletes:	oxygen2  <= %{oxygen2_version}
Obsoletes:      ximian-connector <= 2.2.2
Provides:       ximian-connector = 2.2.2

%description
Provides a connector library for Evolution to access Microsoft Exchange.

%prep
%setup -q

%build

%ifos linux
%define ldap_option --with-openldap=%{_prefix}
%define krb5_option --with-krb5=%{_prefix}
%else
%define ldap_option --with-sunldap=%{_prefix}
%define krb5_option --with-krb5=no
%endif

export CFLAGS="$CFLAGS $RPM_OPT_FLAGS"

aclocal $ACLOCAL_FLAGS
libtoolize --force
glib-gettextize --force --copy
intltoolize --force --automake
autoheader
automake -a -f -c --gnu
autoconf

./configure  --prefix=%{_prefix}				\
	     %ldap_option					\
	     %krb5_option

make

%install
#? export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make -i install DESTDIR=$RPM_BUILD_ROOT
#? unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'

%clean
rm -rf $RPM_BUILD_ROOT

%post
#? export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
#? SCHEMAS="apps_evolution_exchange.schemas"
#? for S in $SCHEMAS; do
#?         gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
#? done

%postun

%files
%defattr (-, root, root)
%doc AUTHORS COPYING ChangeLog NEWS README
%{_bindir}/*
%{_libdir}/bonobo/servers/*
%{_libdir}/evolution-data-server-1.2/camel-providers/*.so*
%{_libdir}/evolution-data-server-1.2/camel-providers/*.urls
%{_libexecdir}/evolution/2.6/*
%{_datadir}/gtk-doc/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/evolution-exchange/*
#? %config %{_sysconfdir}/gconf/schemas/*

%changelog
* Mon Apr 10 2006 - [email protected]
- Bump to 2.6.1.

* Tue Apr 04 2006 - [email protected]
- Remove .a/.la files in linux spec.

* Thu Mar 30 2006 - [email protected]
- Alter "remove *.a/*.la files part" to SUNWevolution-exchange.spec

* Mon Mar 13 2006 - [email protected]
- Bump to 2.6.0.

* Tue Feb 28 2006 - [email protected]
- Bump to 2.5.92.

* Tue Feb 14 2006 - [email protected]
- Bump to 2.5.91.

* Mon Jan 30 2006 - [email protected]
- Bump to 2.5.9.0.

* Thu Jan 19 2006 - [email protected]
- Bump to 2.5.5.

* Wed Jan 04 2006 - [email protected]
- Bump to 2.5.4.

* Wed Dec 21 2005 - [email protected]
- Correct Source filed.

* Mon Dec 19 2005 - [email protected]
- Bump to 2.5.3.

* Tue Nov 29 2005 - [email protected]
- Bump to 2.4.2.

* Wed Oct 12 2005 - [email protected]
- change --with-ldap to --with-sunldap.

* Mon Oct 10 2005 - [email protected]
- Bum to 2.4.1.

* Thu Sep 15 2005 - [email protected]
- Use aclocal, ..., ./configure steps, not ./autogen,
  because download tarball does not have autogen.sh.
- Add define krb5_option, disable Kerberos 5 on Solaris.

* Wed Sep 7 2005 - [email protected]
- Bump to 2.4.0.

* Fri Sep 2 2005 - [email protected]
- Use --with-openldap=no on solaris with %ldap_option because patch is not ready.
- Use ./autogen.sh to replace libtoolize aclocal automake autoconf ./configure
  steps, because we need build code that checked out from community HEAD.

* Wed Aug 24 2005 - [email protected]
- Move the ximian-connector component over to evolution-exchange
  and bump to 2.3.8

* Tue Aug 16 2005 - [email protected]
- Bump to 2.2.3.

* Thu Jul 21 2005 - [email protected]
- Turn off OpenLDAP support on Solaris as it is too old.

* Thu Jul 14 2005 - [email protected]
- Remove obsolete gnome2-macros dir from aclocal call.

* Mon Jun 27 2005 - [email protected]
- Bump to 2.2.2

* Thu Jun 17 2004 - [email protected]
- Initial spec file for ximian-connector 1.5.9