Solaris/SUNWgnome-session.spec
author laca
Tue, 20 Apr 2004 03:44:00 +0000
changeset 2502 ae062627ff2c
parent 2500 e0a964599faa
child 2621 ffa9546fd848
permissions -rw-r--r--
2004-04-20 Laszlo Peter <[email protected]> * SUNWevolution-openldap.spec, SUNWevolution-openssl.spec, SUNWevolution.spec, SUNWgnome-a11y-reader.spec, SUNWgnome-archive-mgr.spec, SUNWgnome-audio.spec, SUNWgnome-base-libs.spec, SUNWgnome-calculator.spec, SUNWgnome-component.spec, SUNWgnome-config.spec, SUNWgnome-desktop-prefs.spec, SUNWgnome-display-mgr.spec, SUNWgnome-file-mgr.spec, SUNWgnome-games.spec, SUNWgnome-image-viewer.spec, SUNWgnome-img-editor.spec, SUNWgnome-libs.spec, SUNWgnome-media.spec, SUNWgnome-panel.spec, SUNWgnome-pdf-viewer.spec, SUNWgnome-pilot-link.spec, SUNWgnome-ps-viewer.spec, SUNWgnome-remote-desktop.spec, SUNWgnome-session.spec, SUNWgnome-terminal.spec, SUNWgnome-text-editor.spec, SUNWgnome-vfs.spec, SUNWgnome-wm.spec, SUNWopenjade.spec: fix root subpkg permissions

#
# spec file for package SUNWgnome-session
#
# includes module(s): gnome-session
#
# Copyright (c) 2004 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include Solaris.inc

%use gsession = gnome-session.spec

Name:                    SUNWgnome-session
Summary:                 GNOME session manager - platform dependent files, /usr filesystem
Version:                 2.6.0
Source:                  gnome-session-properties.1
Source1:                 gnome-session-save.1
Source2:                 gnome-session.1
Source3:                 gnome-smproxy.1
Source4:                 gnome-wm.1
Source5:                 default.session.5
SUNW_BaseDir:            %{_prefix}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWgnome-vfs-root
Requires: SUNWgnome-vfs-share
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-config
# Requires: SUNWgnome-component
Requires: SUNWpl5u
Requires: SUNWbzip
Requires: SUNWzlib
Requires: SUNWlxml

%package share
Summary:                 GNOME session manager - platform independent files, /usr/share
SUNW_BaseDir:            %{_prefix}
%include default-depend.inc
Requires: SUNWpl5u

%package root
Summary:                 GNOME session manager - platform dependent files, / filesystem
SUNW_BaseDir:            /
%include default-depend.inc

%prep
rm -rf %name-%version
mkdir %name-%version
%gsession.prep -d %name-%version

%build
export PERL5LIB=%{_prefix}/perl5/site_perl/5.6.1/sun4-solaris-64int
export PKG_CONFIG_PATH=%{_libdir}/pkgconfig:/usr/lib/pkgconfig
export MSGFMT="/usr/bin/msgfmt"
export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
export LDFLAGS="-L%{_libdir} -R%{_libdir}"

%gsession.build -d %name-%version

%install
%gsession.install -d %name-%version
export GCONF_CONFIG_SOURCE=xml::$RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults
for S in $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas/*.schemas; do
  %{_bindir}/gconftool-2 --makefile-install-rule $S >/dev/null
done
chmod -R a+rX $RPM_BUILD_ROOT/%{_sysconfdir}/gconf
rm $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/schemas/?gconf.xml
rm $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/apps/?gconf.xml
rm $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/schemas/apps/?gconf.xml
rm -rf $RPM_BUILD_ROOT%{_mandir}
install -d $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0644 %SOURCE0 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0644 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0644 %SOURCE4 $RPM_BUILD_ROOT%{_mandir}/sman1
install -d $RPM_BUILD_ROOT%{_mandir}/sman5
install --mode=0644 %SOURCE5 $RPM_BUILD_ROOT%{_mandir}/sman5

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, other)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*

%files share
%defattr (-, root, other)
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/gnome
%{_datadir}/pixmaps
%{_datadir}/locale
%{_datadir}/control-center-2.0
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*

%files root
%attr (0755, root, sys) %dir %{_sysconfdir}
%defattr (-, root, other)
%{_sysconfdir}/*
%defattr (0755, root, sys)

%changelog
* Wed Mar 24 2004 - [email protected]
- Added SGML man page integration
* Thu Mar 04 2004 - <[email protected]>
- fix 2 more gconf clashes
* Sat Feb 28 2004 - <[email protected]>
- fix gconf dir permissions (a+rX)
- remove clashing gconf.xml file
* Mon Feb 23 2004 - <[email protected]>
- install gconf schemas at end of install stage.