gnome-pilot.spec
author fujiwara
Fri, 05 Nov 2004 12:17:36 +0000
changeset 4455 aea26bce3124
parent 4409 4fec71e58697
child 4541 aa555c8d3378
permissions -rw-r--r--
2004-11-05 Takao Fujiwara <[email protected]> * ext-sources/l10n-configure.sh: Added to patch ALL_LINGUAS issues automatically * *.spec: Updated

Name:     	gnome-pilot
License:        GPL/LGPL
Group:		Applications/Communications
Version: 	2.0.10
Release:	43
Distribution:   Cinnabar	
Vendor:		Sun Microsystems, Inc.
Summary:	PalmOS link utilities
Source:		http://ftp.gnome.org/pub/GNOME/sources/gnome-pilot/2.0/%{name}-%{version}.tar.bz2
Source1:    gnome-pilot-l10n-po-1.7.tar.bz2
Source2:    gnome-pilot-docs-0.2.tar.bz2
Source3:    gnome-pilot-l10n-online-help-ci.tar.bz2
Source4:    gpilot-install-file.1.gz
Source5:    gpilotd-control-applet.1.gz
Source6:    l10n-configure.sh
Patch1:     gnome-pilot-01-potfiles-in.diff
Patch2:     gnome-pilot-02-menu-entry.diff
Patch3:     gnome-pilot-03-add-all-linguas.diff
Patch4:     gnome-pilot-04-g11n-i18n-ui.diff
Patch5:     gnome-pilot-05-automake-fix.diff
Patch6:		gnome-pilot-06-C_docs.diff
Patch7:     gnome-pilot-07-help-links.diff
Patch8:     gnome-pilot-08-l10n-online-help.diff
URL:		http://ftp.gnome.org/pub/GNOME/sources/gnome-pilot
BuildRoot:	%{_tmppath}/%{name}-%{version}-root
Docdir:         %{_defaultdocdir}/gnome-pilot
Autoreqprov:    on
Prereq:		scrollkeeper

%define pilot_link_version 0.11.8 
%define scrollkeeper_version 0.3.14
%define gnome_panel_version 2.6.1

Requires:	scrollkeeper >= %{scrollkeeper_version}
Requires:	gnome-panel >= %{gnome_panel_version}
Requires:       pilot-link >= %{pilot_link_version}
BuildRequires:	scrollkeeper >= %{scrollkeeper_version}
BuildRequires:  javahelp-convert
BuildRequires:	pilot-link-devel >= %{pilot_link_version}

%description
GNOME Pilot is a collection of programs and daemons for using 
Palm OS-based systems with GNOME, the complete user-friendly desktop 
based entirely on free software.

%package -n gnome-pilot-devel
Summary:	Pilot development header files.
Group:		Development/Libraries
Requires:	gnome-pilot = %{version}-%{release}
Requires:	pilot-link-devel >= %{pilot_link_version}

%description -n gnome-pilot-devel
GNOME Pilot is a collection of programs and daemons for using 
Palm OS-based systems with GNOME, the complete user-friendly desktop 
based entirely on free software.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
bzcat %SOURCE1 | tar xvf -
bzcat %SOURCE2 | tar xvf -
bzcat %SOURCE3 | tar xvf -
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1

bash -x %SOURCE6

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

LC_ALL=
LANG=
export LC_ALL LANG
libtoolize --force
aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"				\
./configure  --prefix=%{_prefix}		\
	     --sysconfdir=%{_sysconfdir}	\
	     --mandir=%{_mandir}		\
             --libexecdir=%{_libexecdir}        \
	     --localstatedir=/var
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE4 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE5 $RPM_BUILD_ROOT%{_mandir}/man1

javahelp-convert-install $RPM_BUILD_ROOT %{name} %{name}.xml

rm $RPM_BUILD_ROOT%{_libdir}/gnome-pilot/conduits/*.a
rm $RPM_BUILD_ROOT%{_libdir}/gnome-pilot/conduits/*.la
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la


%clean
rm -rf $RPM_BUILD_ROOT

%post
scrollkeeper-update -q
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="pilot.schemas"
for S in $SCHEMAS; do
	gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%postun
scrollkeeper-update -q

%files
%defattr(-, root, root)
%{_datadir}/locale/*/LC_MESSAGES/*
%{_datadir}/control-center-2.0/capplets/*
%{_datadir}/idl/*
%{_datadir}/mime-info/*
%{_datadir}/pixmaps/*
%{_bindir}/*
%{_libexecdir}/*
%{_libdir}/bonobo/servers/*
%{_libdir}/gnome-pilot/conduits/*.so
%dir %{_datadir}/gnome-pilot
%dir %{_datadir}/gnome-pilot/glade
%{_datadir}/gnome-pilot/conduits
%{_datadir}/gnome-pilot/glade/*.png
%{_datadir}/gnome-pilot/glade/*.glade
%{_datadir}/gnome/help/*
%{_datadir}/gnome/javahelp/*
%{_datadir}/omf/*
%{_sysconfdir}/gconf/schemas/pilot.schemas
%{_libdir}/*.so.*
%{_datadir}/gnome-2.0/ui/*
%{_mandir}/man1/*

%files -n gnome-pilot-devel
%defattr(-, root, root)
%{_includedir}/*
%{_libdir}/pkgconfig/*
%{_libdir}/*.so

%changelog
* Thu Oct 28 2004 - [email protected]
- Add gpilot-install-file.1, gpilotd-control-applet.1 man pages

* Wed Aug 25 2004 - [email protected]
- Added l10n help files with patch

* Thu Aug 19 2004 - [email protected]
- Integrated updated docs tarball from [email protected].

* Mon Aug 16 2004 - [email protected] 
- Help invocation for the applet is implemented.  

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gnome-pilot-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- ported to rpm4
                                                                                
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed Jun 09 2004 - [email protected]
- Integrated docs and associated patch from [email protected]

* Wed May 12 2004 - [email protected]
- Updated l10n content to gnome-pilot-l10n-po-1.1.tar.bz2

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Thu Apr 01 2004 - [email protected]
- Javahelp conversion

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to gnome-pilot-l10n-po-1.0.tar.bz2

* Tue Mar 16 2004 - [email protected]
- add patch5 to fix build with newer versions of automake
- add --libexecdir

* Fri Mar 05 2004 - [email protected]
- Modified %files section in spec file to fix 4932068
- Changed gnome-pilot-04-trans-pilot-menu.diff to gnome-pilot-04-g11n-i18n-ui.diff

* Wed Feb 18 2004 - [email protected]
- Updated distro to Cinnabar, added l10n stuff
- Port patchs 03/04, and libtoolize it

* Fri Oct 31 2003 - [email protected]
- Remove the Sun Settings keyword from the 
  menu entry patch.

* Fri Oct 10 2003 - [email protected]
- upgrade deps versions

* Fri Oct 03 2003 - <[email protected]>
- remove man pages

* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la

* Mon Aug 01 2003 - [email protected]
- Add some menu categorization

* Mon Jul 28 2003 - [email protected]
- Updated POTFILES.in

* Fri Jul 28 2003 - [email protected]
- Install the applet as part of the main
  package. There is no reason to have an 
  extra package for this one.

* Fri Jul 25 2003 - [email protected]
- Base package requires pilot-link

* Thu Jul 24 2003 - <[email protected]>
- Initial version