SUNWliboil.spec
author laca
Wed, 28 Feb 2007 18:57:18 +0000
changeset 9397 b16e349d18c5
child 9568 deb9c2d524d2
permissions -rw-r--r--
the easy part of the reorg (most files moved around)

#
# spec file for package SUNWliboil
#
# includes module(s): liboil
#
# Copyright (c) 2004 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: yippi
#
%include Solaris.inc

%use liboil = liboil.spec

Name:                    SUNWliboil
Summary:                 GNOME structured file library
Version:                 %{liboil.version}
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWgnome-base-libs
Requires: SUNWlibms
BuildRequires: SUNWgnome-base-libs
BuildRequires: SUNWgnome-base-libs-devel
%ifarch amd64 i386
BuildRequires: SUNWgcc
%endif

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc

%prep
rm -rf %name-%version
mkdir %name-%version
%liboil.prep -d %name-%version

# Note, on x86 build with gcc since liboil contains GCC-style assembly
# code which won't compile with Sun Studio.  For better performance,
# we use GCC here.
#
%build
export PKG_CONFIG_PATH=%{_pkg_config_path}
export CFLAGS="%optflags"
export LDFLAGS="%_ldflags"
%ifarch i386
export CC=gcc
export CFLAGS="-O2 -march=i586 -Xlinker -i -fno-omit-frame-pointers -fPIC -DPIC"
%endif
export RPM_OPT_FLAGS="$CFLAGS"
%liboil.build -d %name-%version

%install
%liboil.install -d %name-%version

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*.so*

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_includedir}
%dir %attr (0755, root, sys) %{_datadir}
%{_includedir}/*
%{_datadir}/gtk-doc/html/*
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*

%changelog
* Mon Feb 12 2006 - [email protected]
- Fix building with gcc based on Laca's comments.
* Wed Jan 31 2006 - [email protected]
- Build with gcc so that on x86 we compile hardware acceleration GCC asm code.
* Wed Jun 14 2006 - [email protected]
- Add new bindir files included in 0.3.9.
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Thu May 11 2006 - [email protected]
- Change build dependency on SUNWgnome-base-libs-share. That pkg is obsolete
  with files now in the base package.
* Thu Mar 23 2006 - [email protected]
- Updated Package Summary
* Fri Mar 17 2006 - [email protected]
- Updated Package Summary
* Fri Feb 17 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Wed Oct 26 2005 - [email protected]
- Created.