SUNWtgnome-tsoljdslabel.spec
author laca
Wed, 28 Feb 2007 18:57:18 +0000
changeset 9397 b16e349d18c5
permissions -rw-r--r--
the easy part of the reorg (most files moved around)

#
# spec file for package SUNWtgnome-tsoljdslabel
#
# includes module(s): tsoljdslabel
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner:stephen

%define tsoljdslabel_version 0.5
%define t_suffix
%{?nightly:%define t_suffix -%(TZ=GMT date +%Y%m%d)}
%define t_suffix -%(TZ=GMT date +%Y%m%d)

%include Solaris.inc

Name:                    SUNWtgnome-tsoljdslabel
Summary:                 GNOME Trusted Extensions Session Label Selector
Version:                 %{default_pkg_version}
Source:			 tsoljdslabel-%{tsoljdslabel_version}%{t_suffix}.tar.bz2
Source1:		 l10n-configure.sh
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%if %build_tjds

%include default-depend.inc
BuildRequires: SUNWxwts
BuildRequires: SUNWtgnome-tsol-libs-devel
BuildRequires: SUNWgnome-component-devel
BuildRequires: SUNWgnome-config-devel
BuildRequires: SUNWgnome-libs-devel
BuildRequires: SUNWgnome-vfs-devel
Requires: SUNWxwts
Requires: SUNWtgnome-tsol-libs
Requires: SUNWgnome-component
Requires: SUNWgnome-config
Requires: SUNWgnome-libs
Requires: SUNWgnome-vfs
#Requires: SUNWgnome-display-mgr

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%prep
%setup -q -n tsoljdslabel-%{tsoljdslabel_version}
%if %build_l10n
bash -x %SOURCE1
%endif

%build
export ACLOCAL_FLAGS="-I /usr/share/aclocal"

libtoolize -f
glib-gettextize --copy --force
intltoolize --copy --force
aclocal $ACLOCAL_FLAGS
autoconf
autoheader
automake -acf

./configure --with-gnome-prefix=%{_prefix} \
            --prefix=%{_prefix} \
	    --sysconfdir=%{_sysconfdir} \
	    --mandir=%{_mandir}

%install
make install DESTDIR=$RPM_BUILD_ROOT
LANG_LIST='
ar ar_EG.UTF-8
cs_CZ.ISO8859-2
da_DK.ISO8859-15
de.UTF-8 de
el_GR.ISO8859-7
en_GB.ISO8859-15 en_IE.ISO8859-15 en_US.ISO8859-15 en_US.UTF-8
es.UTF-8 es
et_EE.ISO8859-15
fi_FI.ISO8859-15
fr.UTF-8 fr
he he_IL.UTF-8
hi_IN.UTF-8
hr_HR.ISO8859-2
hu hu_HU.ISO8859-2
it.UTF-8 it
ja ja_JP.PCK ja_JP.UTF-8 ja_JP.eucJP
ko.UTF-8 ko
nl_BE.ISO8859-15 nl_NL.ISO8859-15
pl_PL.ISO8859-2 pl_PL.UTF-8
pt_BR.UTF-8 pt_BR pt_PT.ISO8859-15
ru_RU.ISO8859-5 ru_RU.UTF-8
sv.UTF-8 sv 
th_TH.ISO8859-11 th_TH.TIS620 th_TH.UTF-8 th_TH
tr_TR.ISO8859-9
zh.GBK zh.UTF-8 zh zh_HK.BIG5HK zh_TW.BIG5 zh_TW.UTF-8 zh_TW
'

cd $RPM_BUILD_ROOT/%{_prefix}/dt/config
for lang in $LANG_LIST
do
  cp -Rp C $lang
done

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, other)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/tsoljdslabel
%{_bindir}/tsoljdslabel-ui
%dir %attr(0755, root, sys) %{_datadir}
%dir %attr(0755, root, other) %{_datadir}/locale
%dir %attr(0755, root, bin) %{_datadir}/xsessions
%{_datadir}/xsessions/tsolcde.desktop
%{_datadir}/xsessions/tsoljds.desktop
%dir %attr (0755, root, bin) %{_prefix}/dt
%dir %attr (0755, root, bin) %{_prefix}/dt/config
%{_prefix}/dt/config/Xsession.tjds
%{_prefix}/dt/config/Xsession2.tjds
%{_prefix}/dt/config/Xinitrc.tjds
%dir %attr (0755, root, bin) %{_prefix}/dt/config/C
%dir %attr (0755, root, bin) %{_prefix}/dt/config/[a-z]*
%dir %attr (0755, root, bin) %{_prefix}/dt/config/*/Xresources.d
%{_prefix}/dt/config/*/Xresources.d/Xtsolresources.jds

%if %build_l10n
%files l10n
%defattr (-, root, other)
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/locale
%endif

%endif

%changelog
* Mon Nov 06 2006 - [email protected]
- removed tsoljdslabel-helper binary

* Fri Sep 15 2006 - [email protected]
- Add *-10n package.

* Sun Jul 30 2006 - [email protected]
- Always use nightly tarballs as source.

* Wed Jul 19 2006 - [email protected]
- Update Build/BuildRequires after check-deps.pl run.

* Thu Jul 13 2006 - [email protected]
- Add %{_datadir}/locale to %files, a byproduct of intltool up-rev.

* Tue Jul 11 2006 - [email protected]
- Add autogen.sh commands to %prep to permit building from 'cvs co' tarballs.

* Fri Jun 30 2006 - [email protected]
- Changed version to default for vermillion port

* Mon Jun 26 2006 - [email protected]
- Added locale dirs for /usr/dt/config/*/Xresources.d/Xtsolresources.jds
  Fixes 6439171

* Wed May 24 2006 - [email protected]
- remove man page from files and shorten summary

* Wed Mar 22 2006 - [email protected]
- Fix dir permissions after last commit.

* Sat Mar 18 2006 - [email protected]
- Fix dir permissions after last commit.

* Thu Mar 16 2006 - [email protected]
- Changed installation location for startup up config scripts from /etc to /usr
  as requested by ARC as a TCR.

* Wed Mar  8 2006 - [email protected]
- Add %dir %attr for %{_datadir} as %defattr is wrong for this dir.

* Tue Nov 22 2005 - <[email protected]>
- added root package and moved dtlogin integration to /etc/dt

* Tue Oct 04 2005 - <[email protected]>
- added dtlogin session configuration

* Thu Aug 25 2005 - <[email protected]>
- created