base-specs/gtkam.spec
author laca
Wed, 28 Feb 2007 18:57:18 +0000
changeset 9397 b16e349d18c5
child 9448 ce284dbad282
permissions -rw-r--r--
the easy part of the reorg (most files moved around)

#
# spec file for package gtkam
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: mattman
# bugdb: http://sourceforge.net/tracker/index.php?func=detail&group_id=8874&atid=108874&aid=
#
%include l10n.inc
%define gexif_version 0.5

Name:         gtkam
License:      GPL
Group:        Hardware/Other
Version:      0.1.14
Release:      3
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      A GTK Digital Camera Viewing Tool
Source:       http://easynews.dl.sourceforge.net/sourceforge/gphoto/%{name}-%{version}.tar.bz2
Source1:      http://umn.dl.sourceforge.net/libexif/gexif-%{gexif_version}.tar.bz2
Source2:      %{name}-po-sun-%{po_sun_version}.tar.bz2
# date:2003-08-15 type:branding owner:mattman bugid:1619752
Patch1:	      gtkam-01-menu-entry.diff
# date:2004-02-04 type:bug owner:yippi bugster:6329710
Patch2:	      gtkam-02-gettext.diff
# date:2004-02-04 type:bug owner:fujiwara bugid:1616317,1616320,1616397 bugster:6329710
Patch3:       gtkam-03-fixgexif.diff
URL:          http://www.gphoto.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:	      %{_datadir}/doc 

%define libgphoto2_version 2.1.1
%define libexif_gtk_version 0.3.2

Requires:      libgphoto2 >= %{libgphoto2_version}
Requires:      libexif-gtk >= %{libexif_gtk_version}
BuildRequires: libgphoto2 >= %{libgphoto2_version}
BuildRequires: libexif-gtk >= %{libexif_gtk_version}
BuildRequires: gimp-devel

%description
GTKam is a GTK/GNOME based tool to access Digital Cameras,
view thumbnails and download pictures from the camera.

%prep
%setup -q
bzcat %SOURCE1 | tar xf -
%if %build_l10n
bzcat %SOURCE2 | tar xf -
cd po-sun; make; cd ..
%endif
%patch1 -p1
%patch2 -p1
%patch3 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

glib-gettextize -f
gnome-doc-common
libtoolize --force
intltoolize --copy --force --automake
aclocal $ACLOCAL_FLAGS -I ./m4m
automake -a -c -f
autoconf
CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix} \
		--bindir=%{_bindir} \
		--libdir=%{_libdir} \
                --includedir=%{_includedir} \
		--mandir=%{_mandir}		\
		--with-libintl-prefix=/usr
make -j $CPUS INTLLIBS=

cd gexif-*
  glib-gettextize -f
  libtoolize --force
  intltoolize --copy --force --automake
  aclocal $ACLOCAL_FLAGS
  automake -a -c -f
  autoconf
  CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" ./configure --prefix=%{_prefix}
  make INTLLIBS=
cd ..

%install
mkdir -p $RPM_BUILD_ROOT%{_prefix}
make DESTDIR=$RPM_BUILD_ROOT install-strip
cd gexif-*
	make prefix=$RPM_BUILD_ROOT%{_prefix} install-strip
cd ..


# FIXME: Remove scrollkeeper files
rm -rf $RPM_BUILD_ROOT%{_prefix}/var/scrollkeeper

%clean
rm -rf $RPM_BUILD_ROOT;

%files
%defattr(-,root,root)
%doc AUTHORS COPYING NEWS README TODO
%attr(755,root,root) %{_bindir}/gtkam
%attr(755,root,root) %{_bindir}/gexif
%{_datadir}/gtkam
%{_datadir}/images/gtkam
%{_datadir}/pixmaps/*
%{_datadir}/locale/*/*/*
%{_datadir}/applications/*
%{_datadir}/gnome/help
%{_datadir}/omf/*
%{_libdir}/gimp/*/plug-ins/gtkam-gimp
%{_mandir}/man1/*

%changelog
* Tue Feb 13 2007 - [email protected]
- Add l10n tarball.

* Tue Feb 06 2007 - [email protected]
- Update patch comments

* Tue Dec 19 2006 - [email protected]
- Bump to 0.1.14.  Fix patches, removing upstream patches.

* Thu Dec 14 2006 - [email protected]
- Remove gtkam-05-short-cut-key.diff : not needed anymore

* Tue Dec 12 2006 - [email protected]
- Added gtkam-06-g11n-i18n-menu.diff. Fixes 6488200

* Mon Jul 24 2006 - [email protected]
- add option --with-libintl-prefix=/usr

* Mon May 29 2006 - [email protected]
- Remove sfw patch since we're now in /usr/bin by default.
* Tue Jan 03 2006 - [email protected]
- Bump to 0.1.13.
- Remove obsolete patches -06-wall and -07-gimp-plugin. Renumber remaining.

* Fri Dec 02 2005 - [email protected]
- Added gtkam-08-sfw-path.diff to use the absolute path of the executable 
  in the .desktop file as usr/sfw/bin should not be included in $PATH.
  Fixes bug #6345489.

* Tue Nov 29 2005 - laca.com
- remove javahelp stuff

* Sun Sep 18 2005 - [email protected]
- Add gimp-devel as BuildRequires, and add patch so that we install into the
  correct plugin directory.

* Fri Jul 08 2005 - [email protected]
- Add patch 08 to remove '-W -Wall -Wno-unused' as they do not work on Solaris.

* Wed Jun 15 2005 - [email protected]
- Bump to 0.1.12

* Thu May 05 2005 - [email protected]
- 6227253: Change xml file in gtkam-C.omf from gtkam.xml to
  sample_apps_info.xml (part of gnome-user-docs). Bit of a hack but a very easy
  one to maintain.

* Thu Mar 10 2005 - [email protected]
- Add docs tarball (Source4) to %setup section.

* Fri Feb 25 2005 - [email protected]
- Added dummy l10n online help to follow base update

* Wed Feb 16 2005 - [email protected]
- Integrate docs tarball (gtkam-docs-0.1) from [email protected].

* Fri Nov 12 2004 - [email protected]
- added --libdir and --bindir to configure opts so they can be redirected
  on Solaris

* Mon Oct 11 2004 - [email protected]
- Move gtkam-gimp plugin to lib/gimp/2.0.

* Wed Sep 15 2004 - [email protected]
- Added gtkam-06-g11n-potfiles.diff

* Mon Sep 13 2004 - [email protected]
- Added code to install javahelp documents. Fixes #5096653

* Wed Aug 25 2004 - [email protected]
- fixed man pages and docs installation

* Wed Aug 25 2004 - [email protected]
- fixed glib-gettextize call

* Wed Aug 25 2004 - [email protected]
- Add unpackaged files to %files section.

* Mon Aug 09 2004 - [email protected]
- Added patch gtkam-05-short-cut-key.diff

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gtkam-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Fri Jun 18 2004 - [email protected]
- Run glib-gettexttize and intltoolize for both Solaris and Linux
- merge i18n patches

* Thu Jun 10 2004 - [email protected]
- make patch5 solaris-only

* Wed Jun 02 2004 - [email protected]
- Added needed patches for Solaris.

* Wed May 12 2004 - [email protected]
- Updated l10n content to gtkam-l10n-po-1.1.tar.bz2

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to gtkam-l10n-po-1.0.tar.bz2

* Thu Mar 18 2004 - [email protected]
- Bump to 0.1.11

* Thu Mar 04 2004 - [email protected]
- Updated gtkam-03-l10n-and-utf8.diff to gtkam-03-g11n-i18n-ui.diff 
  to fix 4935751, 4981813

* Thu Feb 04 2004 - [email protected]
- Add l10n tarball, edit to gtkam-04-gexif-i18n.diff

* Wed Feb 04 2004 - [email protected]
- Port Patches, gexif version

* Fri Jan 16 2004 - [email protected]
- Enable deprecated patch

* Thu Aug 14 2003 - [email protected]
- desktop file for menu entry

* Wed Jul 16 2003 - [email protected]
- Initial version