SUNWbrltty.spec
author davelam
Thu, 07 Aug 2008 02:31:31 +0000
branchgnome-2-22
changeset 12491 b2fc226f1836
parent 12016 ae9845dead4d
child 12763 63d744a55e5f
permissions -rw-r--r--
2008-08-07 Dave Lin <[email protected]> * closed/SUNWflash-player-plugin.spec: Hack the version number from 9.0.125 9.0.1250 to fix the integration issue, which was caused by the incorrect version number(9.0.1124 should be 9.0.124) in the previous version bump.

#
# spec file for package SUNWbrltty
#
# includes module(s): brltty
#
# Copyright 2007 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner:dcarbery
#
%include Solaris.inc

%use brltty = brltty.spec

Name:              SUNWbrltty
Summary:           Braille support
Version:           %{brltty.version}
SUNW_BaseDir:      %{_basedir}
SUNW_Copyright:    %{name}.copyright
BuildRoot:         %{_tmppath}/%{name}-%{version}-build
Requires: SUNWugen
Requires: SUNWcslr
%if %option_with_fox
Requires: FSWxorg-clientlibs
Requires: FSWxwrtl
%else
Requires: SUNWxwrtl
Requires: SUNWxwplt
%endif
Requires: SUNWPython
Requires: SUNWPython-extra
Requires: SUNWgnome-a11y-libs
BuildRequires: SUNWugenu
BuildRequires: SUNWcslr
BuildRequires: SUNWPython-devel
BuildRequires: SUNWPython-extra
BuildRequires: SUNWgnome-a11y-libs-devel

%include default-depend.inc

%package -n SUNWbrltty-root
Summary:           %{summary} - / filesystem
SUNW_BaseDir:            /
%include default-depend.inc

%package -n SUNWbrltty-devel
Summary:           %{summary} - development files
SUNW_BaseDir:      %{_basedir}
%include default-depend.inc

%prep
rm -rf %name-%version
mkdir %name-%version
%brltty.prep -d %name-%version

%build
export PKG_CONFIG_PATH=%{_pkg_config_path}
export CFLAGS="%optflags -I%{_includedir}"
export RPM_OPT_FLAGS="$CFLAGS"
export LDFLAGS="%_ldflags"

%brltty.build -d %name-%version

%install
%brltty.install -d %name-%version

rm -rf $RPM_BUILD_ROOT%{_mandir}/man3

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/brltty*
%{_bindir}/vstp
%{_bindir}/xbrlapi
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/libbrlapi.so.*
%{_libdir}/libbrlapi.so
%{_libdir}/brltty/libbrltty*.so
%{_libdir}/brltty/rw
%{_libdir}/python?.?/vendor-packages
%dir %attr(0755, root, sys) %{_datadir}
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/man1/*

%files root
%defattr(-, root, sys)
%dir %attr (0755, root, sys) %{_sysconfdir}
%{_sysconfdir}/brltty/*

%files devel
%defattr(-, root, bin)
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/brlapi*.h
%{_includedir}/brltty/*.h
%dir %attr(0755, root, sys) %{_datadir}
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*


%changelog
* Thu Apr 03 2008 - [email protected]
- Add SUNW_Copyright.
* Mon Nov 12 2007 - [email protected]
- Remove brlapi manpages.
* Thu Oct 11 2007 - [email protected]
- Add 'Build/Requires: SUNWcslr' to fix 6615512.
* Wed Oct 10 2007 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Fri Sep 28 2007 - [email protected]
- add option to build with FOX instead of Nevada X
* Wed Jul 25 2007 - [email protected]
- Update %files for new tarball. Add Build/Requires SUNWPython-extra and
  SUNWPython/-devel to ensure python bindings are built (for use with orca).
* Thu Oct 05 2006 - [email protected]
- Add Requires SUNWxwplt to partially fix 6454451.
* Sat Aug 12 2006 - [email protected]
- delete some unnecessary env variables
* Thu May 04 2006 - [email protected]
- merge -share pkg(s) into the base pkg(s)
* Tue Apr 04 2006 - [email protected]
- Fix installation of devel vs non-devel libraries.
* Thu Feb 23 2006 - [email protected]
- Anal-rententive version name change to match ../brltty.spec (3.7.2)
* Fri Feb 17 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Fri Oct 28 2005 - [email protected]
- Update packaging for new source tarball. Add prerequisite packages.
* Fri Sep 09 2005 - <[email protected]>
- add unpackaged files to %files
* Thu Aug 25 2005
- Removed the 'export CC="/opt/SUNWspro/bin/cc"' line. No longer needed.
* Mon Aug 22 2005
- Adjustments needed to make the package proto maps equivalent to what gets
  installed via "make install"
* Tue Aug 16 2005 - [email protected]
- initial version