SUNWlibgc.spec
author davelam
Thu, 07 Aug 2008 02:31:31 +0000
branchgnome-2-22
changeset 12491 b2fc226f1836
parent 12410 72cd6319f51f
child 12966 a28c5890b40c
permissions -rw-r--r--
2008-08-07 Dave Lin <[email protected]> * closed/SUNWflash-player-plugin.spec: Hack the version number from 9.0.125 9.0.1250 to fix the integration issue, which was caused by the incorrect version number(9.0.1124 should be 9.0.124) in the previous version bump.

#
# spec file for package SUNWlibgc
#
# includes module(s): libgc
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner:jerrytan
#
%include Solaris.inc

%use libgc = libgc.spec

Name:                    SUNWlibgc
Summary:                 Boehm-Demers-Weiser garbage collector for C/C++
Version:                 %{libgc.version}
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWlibms

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}

%prep
rm -rf %name-%version
mkdir %name-%version
%libgc.prep -d %name-%version

%build
export CFLAGS="%optflags"
export LDFLAGS="%{_ldflags}"

%libgc.build -d %name-%version

%install
rm -rf $RPM_BUILD_ROOT
%libgc.install -d %name-%version

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*.so*

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/gc

%changelog
* Thu Mar 27 2008 - [email protected]
- Add copyright file
* Sun Mar 02 2008 - [email protected]
- Correct package version number.
* Thu Jan 03 2008 - [email protected]
- Use base spec libgc.spec
* Mon Oct 15 2007 - [email protected]
- Bump to 7.0
- s/gc%{version}/gc-%{version}/g
- Add *.pc to %files devel
* Thu Jul  6 2006 - [email protected]
- rename to SFEhp-gc
- delete -share subpkg
- update file attributes
- delete unnecessary env variables
* Mon Jan 30 2006 - [email protected]
- Initial version