SUNWsigcpp.spec
author davelam
Thu, 07 Aug 2008 02:31:31 +0000
branchgnome-2-22
changeset 12491 b2fc226f1836
parent 11935 fa2b34838439
child 13005 e51ff802ea0e
permissions -rw-r--r--
2008-08-07 Dave Lin <[email protected]> * closed/SUNWflash-player-plugin.spec: Hack the version number from 9.0.125 9.0.1250 to fix the integration issue, which was caused by the incorrect version number(9.0.1124 should be 9.0.124) in the previous version bump.

#
# spec file for package SUNWsigcpp
#
# includes module(s): libsigc++
#
# # Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: elaine
#

%include Solaris.inc
%use sigcpp = sigcpp.spec

Name:                    SUNWsigcpp
Summary:                 Libsigc++ - a library that implements typesafe callback system for standard C++ 
Version:                 %{sigcpp.version}
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWlibC

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: %name

%prep
rm -rf %name-%version
mkdir %name-%version
%sigcpp.prep -d %name-%version
cd %{_builddir}/%name-%version

%build
%if %cc_is_gcc
export CXXFLAGS="%{gcc_cxx_optflags}"
%else
export CFLAGS="%optflags"
export CXX="${CXX} -norunpath"
export CXXFLAGS="%cxx_optflags"
%endif
export LDFLAGS="%_ldflags"
%sigcpp.build -d %name-%version

%install
rm -rf $RPM_BUILD_ROOT
%sigcpp.install -d %name-%version
rm -f $RPM_BUILD_ROOT%{_libdir}/lib*a

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%{_libdir}/sigc++*
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/doc
%{_datadir}/doc/*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*

%changelog
* Thu Mar 27 2008 - [email protected]
- Add file SUNWsigcpp.copyright.
* Sun Mar 02 2008 - [email protected]
- Correct package version number.
* Fri Feb 01 2008 - [email protected]
- create, split from SFEsigcpp.spec