yelp.spec
author dermotm
Mon, 06 Jun 2005 13:09:35 +0000
changeset 5484 b4c330e76240
parent 5480 2d26e14bdb97
child 5506 38c94258e0d4
permissions -rw-r--r--
Incremented release numbers for build 37

#
# spec file for package yelp (Version 2.2.3)
#
# Copyright (c) 2003 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

Name:         yelp 
License:      GPL
Group:        System/GUI/GNOME
Version:      2.6.1
Release:      41
Distribution: Java Desktop System, Release 3
Vendor:	      Sun Microsystems, Inc.
Summary:      The GNOME 2.4 Help Browser 
Source:       http://ftp.gnome.org/pub/GNOME/sources/yelp/2.5/yelp-%{version}.tar.bz2
Source1:      yelp-l10n-po-1.16.tar.bz2
Source2:      gnome-help.1.gz
Source3:      yelp.1.gz
Source4:      l10n-configure.sh
Patch1:       yelp-01-empty-struct-build-fix.diff
Patch2:       yelp-02-g11n-potfiles.diff
Patch3:       yelp-03-session-save.diff
Patch4:       yelp-04-yelp-sections.diff
Patch5:       yelp-05-l10n-online-help.diff
Patch6:       yelp-06-yelp-pager.diff
URL:          www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Autoreqprov:  on

%define libxml2_version 2.6.0
%define pango_version 1.2.5
%define gtk2_version 2.2.4
%define libgtkhtml_version 2.2.1
%define gnome_vfs_version 2.4.0
%define libgnomeui_version 2.4.0.1
%define libbonobo_version 2.4.0
%define libglade_version 2.0.1
%define libxslt_version 1.1.4
%define gail_version 1.4.0

Requires: gtk2 >= %{gtk2_version}
Requires: gnome-vfs >= %{gnome_vfs_version}
Requires: libgtkhtml >= %{libgtkhtml_version}
Requires: libgnomeui >= %{libgnomeui_version}
Requires: libbonobo >= %{libbonobo_version}
Requires: libxslt >= %{libxslt_version}
Requires: libglade >= %{libglade_version}
Requires: libxml2 >= %{libxml2_version}
BuildRequires: pango-devel >= %{pango_version}
BuildRequires: gtk2-devel >= %{gtk2_version}
BuildRequires: gnome-vfs-devel >= %{gnome_vfs_version}
BuildRequires: libgtkhtml-devel >= %{libgtkhtml_version}
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: libbonobo-devel >= %{libbonobo_version}
BuildRequires: libglade-devel >= %{libglade_version}
BuildRequires: libxslt-devel >= %{libxslt_version}
BuildRequires: gail-devel >= %{gail_version}
BuildRequires: libxml2-devel >= %{libxml2_version}

%description
"Yelp" is the help browser for the GNOME 2.2 Desktop. It features man, info and docbook document sources.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
bzcat %SOURCE1 | tar xf -

bash -x %SOURCE4

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
automake -a -c -f
autoconf

./configure \
    --prefix=%{_prefix} \
    --sysconfdir=%{_sysconfdir} \
    --libexecdir=%{_libexecdir} \
    --localstatedir=/var/lib
make -j $CPUS

%install
make install DESTDIR=$RPM_BUILD_ROOT
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/man1
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
                                                                                                                                                             
%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, root)
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_bindir}/*
%{_datadir}/sgml/docbook/yelp
%{_datadir}/yelp
%{_datadir}/applications/yelp.desktop
%{_libdir}/*
%{_mandir}/man1/*

%changelog
* Fri Feb 25 2005 - [email protected]
- #6233172, Add Actions section, change Development Section

* Thu Feb 17 2005 - [email protected]
- #6228279, yelp crash viewing jdsoverview.xml

* Fri Dec 24 2004 - [email protected]
- Bug fix for 6186542, added zh_HK entry in l10n.xml

* Mon Nov 15 2004 - [email protected]
- #6182913, patch yelp-04-help-sections.diff

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to yelp-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Thu May 20 2004 - [email protected]
- added yelp-03-session-save.diff. Yelp is session aware now!

* Wed May 12 2004 - [email protected]
- Updated l10n content to yelp-l10n-po-1.1.tar.bz2

* Thu May 06 2004 - [email protected]
- Bump to 2.6.1

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to yelp-l10n-po-1.0.tar.bz2

* Wed Mar 24 2004 - [email protected]
- Bump to 2.6.0. Remove the sed build fixes, rename the
  empty struct diff, and update the potfiles patch.

* Mon Mar 22 2004 - [email protected]
- fix non-portable sed commands (bugzilla #134534)

* Thu Mar 18 2004 - [email protected]
- Bump to 2.5.91

* Thu Mar 11 2004 - [email protected]
- added yelp-03-g11n-potfiles.diff 

* Tue Feb 24 2004 - [email protected]
- Bump to 2.5.5

* Tue Feb 17 2004 - [email protected]
- two patches two fix a solaris build issues
- add ACLOCAL_FLAGS to aclocal

* Fri Feb 06 2004 - [email protected]
- Bump to 2.5.4, remove two patches, update l10n tarball

* Tue Dec 16 2003 - [email protected]
- Bump to 2.5.1

* Fri Oct 31 2003 - [email protected]
- Removed the Sun Supported menu entry since we're
  removing the Extras menu.

* Mon Oct 13 2003 - [email protected]
- New 2.4 Tarball

* Tue Oct 07 2003 - [email protected]
- Second Change For Help Section for Java Desktop System

* Fri Sep 26 2003 - [email protected]
- Modified Help Section for Java Desktop System

* Fri Aug 22 2003 - [email protected]
- categorycode patch

* Mon Aug 18 2003 - [email protected]
- Help sections patch

* Fri Aug 01 2003 - [email protected]
- Add menu categorization.

* Wed Jul 23 2003 - [email protected]
- Add back window icon.

* Thu Jul 10 2003 - [email protected]
- Added .po tarball

* Wed Jun 25 2003 - [email protected]
- Add libexec/* to %files

* Wed Jun 25 2003 - [email protected]
- Update the version of Yelp

* Wed May 14 2003 - [email protected]
- Initial Sun release