gnome-doc-utils.spec
author dc144907
Tue, 27 Sep 2005 11:41:19 +0000
changeset 6016 b54189f766bc
parent 5777 dc098cf3a13d
child 6038 fd6d4bcdd2bb
permissions -rw-r--r--
*.spec: Bump versions. Fix Source url in some files without bumping.

#
# spec file for package gnome-doc-utils
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:			gnome-doc-utils
License:		GPL
Group:			System/Libraries
Version:		0.4.1
Release:		2
Distribution:		Java Desktop System
Vendor:			Sun Microsystems, Inc.
Summary:		Documentation utilities for GNOME
Source:			http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.4/%{name}-%{version}.tar.bz2
URL:			http://www.gnome.org
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
Docdir:			%{_defaultdocdir}/%{name}
Autoreqprov:		on

%define libxml2_version 2.6.12
%define libxslt_version 1.1.8

Requires:	libxml2 >= %{libxml2_version}
Requires:	libxslt >= %{libxslt_version}

BuildRequires:	libxml2-devel >= %{libxml2_version}
BuildRequires:	libxslt-devel >= %{libxslt_version}

%description
This package contains a selection of utilities for managing documents 
in the GNOME desktop.

The xml2po program is used to convert between PO files and XML documents.
Within gnome-doc-utils, it is used primarily to translate documentation
written in the DocBook format. 

The gnome-doc-prepare script is used to initialize your source tree for 
using the gnome-doc-utils build utilities.  It can also be used to 
create a template document and the necessary supporting files and folders.

%prep
%setup -q

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS" ./configure $MYARCH_FLAGS \
        --prefix=%{_prefix} \
        --sysconfdir=%{_sysconfdir} \
	--localstatedir=%{_localstatedir}/lib \
	--disable-scrollkeeper

make -j $CPUS

%install
make prefix=$RPM_BUILD_ROOT%{_prefix} sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} install

#man pages
mv -f $RPM_BUILD_ROOT/%{_prefix}/man $RPM_BUILD_ROOT/%{_datadir}/man

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, root)
%{_bindir}/gnome-doc-prepare
%{_bindir}/xml2po
%{_libdir}/pkgconfig/*
%{_mandir}/man1/*
%{_datadir}/aclocal/*
%{_datadir}/gnome-doc-utils/*
%{_datadir}/gnome/help/*
%{_datadir}/omf/*
%{_datadir}/xml/*
%{_datadir}/xml2po/*

%changelog
* Thu Sep 08 2005 - [email protected]
- Bump to 0.4.1 since this contains some fixes that cause things
  to break for Solaris in 0.4.0. 
* Mon Aug 15 2005 - [email protected]
- Bump to 0.3.2.
* Thu Jun 09 2005 - [email protected]
- Update so that builds
* Wed May 18 2005 - [email protected]
- Initial spec of gnome-doc-utils