system-tools-backends.spec
author dc144907
Tue, 27 Sep 2005 11:41:19 +0000
changeset 6016 b54189f766bc
parent 5548 ddbd17ae3838
child 6684 45823e136c53
permissions -rw-r--r--
*.spec: Bump versions. Fix Source url in some files without bumping.

#
# spec file for package system-tools-backends
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#


Name:		system-tools-backends
License:	GPL
Group:		System/GUI/GNOME
Version:	1.3.92
Release:	1
Distribution:	Java Desktop System
Vendor:		Sun Microsystems, Inc.
Summary:	Backends for the GNOME System Tools
Source:		http://ftp.gnome.org/pub/GNOME/sources/system-tools-backends/1.3/%{name}-%{version}.tar.bz2
URL:		http://www.gnome.org
BuildRoot:	%{_tmppath}/%{name}-%{version}-build
Docdir:		%{_defaultdocdir}/%{name}
Autoreqprov:	on

%define glib2_version 2.3.0

Requires:	glib2 >= %{glib2_version}
BuildRequires:  glib2-devel >= %{glib2_version}
BuildRequires:  intltool

%description
The System Tools Backends are a set of cross-platform scripts for Linux and 
other Unix systems. The backends provide an standard XML interface for 
modifying the configuration regarless of the distribution that's being used.

%prep
%setup -q


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
	--prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir} \
	--mandir=%{_mandir}
make -j $CPUS

%install
make -i install DESTDIR=$RPM_BUILD_ROOT

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, root)
%{_libdir}/pkgconfig/
%{_datadir}/setup-tool-backends/
%{_datadir}/aclocal/
%{_datadir}/locale/*/LC_MESSAGES/*.mo

%changelog
* Tue Sep 27 2005 - [email protected]
- Bump to 1.3.92.

* Mon Aug 16 2005 - [email protected]
- Bump to 1.3.2.

* Tue May 24 2005 - [email protected]
- Initial spec