dbus.spec
author hh150184
Tue, 24 Jan 2006 11:56:37 +0000
branchgnome-2-12
changeset 19207 b59a653a3329
parent 6296 0b8df700d097
child 6589 294b872f64aa
permissions -rw-r--r--
* evolution-jescs.spec: Bump to 2.4.4, Remove unused define evolution_imagesdir and evolution_libsdir, Remove hard code 1.2, 2.4. * Solaris/SUNWevolution-jescs.spec: Remove *.la under /usr/lib when install, s/evolution-data-server-1.2/evolution-data-server-*/g.

#
# spec file for package dbus
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         dbus
License:      Other
Group:        System/Libraries
Version:      0.50
Release:      2
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Simple IPC library based on messages
Source:       http://dbus.freedesktop.org/releases/%{name}-%{version}.tar.gz
URL:          http://www.freedesktop.org/wiki/Software_2fdbus
Patch1:       dbus-01-auth-external.diff
Patch2:       dbus-02-glib_cflags.diff
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:	      %{_defaultdocdir}/doc
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define glib2_version 2.6.4
%define libxml2_version 2.6.19
%define python_version 2.4
BuildRequires: glib2-devel >= %glib2_version
BuildRequires: libxml2-devel >= %libxml2_version
# FIXME: get python rpm: BuildRequires: python >= %python_version
Requires: glib2 >= %glib2_version
Requires: libxml2 >= %libxml2_version

%description
D-BUS is a message bus system, a simple way for applications to talk to one
another.
D-BUS supplies both a system daemon (for events such as "new hardware device 
added" or "printer queue changed") and a per-user-login-session daemon (for 
general IPC needs among user applications). Also, the message bus is built on
top of a general one-to-one message passing framework, which can be used by
any two apps to communicate directly (without going through the message bus
daemon). 

%package devel
Summary:      Simple IPC library based on messages
Group:        Development/Libraries
Requires:     %{name} = %{version}

%description devel
D-BUS is a message bus system, a simple way for applications to talk to one 
another.

D-BUS supplies both a system daemon (for events such as "new hardware device
added" or "printer queue changed") and a per-user-login-session daemon (for
general IPC needs among user applications). Also, the message bus is built on
top of a general one-to-one message passing framework, which can be used by
any two apps to communicate directly (without going through the message bus
daemon). 

%prep
%setup -q

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi
%ifos solaris
%patch1 -p1
%patch2 -p1
export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -I/usr/sfw/include"
export LDFLAGS="%_ldflags -L/usr/sfw/lib -R/usr/sfw/lib -lexpat"
%endif
CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}		\
            --sysconfdir=%{_sysconfdir} \
            --libexecdir=%{_libexecdir} \
            --localstatedir=%{_localstatedir} \
            --disable-python		\
	    --mandir=%{_mandir}
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
mkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/services
rm $RPM_BUILD_ROOT%{_libdir}/libdbus-1*.a
rm $RPM_BUILD_ROOT%{_libdir}/libdbus-1*.la
rm $RPM_BUILD_ROOT%{_libdir}/libdbus-glib-1*.a
rm $RPM_BUILD_ROOT%{_libdir}/libdbus-glib-1*.la

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%clean 
rm -rf $RPM_BUILD_ROOT

%files 
%defattr(-, root, root)
%config %{_sysconfdir}/dbus-1/session.conf
%config %{_sysconfdir}/dbus-1/system.conf
%{_bindir}/*
%{_libdir}/libdbus-1.so.*
%{_libdir}/libdbus-glib-1.so.*
%{_datadir}/man/*
%{_datadir}/dbus-1/*

%files devel
%defattr(-, root, root)
%{_libdir}/*.so
%{_includedir}/dbus-1.0/*
%{_libdir}/dbus-1.0/*
%{_libdir}/pkgconfig/*

%changelog
* Tue Oct 25 2005 - [email protected]
- Remove patch3 as an include dir under _libdir is okay. Bump to 0.50. Disable
  python bindings as they fail. Bug 4878 files at freedesktop.org.

* Fri Oct 21 2005 - [email protected]
- Add patches to build on Solaris.

* Tue Aug 30 2005 - [email protected]
- Create the dbus-1 services directory

* Tue Aug 16 2005 - [email protected]
- Add python >= 2.4 dependency. Reformat description text.

* Mon Aug 15 2005 - [email protected]
- Bump to 0.35.2.

* Mon Jun 20 2005 - [email protected]
- dbus 0.23 is actually shipped with gnome 2.10 so bumping down tarball

* Thu Jun 09 2005 - [email protected]
- add buildrequires glib2, libxml2

* Thu May 12 2005 - [email protected]
- Initial spec file for dbus.