gaim.spec
author hh150184
Tue, 24 Jan 2006 11:56:37 +0000
branchgnome-2-12
changeset 19207 b59a653a3329
parent 6299 4b3aea37c890
child 6602 768c5f920c88
permissions -rw-r--r--
* evolution-jescs.spec: Bump to 2.4.4, Remove unused define evolution_imagesdir and evolution_libsdir, Remove hard code 1.2, 2.4. * Solaris/SUNWevolution-jescs.spec: Remove *.la under /usr/lib when install, s/evolution-data-server-1.2/evolution-data-server-*/g.

#
# spec file for package gaim
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:		gaim
Version:	1.5.0
Release:        201
License:	GPL
Group:		Applications/Internet
Distribution:	Java Desktop System
Vendor:		Sun Microsystems, Inc.
Summary:	Multiprotocol Instant Messaging Client
Source:		http://heanet.dl.sourceforge.net/sourceforge/%{name}/%{name}-%{version}.tar.bz2
Patch1:         gaim-01-g11n-menu-entry.diff
Patch2:         gaim-02-remove-unwanted-protocols.diff
Patch3:         gaim-03-perl-common-argc.diff
Patch4:         gaim-04-uint_max.diff
Patch5:         gaim-05-po-mkinstalldirs.diff
Patch6:         gaim-06-gettext.diff
Patch7:         gaim-07-void-return.diff
Patch8:         gaim-08-sound_errors.diff
Patch9:         gaim-09-add-help.diff
Patch10:        gaim-10-long-preferences.diff
Patch11:        gaim-11-g11n-enable-im.diff

URL:		http://gaim.sourceforge.net/
BuildRoot:	%{_tmppath}/%{name}-%{version}-build
Docdir:		%{_defaultdocdir}/gaim
Autoreqprov:	on

BuildRequires:	gtk2-devel
BuildRequires:	glib2-devel

%description
Gaim allows you to chat over the Internet using a variety of
messaging protocols, including AIM, ICQ, IRC, Yahoo!, 
MSN Messenger and Jabber.
These protocols are implemented using a modular, easy to use
design.

%package devel
Summary:      Multiprotocol Instant Messaging Client
Group:        System/GUI/GNOME
Autoreqprov:  on
Requires:     %name = %version

%description devel
Gaim allows you to chat over the Internet using a variety of
messaging protocols, including AIM, ICQ, IRC, Yahoo!, 
MSN Messenger and Jabber.
These protocols are implemented using a modular, easy to use
design.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
%patch11 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

glib-gettextize -f
libtoolize --force
aclocal $ACLOCAL_FLAGS -I .
autoheader
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS -DG_IMPLEMENT_INLINES -DG_HAVE_ISO_VARARGS" \
LD_LIBRARY_PATH="%{_libdir}:$LD_LIBRARY_PATH"
./configure --prefix=%{_prefix} --mandir=%{_mandir}

make -j $CPUS

%install
if [ -d $RPM_BUILD_ROOT ]; then rm -r $RPM_BUILD_ROOT; fi;
make DESTDIR=$RPM_BUILD_ROOT install \
    SITEPREFIX=/dummy VENDORPREFIX=/dummy PERLPREFIX=/dummy
rm -Rf $RPM_BUILD_ROOT%{_libdir}/perl5
rm -Rf $RPM_BUILD_ROOT/dummy
rm $RPM_BUILD_ROOT%{_libdir}/gaim/*.la
rm $RPM_BUILD_ROOT%{_libdir}/*.la

%files
%defattr(-, root, root)
%doc doc/the_penguin.txt doc/CREDITS NEWS COPYING AUTHORS
%doc doc/FAQ README ChangeLog HACKING
%attr(755, root, root) %{_libdir}/gaim/*.so
%attr(755, root, root) %{_libdir}/libgaim-remote.so.*
%{_bindir}/*
%{_mandir}/man1/*
%{_datadir}/locale/*/*/*
%{_datadir}/pixmaps/*
%{_datadir}/sounds/gaim/*
%{_datadir}/applications/*

%files devel
%defattr(-, root, root)
%{_libdir}/pkgconfig/*
%{_includedir}/gaim/*

%clean
rm -r $RPM_BUILD_ROOT

%changelog
* Tue Nov 29 2005 - laca.com
- remove javahelp stuff

* Mon Aug 15 2005 - [email protected]
- Bump to 1.5.0.

* Thu Jun 10 2005 - [email protected]
- Bump to 1.3.0

* Thu Mar 24 2005 - [email protected]
- Rev to 1.3.0.  Patches #9, 12, 17, 18 and 19 removed.

* Thu Mar 24 2005 - [email protected]
- Added gaim-19-yahoo-privacy-fix.diff patch, fixes yahoo
  privacy issue.

* Tue Jan 25 2005 - [email protected]
- Update docs with Linux specific tarball from [email protected].

* Tue Jan 18 2005 - [email protected]
- New backported patch to fix msn messenger. Fixes #6217610.

* Wed Jan 12 2005 - [email protected]
- Added gaim-15-g11n-enable-im.diff to enable Ja input method.  Fix 4990149.
- Added gaim-16-g11n-filename.diff to get/put localized filenames. Fixes 6216501

* Tue Jan 11 2005 - [email protected]
- Added patch #15. Fixes #6204972

* Thu Dec 16 2004 - [email protected]
- Update l10n help tarball to use linux version 

* Wed Dec  8 2004 - [email protected]
- Update docs tarball from [email protected].

* Fri Nov 12 2004 - [email protected]
- Added workaround fix for 6193354

* Fri Oct 29 2004 - [email protected]
- Fixes msn security issues.

* Thu Oct 21 2004 - [email protected]
- Added patch #11. Fixes #5101982

* Mon Sep 06 2004 - [email protected]
- Add javahelp-convert for new docs

* Fri Sep 03 2004 - [email protected]
- Add docs tarball from [email protected].
- Add patch to incorporate docs tarball.

* Mon Aug 30 2004 - [email protected]
- Bump to 0.82.1

* Tue Aug 24 2004 - [email protected]
- mandir/man3 added to base package

* Tue Aug 24 2004 - [email protected]
- Bump to 0.81 and create a devel package.

* Fri Aug 20 2004 - [email protected]
- Comment out removal of man3 files - these don't exist on Solaris.

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gaim-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- ported to rpm4
                                                                                
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed Jun 09 2004 - [email protected]
- Modified patch gaim-02-remove-unwanted-protocols.diff to remove the 
  unnecessary protocols from the build.

* Fri Jun 04 2004 - [email protected]
- Add patch gaim-10-iconv-open.diff. Fixes the irc protocol on
  Solaris

* Wed May 12 2004 - [email protected]
- Updated l10n content to gaim-l10n-po-1.1.tar.bz2

* Sun May 02 2004 - [email protected]
- add patch #9 (void-return) for a void function returning a value

* Tue Apr 27 2004 - [email protected]
- Bumped new tarball 0.76 version and updated spec file 
  accordingly.

* Mon Apr 05 2004 - [email protected]
- ifos'ify glib-gettexttize, to stop nameless .mo files being 
  generated on cinnabar/linux.

* Sun Apr 04 2004 - [email protected]
- add glib-gettextize to make the build work with Solaris msgfmt

* Wed Mar 31 2004 - [email protected]
- replace tar jxf with the more solaris friendly
  bzcat piped through tar

* Mon Mar 29 2004 - [email protected]
- Adding gaim-l10n-po-1.0.tar.bz2 l10n content

* Mon Mar 08 2004 - [email protected]
- Fixes all vulnerabilities reproted in the bug report.

* Thu Mar 04 2004 - [email protected]
- Removed gaim-01-menu-entry.diff
- Added gaim-01-g11n-menu-entry.diff to fix 4957377
- Added gaim-08-g11n-potfiles.diff

* Wed Mar 03 2004 - <[email protected]>
- fix Solaris build by forcing the use of the glib gettext test macro

* Fri Feb 20 2004 - <[email protected]>
- Distro to Cinnabar, fixed patch gaim-06-po-mkinstalldirs.diff

* Thu Feb 19 2004 - <[email protected]>
- Update to 0.75.

* Fri Oct 31 2003 - <[email protected]>
- Remove the Sun Supported keyword from the menu
  patch.

* Mon Oct 20 2003 - <[email protected]>
- update to 0.70 and removed potfiles patch

* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la

* Tue Aug 05 2003 [email protected]
- Added POTFILES.in patch again (updated)

* Fri Aug 01 2003 [email protected]
- removed unwanted protocols

* Fri Aug 01 2003 [email protected]
- why was there no changelog for this before? well 
  new tarball, bumped release, reset release, added lbgaim-remote.so.*