base-specs/gnome-games.spec
author dcarbery
Tue, 26 Feb 2008 20:53:14 +0000
changeset 11725 b731d2d412a2
parent 11627 b057418d5e4e
child 11758 ea99458c010b
permissions -rw-r--r--
2008-02-26 Damien Carbery <[email protected]> * include/prod.inc: Bump to 2.21.92. * patches/eel-01-multibyte-bookmark-menu.diff: Reworked. * patches/nautilus-07-lockdown.diff: Rework. * patches/nautilus-09-interface-changes.diff: Rework. * base-specs/eog.spec: Bump to 2.21.92. Remove upstream patch 03-zh_TW-help. * patches/eog-03-zh_TW-help.diff: Removed, upstream. * patches/gnome-applets-01-disable-drivemount.diff: Rework. * base-specs/eel.spec, base-specs/nautilus.spec, base-specs/libgnomeui.spec, base-specs/gnome-games.spec, base-specs/file-roller.spec, base-specs/control-center.spec, base-specs/deskbar-applet.spec, base-specs/orca.spec, base-specs/gnome-applets.spec: Bump to 2.21.92. * base-specs/zenity.spec: Bump to 2.21.1. * base-specs/pango.spec: Bump to 2.15.7. * base-specs/gtk2-engines.spec: Bump to 2.13.6. * base-specs/java-access-bridge.spec: Bump 1.22.0. * base-specs/accerciser.spec: Bump to 1.1.92. * base-specs/libsoup.spec: Bump to 2.3.4. * base-specs/glibmm.spec: Bump to 2.15.7.

#
# spec file for package gnome-games
#
# Copyright (c) 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: migi
#
Name:         gnome-games
License:      GPL
Group:        Amusements/Games
Version:      2.21.92
Release:      1
Distribution: Java Desktop System
Vendor:	      Sun Microsystems, Inc.
Summary:      GNOME games
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.21/%{name}-%{version}.tar.bz2
# owner:dcarbery date:2008-01-02 type:bug bugzilla:509409
Patch1:       gnome-games-01-skip-ggz-check.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on
Prereq:       GConf

%define python_version 2.4
%define libgnomeui_version 2.2.0
%define scrollkeeper_version 0.3.11

BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: scrollkeeper >= %{scrollkeeper_version}
BuildRequires: intltool
Requires:      libgnomeui >= %{libgnomeui_version}

%description
The gnome-games package includes some small games that come with the
GNOME desktop environment but can be used under any desktop.
The games are mostly puzzle or solitaire games.

%prep
%setup -q
%patch1 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

export install_user=$LOGNAME
export install_group=`groups | awk '{print $1}'`

# Force the update of aclocal.m4 to incorporate the modified sdl.m4. Otherwise
# configure fails because /usr/bin/xgettext is checked instead of the CBE
# version which is GNU xgettext.
aclocal --force $ACLOCAL_FLAGS -I m4
automake -a -c -f
autoconf
./configure --prefix=%{_prefix} 	\
	    --sysconfdir=%{_sysconfdir} \
	    --bindir=%{_bindir} \
	    --libdir=%{_libdir} \
            --includedir=%{_includedir} \
	    --libexecdir=%{_libexecdir} \
	    --with-scores-user=$install_user   \
	    --with-scores-group=$install_group \
	    --disable-setgid \
	    --disable-scrollkeeper \
	    --with-libggz-includes=%{libggz_build_dir}/src \
	    --with-libggz-libraries=%{libggz_build_dir}/src/.libs \
	    --with-ggzmod-includes=%{ggzmod_build_dir}/ggzmod \
	    --with-ggzmod-libraries=%{ggzmod_build_dir}/ggzmod/.libs \
	    --enable-omitgames=aisleriot,blackjack,gnometris

make -j $CPUS \
	pythondir=%{_libdir}/python%{python_version}/vendor-packages

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
%makeinstall localstatedir=%{_localstatedir}/lib \
	pythondir=%{_libdir}/python%{python_version}/vendor-packages
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL

## things we just don't want in the package
rm -rf $RPM_BUILD_ROOT/var/lib/scrollkeeper
find $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm {} ';'

## install desktop files

%find_lang %{name}

#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="blackjack.schemas gataxx.schemas glines.schemas gnect.schemas gnibbles.schemas gnobots2.schemas gnomine.schemas gnotravex.schemas gtali.schemas iagno.schemas mahjongg.schemas same-gnome.schemas"
for S in $SCHEMAS; do
  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S > /dev/null
done

%clean
rm -rf $RPM_BUILD_ROOT

%files -f %{name}.lang
%defattr(-, root, root)
%doc AUTHORS COPYING ChangeLog

# these are not setgid games
%{_bindir}/games-server.py
%{_bindir}/gnect
%{_bindir}/blackjack

%{_localstatedir}/lib

# these are setgid games
%attr(2551, root, games) %{_bindir}/gnomine
%attr(2551, root, games) %{_bindir}/same-gnome
%attr(2551, root, games) %{_bindir}/mahjongg
%attr(2551, root, games) %{_bindir}/gtali
%attr(2551, root, games) %{_bindir}/gnobots2
%attr(2551, root, games) %{_bindir}/gataxx
%attr(2551, root, games) %{_bindir}/gnotravex
%attr(2551, root, games) %{_bindir}/gnotski
%attr(2551, root, games) %{_bindir}/gnibbles
%attr(2551, root, games) %{_bindir}/glines
%attr(2551, root, games) %{_bindir}/iagno

%{_datadir}/applications
%{_datadir}/blackjack
%{_datadir}/gnect
%{_datadir}/gnibbles
%{_datadir}/gnobots2
%{_datadir}/gnome
%{_datadir}/gnome-games
%{_datadir}/locale/zh_HK/LC_MESSAGES
%{_datadir}/omf
%{_datadir}/pixmaps
%{_datadir}/sounds
%{_sysconfdir}/gconf/schemas/*
%config %{_sysconfdir}/sound/events/*

%changelog
* Tue Feb 26 2008 - [email protected]
- Bump to 2.21.92.
* Wed Feb 13 2008 - [email protected]
- Bump to 2.21.91.
* Tue Jan 29 2008 - [email protected]
- Bump to 2.21.90.
* Fri Jan 25 2008 - [email protected]
- Force the update of aclocal.m4 to incorporate the modified sdl.m4. Otherwise
  configure fails because /usr/bin/xgettext is checked instead of the CBE
  version which is GNU xgettext.
* Tue Jan 15 2008 - [email protected]
- Bump to 2.21.5.
* Wed Jan 09 2008 - [email protected]
- Remove 02-msgfmt patch, instead set ACLOCAL_FLAGS in SUNWgnome-games.spec to
  pick up modified intltool.m4.
* Mon Jan 07 2008 - [email protected]
- Add patch gnome-games-02-msgfmt.diff
* Mon Jan 07 2008 - [email protected]
- Specify ggzmod location in configure.
* Wed Jan 02 2008 - [email protected]
- Use variable from SUNWgnome-games.spec to specify libggz location. Add patch
  01-skip-ggz-check to set compiler flags to get libggz search test work.
* Tue Dec 18 2007 - [email protected]
- Bump to 2.21.4.
* Tue Dec 04 2007 - [email protected]
- Bump to 2.21.3.
* Tue Nov 13 2007 - [email protected]
- Bump to 2.21.2.
* Tue Oct 30 2007 - [email protected]
- Bump to 2.21.1.
* Fri Oct 19 2007 - [email protected]
- Bump to 2.20.1.
* Tue Oct  9 2007 - [email protected]
- Add --disable-setgid to configure so that the games are not setgid-bin, which
  violates ARC rules.
* Tue Sep 18 2007 - [email protected]
- Bump to 2.20.0.1. Remove upstream patch, 01-func-decl.
* Mon Sep 03 2007 - [email protected]
- Bump to 2.19.92. Add patch, 01-func-decl, to fix #473327.
* Wed Aug 29 2007 - [email protected]
- Bump to 2.19.91.1.
* Tue Aug 28 2007 - [email protected]
- Bump to 2.19.91. Remove upstream patch, gnome-menus-05-iconv-solaris.
* Thu Aug 16 2007 - [email protected]
- Add patch gnome-menus-05-iconv-solaris to fix #467309. Modify
  intltool-merge.in to allow use of non-GNU iconv.
* Wed Aug 15 2007 - [email protected]
- Bump to 2.19.90.1.
* Wed Aug 15 2007 - [email protected]
- Bump to 2.19.90b. Remove upstream patch, 01-build-gnometris.
* Mon Jul 30 2007 - [email protected]
- Bump to 2.19.6. Remove upstream patches, 01-strrchr and 03-ggz-signed-char.
  Renumber remainder.
* Tue Jun 19 2007 - [email protected]
- Bump to 2.19.4. Remove upstream patches, 01-named-struct and 03-signed-char.
* Mon Jun 11 2007 - [email protected]
- Add patch 04-build-gnometris to fix build error in gnometris game. Filed
  bugzilla #446290. Also add some autofoo calls to incorporate updates ggz.m4
  file (modified in patch3).
* Fri Jun 08 2007 - [email protected]
- Add patch, 03-signed-char, for #445556.
* Wed Jun 06 2007 - [email protected]
- Bump to 2.19.3. Add patches to fix some build errors.
* Fri May 18 2007 - [email protected]
- Add glchess.desktop back in bugzilla 426538 now fixed in 2.19.1.1
* Wed May 16 2007 - [email protected]
- Bump to 2.19.2.
* Wed May 09 2007 - [email protected]
- Bump to 2.19.1.
* Fri May 04 2007 - [email protected]
- Bump to 2.18.1.1.
* Thu Apr 12 2007 - [email protected]
- Bump to 2.18.1.
* Thu Apr 05 2007 - [email protected]
- Remove glchess.desktop, until glchess is made functional on Solaris
- Bugzilla : 426538, bugster : 6537569
* Wed Mar 21 2007 - [email protected]
- Bump to 2.18.0.1.
* Tue Mar 13 2007 - [email protected]
- Bump to 2.18.0.
* Mon Mar 05 2007 - [email protected]
- Bump to 2.17.92. Removed upstream patch, 01-grep-no-q.
* Thu Feb 15 2007 - [email protected]
- Add patch, 01-grep-no-q.diff, to remove '-q' from grep calls. Fixes 408331.
  Specify build user/group so that chown calls don't fail; disable building
  of aisleriot game (removing code from SUNWgnome-games.spec).
* Tue Feb 13 2007 - [email protected]
- Bump to 2.17.91.
* Wed Jan 24 2007 - [email protected]
- Bump to 2.17.90.1.
* Mon Jan 22 2007 - [email protected]
- Bump to 2.17.90.
* Mon Jan 08 2007 - [email protected]
- Bump to 2.17.5. Remove upstream patch 01-ggz-function.
* Wed Dec 20 2006 - [email protected]
- Bump to 2.17.4.1. Add patch 01-ggz-function to fix #363444.
* Tue Dec 19 2006 - [email protected]
- Bump to 2.17.4.
* Thu Dec 07 2006 - [email protected]
- Bump to 2.17.3. Remove upstream patches, 01-array-init and 02-ggz-function.
  Remove obsolete 'rm' calls in %install (those files/dirs no longer installed).
  Install python libs to vendor-packages dir and remove *.pyo files.
* Fri Nov 24 2006 - [email protected]
- Add patches 01-array-init to fix 363438 and 02-ggz-function to fix 362444.
* Wed Nov 22 2006 - [email protected]
- Bump to 2.17.1.
* Thu Nov 09 2006 - [email protected]
- Bump to 2.16.1.1.
* Tue Oct 03 2006 - [email protected]
- Bump to 2.16.1.
* Tue Sep 05 2006 - [email protected]
- Bump to 2.16.0.
* Tue Aug 22 2006 - [email protected]
- Bump to 2.15.92.
* Tue Aug 08 2006 - [email protected]
- Bump to 2.15.6.
* Mon Jul 24 2006 - [email protected]
- Bump to 2.15.5.
* Web Jul 21 2006 - [email protected]
- Bump to 2.15.4.
* Mon Jun 26 2006 - [email protected]
- remove patch menu-entry.diff since gnome-games is moving back to /usr
* Fri Jun 23 2006 - [email protected]
- Bump to 2.14.2.
* Fri Apr 10 2006 - [email protected]
- Bump to 2.14.
* Mon Mar 13 2006 - [email protected]
- Bump to 2.14.
* Thu Feb 23 2006 - [email protected]
- Bump to 2.13.8.
* Mon Feb 13 2006 - [email protected]
- Bump to 2.13.7.
* Sat Jan 21 2006 - [email protected]
- Remove upstream patch, 02-illegal-cast.
* Tue Jan 17 2006 - [email protected]
- Bump to 2.13.5
* Sun Jan 15 2006 - [email protected]
- Bump to 2.13.4.
* Sat Jan 07 2006 - [email protected]
- Add patch, 02-illegal_cast, to fix compilation errors; bugzilla 326024.
* Tue Dec 20 2005 - [email protected]
- Bump to 2.13.3
* Fri Dec 02 2005 - [email protected]
- Added gnome-games-01-sfw-path.diff to use the absolute path of the 
  executable in the .desktop file as usr/sfw/bin should not be 
  included in $PATH.
  Fixes bug #6345489.
* Tue Nov 29 2005 - laca.com
- remove javahelp stuff
* Tue Nov 29 2005 - [email protected]
- Bump to 2.12.2.
* Wed Oct 12 2005 - [email protected]
- Remove patch as offending struct is no longer empty.
* Tue Oct 11 2005 - [email protected]
- Bump to 2.12.1
* Sat Sep 17 2005 - [email protected]
- Bump to 2.12.0
* Mon Sep 05 2005 - [email protected]
- Bump to 2.11.5.
* Fri Sep 02 2005 - [email protected]
- Add patch to fix zero sized struct Solaris build error.
* Wed Aug 24 2005 - [email protected]
- Add patch to remove blank line 1 from same-gnome.xml (javahelp had prob).
* Mon Aug 15 2005 - [email protected]
- Bump to 2.11.4.
* Fri May 20 2005 - [email protected]
- Bump to 2.10.1
* Wed May 11 2005 - [email protected]
- added gnome-games-05-g11n-desktop-fix.diff 
- to fix CR 6266891
* Wed Apr 27 2005 - [email protected]
- added gnome-games-04-po-install-fixes.diff for CR 6243601
* Fri Nov 12 2004 - [email protected]
- added --libdir and --bindir to configure opts so they can be redirected on
  Solaris
* Mon Sep 20 2004 - [email protected]
- removed sol from files
* Thu Sep 04 2004 - [email protected]
- packaged sol
* Thu Aug 26 2004 - [email protected]
- Put scores files in %{_localstatedir}/lib.
* Wed Aug 25 2004 - [email protected]
- Add unpackaged files to %files.
* Mon Aug 23 2004 - [email protected]
- remove auto*-jds tool dependencies
* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gnome-games-l10n-po-1.2.tar.bz2
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds
* Tue Jun 1 2004 - [email protected]
- Fix up schema install
* Wed May 12 2004 - [email protected]
- Updated l10n content to gnome-games-l10n-po-1.1.tar.bz2
* Fri May 07 2004 - [email protected]
- Bump to 2.6.1
* Wed Apr 21 2004 - [email protected]
- disable javahelp conversion for stuff not built on Solaris
* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris
* Fri Apr 02 2004 - [email protected]
- Added patch 03 to fix Solaris Makefile issue, and added libexecdir to
  configure line.
* Thu Apr 01 2004 - [email protected]
- javahelp conversion
* Mon Mar 29 2004 - [email protected]
- Updated l10n content to gnome-games-l10n-po-1.0.tar.bz2
* Wed Mar 24 2004 - [email protected]
- Use JDS autotools
* Tue Mar 23 2004 - [email protected]
- Bump to 2.6.0. Remove 2 potfile patches and 
  replace with a single one.
* Thu Mar 11 2004 - [email protected]
- added gnome-games-03-g11n-potfiles.diff
* Fri Feb 06 2004 - <[email protected]>
- Bump up 2.5.5, remove intltool-merge patch
- re-engineered patch-01, as automake etc is commented out.
- This could be changed again if automake 1.7 was being used not 1.6 !!
* Thu Jan 29 2004 - <[email protected]>
- add patch 03 for intltool-merge and dep. on intltool
* Fri Dec 29 2003 - <[email protected]>
- comment out libtool, aclocal etc. which 
  is causing build failure
* Fri Dec 29 2003 - <[email protected]>
- Bump to 2.5.3
* Wed Dec 17 2003 - <[email protected]>
- Bump to 2.5.2
* Fri Oct 31 2003 - <[email protected]>
- Remove the Sun Supported keyword from the desktop 
  files. We're removing the Extras menu.
* Wed Oct 22 2003 - <[email protected]>
- Add blackjack into the build
* Tue Oct 21 2003 - <[email protected]>
- Updated to GNOME 2.4.0 version
- Removed freecell entries
- Moved gnome-games-03-menu-entry.diff patch to 
  gnome-games-01-menu-entry.diff
- Dropped gnome-games-04-glines-preferences.diff patch.
* Thu Aug 14 2003 - <[email protected]>
- remove *.so, *.a, *.la
* Wed Aug 06 2003 - <[email protected]>
- fix glines preference dialog
* Thu Jul 17 2003 - <[email protected]>
- remove more xbill stuff
* Wed Jul 09 2003 - <[email protected]>
- add in sun po files
* Tue Jul 08 2003 - [email protected]
- Add menu icon for freecell, and add aclocal, automake checks
* Tue May 13 2003 - [email protected]
- Created new spec file for gnome-games