gnome-applets.spec
author mattk
Fri, 08 Aug 2003 15:05:13 +0000
changeset 1020 bd14b4e5152f
parent 1002 01be3c626198
child 1025 a32d1ed4f10d
permissions -rw-r--r--
Bug #4887871

Name:         gnome-applets 
License:      GPL
Group:        System/GUI/GNOME 
Version:      2.3.5
Release:      19
Distribution: Mercury
Vendor:	      Sun Microsystems, Inc.
Summary:      GNOME Applets
Source:       gnome-applets-%{version}.tar.bz2 
Source1:      accessx-status-applet.png
Source2:      gnome-applets-l10n-po.tar.bz2
Source3:      gnome-mixer.png
Patch1:       gnome-applets-01-accessx-status-applet.diff 
Patch2:       gnome-applets-02-potfiles_in.diff
Patch3:       gnome-applets-03-sticknotes-icon.diff
Patch4:       gnome-applets-04-geyes-themes.diff
Patch5:       gnome-applets-05-gkb-window-icon.diff
Patch6:       gnome-applets-06-mount-floppy-location.diff
Patch7:       gnome-applets-07-mini-commander-filesel.diff
Patch8:       gnome-applets-08-battstat-suspend-command.diff
Patch9:       gnome-applets-09-gkb-current.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/gnome-applets
Autoreqprov:  on

%define gnome_panel_version 2.2.1
%define scrollkeeper_version 0.3.11
%define libgtop_version 2.0.1
%define gail_version 1.2.0

BuildRequires: scrollkeeper >= %{scrollkeeper_version}
BuildRequires: gnome-panel >= %{gnome_panel_version}
BuildRequires: libgtop-devel >= %{libgtop_version}
BuildRequires: gail >= %{gail_version}
Requires:      scrollkeeper >= %{scrollkeeper_version}
Requires:      gnome-panel >= %{gnome_panel_version}
Requires:      libgtop >= %{libgtop_version}
Requires:      gail >= %{gail_version}

%description
GNOME Applets contains a collection of small utilities that are run within the GNOME
Panel.

%prep
%setup -q
%patch1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8
%patch9
cp %SOURCE1 accessx-status/pixmaps
tar jxvf %SOURCE2
cp %SOURCE3 mixer/gnome-mixer-applet.png

%build
libtoolize --force
aclocal -I /usr/share/aclocal/gnome2-macros
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}		\
	    --sysconfdir=%{_sysconfdir} \
	    --libexecdir=%{_libexecdir} \
	    --localstatedir=/var/lib
make 

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 
make DESTDIR=$RPM_BUILD_ROOT install
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL

%clean
rm -rf $RPM_BUILD_ROOT

%post
for i in zh_CN zh_TW ko_KR ja_JP de_DE es_ES fr_FR it_IT sv_SE ; do
        langtag=$i
        [ ${i:0:2} == "zh" ] || langtag=${i:0:2}
	for j in cdplayer char-palette command-line geyes gkb gtik2_applet2 gweather mailcheck mixer_applet2 ; do
		[ -e  %{_datadir}/omf/gnome-applets/$j-$langtag.omf ] && \
        	env LANG=$i LC_ALL=$i scrollkeeper-install -q %{_datadir}/omf/gnome-applets/$j-$langtag.omf
	done
done
scrollkeeper-update -q
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="battstat.schemas cdplayer.schemas charpick.schemas drivemount.schemas geyes.schemas gkb.schemas gtik.schemas gweather.schemas mailcheck.schemas mini-commander.schemas mixer.schemas modemlights.schemas multiload.schemas stickynotes.schemas"
for S in $SCHEMAS; do
  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%postun
for i in zh_CN zh_TW ko_KR ja_JP de_DE es_ES fr_FR it_IT sv_SE ; do
        langtag=$i
        [ ${i:0:2} == "zh" ] || langtag=${i:0:2}
        for j in cdplayer char-palette command-line geyes gkb gtik2_applet2 gweather mixer_applet2 ; do
		[ -e  %{_datadir}/omf/gnome-applets/$j-$langtag.omf ] && \
                env LANG=$i LC_ALL=$i scrollkeeper-uninstall -q %{_datadir}/omf/gnome-applets/$j-$langtag.omf
        done
done
scrollkeeper-update -q

%files
%defattr (-, root, root)
%{_datadir}/omf/gnome-applets/*
%{_datadir}/gnome-2.0/ui/*
%{_libdir}/bonobo/servers/*.server
%{_sysconfdir}/gconf/schemas/*.schemas
%{_datadir}/pixmaps/*.png
%{_datadir}/gen_util/mini-commander.glade
%{_datadir}/battstat_applet/battstat_applet.glade
%{_sysconfdir}/sound/events/battstat_applet.soundlist
%{_sysconfdir}/sound/events/mailcheck.soundlist
%{_datadir}/pixmaps/accessx-status-applet/*.png
%{_datadir}/pixmaps/mailcheck/*.png
%{_datadir}/pixmaps/gweather/*
%{_datadir}/pixmaps/mini-commander/*
%{_datadir}/gnome/gkb/*
%{_datadir}/stickynotes/stickynotes.glade
%{_datadir}/wireless-applet/wireless-applet.glade
%{_datadir}/xmodmap/xmodmap.*
%{_datadir}/pixmaps/gkb/*.png
%{_datadir}/pixmaps/mixer/*.png
%{_datadir}/pixmaps/stickynotes/*.png
%{_datadir}/pixmaps/wireless-applet/*.png
%{_datadir}/gnome/help/*
%{_datadir}/geyes/Horrid/*
%{_datadir}/geyes/Default/*
%{_datadir}/geyes/Bizarre/*
%{_datadir}/geyes/Bloodshot/*
%{_datadir}/geyes/Default-tiny/*
%{_datadir}/locale/*/LC_MESSAGES/gnome-applets-2.0.mo
%{_bindir}/*
%{_libexecdir}/*

%changelog
* Thu Aug 07 2003 - <[email protected]>
- Save current keyboard layout #4887871
* Thu Aug 07 2003 - <[email protected]>
- Default battstat suspend computer command
* Wed Aug 06 2003 - <[email protected]>
- Position the file selector dialog for mini-commander
  applet nicely.
* Wed Jul 23 2003 - <[email protected]>
- Add consistant window icon
* Tue Jul 22 2003 - <[email protected]>
- Make sure geyes themes get installed
* Tue Jul 22 2003 - <[email protected]>
- New mixer icon
* Mon Jul 21 2003 - <[email protected]>
- Changed stickynotes icon for the hell of it
* Wed Jul 09 2003 - <[email protected]>
- add in sun po files
* Thu Jul 03 2003 - [email protected]
- Patch for accessx-applet from head
* Thu Jul 03 2003 - [email protected]
- New Tarball, gnome-applets-2.3.5
* Tue Jun 10 2003 - [email protected]
- New Tarball, gnome-applets-2.3.4, updated files and schemas for new applets.
* Thu May 15 2003 - [email protected]
- Fix installation of mixer & wirelass applets icons
* Wed May 14 2003 - [email protected]
- Initial release