SUNWcairomm.spec
author hem
Mon, 08 Feb 2010 06:46:00 +0000
branchopensolaris-2009-06
changeset 14354 c3d6244280dc
parent 13666 804715cb92ce
child 15650 dbcf7e3715dd
permissions -rw-r--r--
2010-02-08 Hemantha Holla <[email protected]> * base-specs/pidgin.spec: Bump to 2.6.5 as fix for 6913836 * patches/pidgin-07-menu-entry.diff: Rework 6913836 - CVE-2010-0013 - libpurple arbitrary file upload vulnerability

#
# spec file for package SUNWcairomm
#
# includes module(s): cairomm
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: gheet

%include Solaris.inc
%use cairomm = cairomm.spec

Name:                    SUNWcairomm
Summary:                 cairomm - C++ API for the Cairo Graphics Library
Version:                 %{cairomm.version}
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
%include default-depend.inc
Requires: SUNWgnome-base-libs
BuildRequires: SUNWgnome-base-libs-devel
Requires: SUNWsigcpp
BuildRequires: SUNWsigcpp-devel

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: %name
Requires: SUNWgnome-base-libs-devel
Requires: SUNWsigcpp-devel

%prep
rm -rf %name-%version
mkdir %name-%version
%cairomm.prep -d %name-%version

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
    CPUS=1
fi

%if %cc_is_gcc
%else
export CXX="${CXX} -norunpath"
%endif
export CXXFLAGS="%cxx_optflags"
export PERL_PATH=/usr/perl5/bin/perl
%cairomm.build -d %name-%version

%install
rm -rf $RPM_BUILD_ROOT
%cairomm.install -d %name-%version
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'

%clean
rm -rf $RPM_BUILD_ROOT

%files
%doc(bzip2) -d cairomm-%{cairomm.version} COPYING NEWS ChangeLog
%doc -d cairomm-%{cairomm.version} README AUTHORS
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/doc
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/doc
%{_datadir}/doc/cairomm/*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*

%changelog
* Sun Mar 02 2008 - [email protected]
- Correct package version number.
* Tue Feb 19 2008 - [email protected]
- Updated after review.
* Fri Jan 08 2008 - [email protected]
- Modified SFEcairomm.spec to make SUNWcairomm.spec and cairomm.spec
* Mon Nov 12 2007 - [email protected]
- Bump to 1.4.6.
* Wed Sep 19 2007 - [email protected]
- Bump to 1.4.4
* Fri Aug 17 2007 - [email protected]
- Bump to 1.4.2
* Sun Feb 25 2007 - [email protected]
- create