SUNWgnome-im-client.spec
author laca
Mon, 14 Jul 2008 09:46:17 +0000
branchgnome-2-22
changeset 12466 cc05ce1b1d3e
parent 12330 26062c4169d2
child 12483 aa4a3fc97dbb
permissions -rw-r--r--
2008-07-14 Laszlo (Laca) Peter <[email protected]> * indiana/indiana-branded.speclist: add SUNWevolution-exchange.spec because of its optional dependency on Berkeley DB * SUNWgnome-media.spec: s/CBEbison/SUNWbison/

#
# # spec file for package SUNWgnome-im-client
#
# includes module(s): pidgin, pidgin-otr
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: rickju
#
%include Solaris.inc

%use pidgin = pidgin.spec
%use pidginotr = pidgin-otr.spec

Name:                    SUNWgnome-im-client
Summary:                 GNOME multi-protocol instant messaging client
Version:                 %{default_pkg_version}
Source:                  %{name}-manpages-0.1.tar.gz
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-libs
Requires: SUNWPython
Requires: SUNWbash
Requires: SUNWdbus
Requires: SUNWevolution-data-server
Requires: SUNWgnome-component
Requires: SUNWgnome-libs
Requires: SUNWgnutls
Requires: SUNWlibms
Requires: SUNWperl584core
Requires: SUNWpostrun
Requires: SUNWgnome-media
Requires: SUNWavahi-bridge-dsd
Requires: SUNWsqlite3
Requires: SUNWpr
Requires: SUNWtls
BuildRequires: SUNWPython-devel
BuildRequires: SUNWdbus-devel
BuildRequires: SUNWevolution-data-server-devel
BuildRequires: SUNWgnome-component-devel
BuildRequires: SUNWgnome-libs-devel
BuildRequires: SUNWgnutls-devel
BuildRequires: SUNWgnome-base-libs-devel
BuildRequires: SUNWgnome-libs-devel
BuildRequires: SUNWgnome-media-devel
BuildRequires: SUNWavahi-bridge-dsd-devel
BuildRequires: SUNWsqlite3
BuildRequires: SUNWpr
BuildRequires: SUNWtls

%package root
Summary:                 %{summary} - / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWpostrun-root
Requires: SUNWgnome-config

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: %name
Requires: SUNWgnome-base-libs

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%prep
rm -rf %name-%version
mkdir %name-%version
%pidgin.prep -d %name-%version
%pidginotr.prep -d %name-%version
cd %{_builddir}/%name-%version
gzcat %SOURCE0 | tar xf -

%build
%{!?perl_vendorarch: %define perl_vendorarch %(eval "`%{__perl} -V:installvendorarch`"; echo $installvendorarch)}
export PKG_CONFIG_PATH=../pidgin-%{pidgin.version}/libpurple:../pidgin-%{pidgin.version}:%{_pkg_config_path}
export CFLAGS="%optflags -DHAVE_ALLOCA_H"
export RPM_OPT_FLAGS="$CFLAGS"
export LDFLAGS="%_ldflags"
%pidgin.build -d %name-%version
%pidginotr.build -d %name-%version

%install
%pidgin.install -d %name-%version
%pidginotr.install -d %name-%version

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif

# install man page
rm -rf $RPM_BUILD_ROOT%{_mandir}
cd %{_builddir}/%name-%version/sun-manpages
make install DESTDIR=$RPM_BUILD_ROOT

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%post
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS_wait

%postun
test -x $BASEDIR/lib/postrun || exit 0
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS

%post root
%include gconf-install.script

%preun root
test -x $BASEDIR/var/lib/postrun/postrun || exit 0
( echo 'test -x $PKG_INSTALL_ROOT/usr/bin/gconftool-2 || {';
  echo '  echo "WARNING: gconftool-2 not found; not uninstalling gconf schemas"';
  echo '  exit 0';
  echo '}';
  echo 'umask 0022';
  echo 'GCONF_CONFIG_SOURCE=xml:merged:$BASEDIR/etc/gconf/gconf.xml.defaults';
  echo 'GCONF_BACKEND_DIR=$PKG_INSTALL_ROOT/usr/lib/GConf/2';
  echo 'LD_LIBRARY_PATH=$PKG_INSTALL_ROOT/usr/lib';
  echo 'export GCONF_CONFIG_SOURCE GCONF_BACKEND_DIR LD_LIBRARY_PATH';
  echo 'SDIR=$BASEDIR%{_sysconfdir}/gconf/schemas';
  echo 'schemas="$SDIR/gaim.schemas"';
  echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $schemas'
) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/*.so*
%{_libdir}/pidgin/*.so*
%{_libdir}/purple-2/*.so*
%attr(755, root, bin) %{perl_vendorarch}/Pidgin.pm
%attr(755, root, bin) %{perl_vendorarch}/Purple.pm
%attr(755, root, bin) %{perl_vendorarch}/auto/Pidgin
%attr(755, root, bin) %{perl_vendorarch}/auto/Purple
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/*
%dir %attr (0755, root, other) %{_datadir}/pixmaps
%{_datadir}/pixmaps/*
%{_datadir}/sounds
%dir %attr (-, root, other) %{_datadir}/icons
%dir %attr (-, root, other) %{_datadir}/icons/hicolor
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16/apps
%{_datadir}/icons/hicolor/16x16/apps/pidgin.*
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/22x22
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/22x22/apps
%{_datadir}/icons/hicolor/22x22/apps/pidgin.*
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24/apps
%{_datadir}/icons/hicolor/24x24/apps/pidgin.*
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32/apps
%{_datadir}/icons/hicolor/32x32/apps/pidgin.*
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48/apps
%{_datadir}/icons/hicolor/48x48/apps/pidgin.*
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/man1
%{_mandir}/man1/*

%files root
%defattr(-, root, sys)
%attr(0755, root, sys) %dir %{_sysconfdir}
%{_sysconfdir}/gconf/schemas/purple.schemas

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/pidgin
%{_includedir}/libpurple
%{_includedir}/libotr
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/aclocal
%{_datadir}/aclocal/*

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%endif

%changelog
* Wed May 21 2008 - [email protected]
- Add Build/Requires SUNWsqlite3, SUNWpr and SUNWtls to fix #6703993.
* Fri Mar 07 2008  - [email protected]
- add SUNWavahi-bridge-dsd dependency
* Thu Jan  3 2008 - [email protected]
- use gconf-install.script instead of an inline script
* Thu Dec 06 2007  - [email protected]
- %files changed to bump to pidgin 2.3.0
* Tue Nov 16 2007  - [email protected]
- Use SGML man page instead of the one from community
* Tue Nov 06 2007  - [email protected]
- Add ../pidgin-%{pidgin.version}/libpurple to PKG_CONFIG_PATH so that
  pidgin-otr can find the libpurple libraries during build.
* Fri Nov 02 2007  - [email protected]
  remove SUNWavahi-bridge-dsd dependency
* Wed Oct 10 2007 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Fri Sep 28 2007 - [email protected]
- delete some unnecessary env variables
* Wed Aug 22 2007 - [email protected]
- Update %files for new pidgin tarball.
* Fri Jun 01 2007 - [email protected]
- Set %attr for %{datadir}/icons dirs.
* Tue May 30 2007 - [email protected]
- bump to pidgin 2.0.1
* Tue Apr 24 2007 - [email protected]
- s/0755/-/ in defattr so that files are not made all executable
* Fri Feb  9 2007 - [email protected]
- After a review, remove code that made unnecessary copy of $RPM_BUILD_ROOT
  before installing second module in this spec file.
* Wed Feb  7 2007 - [email protected]
- Fixed an install issue (copy $RPM_BUILD_ROOT before %gaimotr.install.
* Mon Feb  5 2007 - [email protected]
- Add Build/Requires SUNWgnome-media/-devel after check-deps.pl run.
* Wed Jan 17 2007 - [email protected]
- Add gaim-otr.spec.
* Fri May 12 2006 - [email protected]
- Updates for new tarball. Add 'root' package for the gaim.schemas file (and 
  %post/%preun scripts too). Remove %{_datadir}/doc from %files as nothing is 
  installed there now.
* Mon Sep 04 2006 - [email protected]
- New Manpage tarball
* Fri Jul 14 2006 - [email protected]
- update %post/%postun/etc scripts to support diskless client setup,
  part of 6448317
* Thu Jun 29 2006 - [email protected]
- update postrun scripts
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Fri May 12 2006 - [email protected]
- Small update to dependency list after check-deps.pl run.
* Thu May 11 2006 - [email protected]
- Move gaim-client-example to demo directory.
* Thu May 11 2006 - [email protected]
- Merge -share pkg(s) into the base pkg(s).
* Wed May 10 2006 - [email protected]
- Now package gaim-notifications-example demo program.
* Mon Feb 20 2006 - [email protected]
- Complete update of Build/Requires after running check-deps.pl script.
* Thu Feb 16 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Wed Jan 18 2006 - [email protected]
- Add devel files from 2.0.0beta1 tarball.
* Sat Dec  3 2005 - [email protected]
- add %post script that runs update-desktop-database
* Tue Nov 29 2005 - [email protected]
- remove javahelp stuff
* Thu Sep 15 2005 - [email protected]
- Define devel subpkg
* Fri Nov 12 2004 - [email protected]
- Added workaround fix for 6193354
* Wed Nov  3 2004 - [email protected]
- Add BuildRequires of SUNWgnome-javahelp-convert to get 
  javahelp-convert-install.
* Tue Oct 05 2004 - [email protected]
- Added localized help files to l10n %files section
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Thu Sep 23 2004 - [email protected]
- Add BuildRequires of SUNWgnome-libs to get scrollkeeper-preinstall.
* Mon Sep 06 2004 - [email protected]
- Added javahelp to %files share
* Fri Sep 03 2004 - [email protected]
- Changes to support docs tarball added to gaim.spec.
* Mon Aug 23 2004 - [email protected]
- s/SUNWpl5u/SUNWperl584usr/
* Mon Jul 12 2004 - [email protected]
- Unset perms for /usr/share/pixmaps and /usr/share/applications.
* Sat Jul 10 2004 - [email protected]
- Set perms for /usr/share/pixmaps and /usr/share/applications.
* Tue Jun 22 2004 - [email protected]
- changed install location to /usr/lib and /usr/bin
* Wed Jun  2 2004 - [email protected]
- Added %{_datadir}/locale to install l10n messages
* Wed Mar 24 2004 - [email protected]
- Added SGML man page integration
* Tue Mar 23 2004 - <[email protected]>
- add -DHAVE_ALLOCA_H to CFLAGS
* Fri Mar 05 2004 - <[email protected]>
- define PERL5LIB
* Wed Mar 03 2004 - <[email protected]>
- remove unnecessary env vars
- fix %files share
* Mon Mar 01 2004 - <[email protected]>
- set CFLAGS, LDFLAGS