SUNWgnome-themes.spec
author laca
Mon, 14 Jul 2008 09:46:17 +0000
branchgnome-2-22
changeset 12466 cc05ce1b1d3e
parent 12042 821b7874d57c
child 13028 62d8d632aa5f
permissions -rw-r--r--
2008-07-14 Laszlo (Laca) Peter <[email protected]> * indiana/indiana-branded.speclist: add SUNWevolution-exchange.spec because of its optional dependency on Berkeley DB * SUNWgnome-media.spec: s/CBEbison/SUNWbison/

#
# spec file for package SUNWgnome-themes
#
# includes module(s): hicolor-icon-theme,  gnome-themes, gtk2-engines,
# blueprint, nimbus, sun-gdm-themes, gnome-icon-theme
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: erwannc
#
%include Solaris.inc
%ifarch amd64 sparcv9
%include arch64.inc
%use engines_64 = gtk2-engines.spec
%if %option_with_blueprint
%use blueprint_64 = blueprint.spec
%endif
%use nimbus_64 = nimbus.spec
%endif

%include base.inc
%use icon_naming = icon-naming-utils.spec
%use tango = tango-icon-theme.spec
%use hicolor = hicolor-icon-theme.spec
%use engines = gtk2-engines.spec
%use gthemes = gnome-themes.spec
%if %option_with_blueprint
%use blueprint = blueprint.spec
%endif
%use nimbus = nimbus.spec
%if %option_with_sun_branding
%use gdmtheme = sun-gdm-themes.spec
%endif
%if %option_with_indiana_branding
%use gdmtheme = opensolaris-gdm-themes.spec
%use neutralplus = neutral-plus-cursors.spec
%endif
%use icontheme = gnome-icon-theme.spec
%use backgrounds = gnome-backgrounds.spec
%if %option_with_indiana_branding
%use brandedbackgrounds = opensolaris-backgrounds.spec
%endif
%if %option_with_sun_branding
%use brandedbackgrounds = sun-backgrounds.spec
%endif
Name:                    SUNWgnome-themes
Summary:                 GNOME themes and support libraries
Version:                 %{default_pkg_version}
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWgnome-base-libs
Requires: SUNWlibms
Requires: SUNWlxml
Requires: SUNWfreetype2
Requires: SUNWlibpopt
Requires: SUNWpng
Requires: SUNWTiff
Requires: SUNWjpg
Requires: SUNWpostrun
BuildRequires: SUNWimagick
BuildRequires: SUNWperl-xml-parser
BuildRequires: SUNWgnome-base-libs-devel
BuildRequires: SUNWlibpopt-devel

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: SUNWgnome-themes
Requires: SUNWperl584usr
Requires: SUNWperl584core
Requires: SUNWlibms
Requires: SUNWperl-xml-parser

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%prep
rm -rf %name-%version
mkdir %name-%version
%ifarch amd64 sparcv9
mkdir %name-%version/%_arch64
%engines_64.prep -d %name-%version/%_arch64
%if %option_with_blueprint
%blueprint_64.prep -d %name-%version/%_arch64
%endif
%nimbus_64.prep -d %name-%version/%_arch64
%endif

mkdir %name-%version/%base_arch
%icon_naming.prep -d %name-%version/%base_arch
%tango.prep -d %name-%version/%base_arch
%hicolor.prep -d %name-%version/%base_arch
%engines.prep -d %name-%version/%base_arch
%gthemes.prep -d %name-%version/%base_arch
%if %option_with_blueprint
%blueprint.prep -d %name-%version/%base_arch
%endif
%nimbus.prep -d %name-%version/%base_arch
%gdmtheme.prep -d %name-%version/%base_arch
%if %option_with_indiana_branding
%neutralplus.prep -d %name-%version/%base_arch
%endif
%icontheme.prep -d %name-%version/%base_arch
%backgrounds.prep -d %name-%version/%base_arch
%brandedbackgrounds.prep -d %name-%version/%base_arch

%build
export PKG_CONFIG=/usr/bin/pkg-config
PKG_CONFIG_DISABLE_UNINSTALLED=
unset PKG_CONFIG_DISABLE_UNINSTALLED
export EXTRA_CFLAGS="-I/usr/sfw/include -DANSICPP"
export CPPFLAGS="-I/usr/sfw/include"
export EXTRA_LDFLAGS="-L/usr/sfw/lib -R/usr/sfw/lib"
export PERL=/usr/perl5/bin/perl
%icon_naming.build -d %name-%version/%base_arch

export INU_DATA_DIR=%{_builddir}/%name-%version/%base_arch/icon-naming-utils-%{icon_naming.version}
chmod a+x $INU_DATA_DIR/icon-name-mapping
export PATH=$INU_DATA_DIR:$PATH

%ifarch amd64 sparcv9
export PKG_CONFIG_PATH=../../%{_arch64}/gtk-engines-%{engines.version}:%{_builddir}/%name-%version/%{base_arch}/icon-naming-utils-%{icon_naming.version}:/usr/lib/%{_arch64}/pkgconfig
%engines_64.build -d %name-%version/%_arch64
%if %option_with_blueprint
%blueprint_64.build -d %name-%version/%_arch64
%endif
%nimbus_64.build -d %name-%version/%_arch64
%endif

export PKG_CONFIG_PATH=../../%{base_arch}/gtk-engines-%{engines.version}:%{_builddir}/%name-%version/%{base_arch}/icon-naming-utils-%{icon_naming.version}:%{_pkg_config_path}

%tango.build -d %name-%version/%base_arch
%hicolor.build -d %name-%version/%base_arch
%engines.build -d %name-%version/%base_arch
%gthemes.build -d %name-%version/%base_arch
%if %option_with_indiana_branding
%neutralplus.build -d %name-%version/%base_arch
%endif
%if %option_with_blueprint
%blueprint.build -d %name-%version/%base_arch
%endif
%nimbus.build -d %name-%version/%base_arch
%gdmtheme.build -d %name-%version/%base_arch
%icontheme.build -d %name-%version/%base_arch
%backgrounds.build -d %name-%version/%base_arch
%brandedbackgrounds.build -d %name-%version/%base_arch

%install
rm -rf $RPM_BUILD_ROOT

%icon_naming.install -d %name-%version/%base_arch
export INU_DATA_DIR=%{_builddir}/%name-%version/%{base_arch}/icon-naming-utils-%{icon_naming.version}
export PATH=$INU_DATA_DIR:$PATH

%ifarch amd64 sparcv9
%engines_64.install -d %name-%version/%_arch64
%if %option_with_blueprint
%blueprint_64.install -d %name-%version/%_arch64
%endif
%nimbus_64.install -d %name-%version/%_arch64
%endif

%tango.install -d %name-%version/%base_arch
%hicolor.install -d %name-%version/%base_arch
%engines.install -d %name-%version/%base_arch
%gthemes.install -d %name-%version/%base_arch
%if %option_with_indiana_branding
%neutralplus.install -d %name-%version/%base_arch
%endif
%if %option_with_blueprint
%blueprint.install -d %name-%version/%base_arch
%endif
%nimbus.install -d %name-%version/%base_arch
%gdmtheme.install -d %name-%version/%base_arch
%icontheme.install -d %name-%version/%base_arch
%backgrounds.install -d %name-%version/%base_arch
%brandedbackgrounds.install -d %name-%version/%base_arch
chmod 0755 $RPM_BUILD_ROOT%{_datadir}/icons/HighContrastLargePrint/48x48/apps/perfmeter.png
chmod 0755 $RPM_BUILD_ROOT%{_datadir}/icons/HighContrastLargePrintInverse/48x48/apps/perfmeter.png

rm -rf $RPM_BUILD_ROOT%{_prefix}/doc

# Remove branded icons that push out the size of the panel - these need to
# be fixed in the nimbus theme. Also remove the Tango icons, since they are
# 2 feet rather than the GNOME icon
%if %option_with_indiana_branding
rm $RPM_BUILD_ROOT%{_datadir}/icons/nimbus/48x48/apps/gnome-main-menu.png
rm $RPM_BUILD_ROOT%{_datadir}/icons/nimbus/32x32/places/gnome-main-menu.png
rm $RPM_BUILD_ROOT%{_datadir}/icons/Tango/16x16/places/gnome-main-menu.png
rm $RPM_BUILD_ROOT%{_datadir}/icons/Tango/22x22/places/gnome-main-menu.png
rm $RPM_BUILD_ROOT%{_datadir}/icons/Tango/24x24/places/gnome-main-menu.png
rm $RPM_BUILD_ROOT%{_datadir}/icons/Tango/32x32/places/gnome-main-menu.png
%endif

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT%{_libdir}}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/gtk-*/2.*/engines/*.so
%ifarch amd64 sparcv9
%dir %attr (0755, root, bin) %{_libdir}/%{_arch64}
%{_libdir}/%{_arch64}/gtk-*/2.*/engines/*.so
%endif
%dir %attr (0755, root, sys) %{_datadir}
%if %option_with_indiana_branding
%{_datadir}/gdm
%endif
%if %option_with_sun_branding
%{_datadir}/gdm
%endif
%{_datadir}/gtk-engines
%attr (-, root, other) %{_datadir}/icons
%dir %attr (0755, root, other) %{_datadir}/pixmaps
%{_datadir}/pixmaps/*
%{_datadir}/themes
%{_datadir}/gnome-background-properties
%{_datadir}/dtds
%{_datadir}/icon-naming-utils

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %dir %{_libdir}
%{_libdir}/icon-name-mapping
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%dir %attr (0755, root, sys) %dir %{_datadir}
%{_datadir}/pkgconfig
%ifarch amd64 sparcv9
%dir %attr (0755, root, bin) %{_libdir}/%{_arch64}
%dir %attr (0755, root, other) %{_libdir}/%{_arch64}/pkgconfig
%{_libdir}/%{_arch64}/pkgconfig/*
%endif

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%endif

%preun
find $BASEDIR/share/icons -name icon-theme.cache -exec /bin/rm -f {} \;

%post
%include icon-cache.script

%changelog
* Mon Jan 21 2007 - [email protected]
- Split out the OpenSolaris and Sun backgrounds into their
  own individual spec files - build one depending on desired
  branding.
* Fri Jan 18 2007 - [email protected]
- add in neutral plus cursor theme
* Sun Dec 16 2007 - [email protected]
- add datadir/gdm to files if either sun or indiana branding is
  requested
* Wed Oct 10 2007 - [email protected]
- change the inline postinstall script to an include
* Tue Oct  2 2007 - [email protected]
- set different PKG_CONFIG_PATHs for 32-bit and 64-bit
* Fri Sep 28 2007 - [email protected]
- disable building blueprint when the --without-blueprint option is used
- disable building sun-gdm-themes when --with-sun-branding is not used
* Fri May 18 2007 - [email protected]
- add 64-bit versions of theme engines
* Thu Apr 26 2007 - [email protected]
- set PERL for icon-naming-utils, part of 6454456
* Wed Mar 14 2007 - [email protected]
- Add %{_datadir}/gtk-engines to %files for new xml files.
* Wed Mar 07 2007 - [email protected]
- Use full path to icon-naming-utils build dir in PKG_CONFIG_PATH to be able to
  get full path to icon-name-mapping script.
* Tue Mar 06 2007 - [email protected]
- Rename ICON_NAME_MAPPING_DIR var to INU_DATA_DIR after bumping
  icon-name-mapping.
* Mon Aug 14 2006 - [email protected]
- Fix path to icons dir in %preun.
* Sat Aug 12 2006 - [email protected]
- change datadir/icons permissions back to root:other since it's a stable
  interface and wasn't supposed to be changed
* Fri Jul 14 2006 - [email protected]
- update %post/%postun/etc scripts to support diskless client setup,
  part of 6448317
* Thu Jun 29 2006 - [email protected]
- update postrun scripts
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Wed May 10 2006 - [email protected]
- merge -share pkg(s) into the base pkg(s)
* Mon Feb 20 2006 - [email protected]
- Complete update of Build/Requires after running check-deps.pl script.
* Fri Feb 17 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Tue Jan 31 2006 - [email protected]
- Remove ref to LowContrastLargePrint/48x48/apps/perfmeter.png as not installed
* Fri Jan 06 2006 - [email protected]
- Move %files around, including adding %{_datadir}/pkgconfig. For new tarballs.
- Set PATH for %install section so icon-name-mapping is found.
* Wed Dec 20 2005 - [email protected]
- Update PKG_CONFIG_PATH to find icon-naming-utils dir for tango-icon-theme.
* Sat Dec  3 2005 - [email protected]
- add %post script that runs gtk-update-icon-cache
* Tue Sep 20 2005 - [email protected]
- Add gnome-backgrounds
* Fri Sep 09 2005 - [email protected]
- remove unpackaged files
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Tue Aug 24 2004 - [email protected]
- No longer package blueprint docs since the AUTHORS, COPYING, ChangeLog,
  NEWS and README files aren't really useful.
* Wed Aug 18 2004 - [email protected]
- Change perms for some png files for Solaris integration.
* Mon Jul 12 2004 - [email protected]
- Unset perms for /usr/share/pixmaps.
* Sat Jul 10 2004 - [email protected]
- Set perms for /usr/share/pixmaps.
* Sat Jun 26 2004  [email protected]
- Changed install location to /usr/...
* Fri Jun 25 2004 - [email protected]
- set ACLOCAL_FLAGS for gnome-themes build
* Wed Jun  2 2004 - [email protected]
- add %{_datadir}/locale to install l10n messages
* Fri Mar 26 2004 - [email protected]
- update gtk engine directory for 2.4.0
* Fri Mar 12 2004 - [email protected]
- add missing pkgconfig files
* Thu Feb 26 2004 - [email protected]
- add -R%{_libdir} to LDFLAGS
- set PERL5LIB for XML:Parser
- add hicolor build stage
* Thu Feb 19 2004 - [email protected]
- initial Sun release.