base-specs/esound.spec
author Jon Tibble <meths@btinternet.com>
Thu, 15 Mar 2012 09:58:35 +0000
branchs11express-2010-11
changeset 22104 cde243cbe3f6
parent 17864 337913e88a9d
child 19973 f05dadadf325
permissions -rw-r--r--
Added tag oi_151a_prestable2 for changeset 47b3f775541a

#
# spec file for package esound
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner yippi
#

%define OSR LFI#105446 (gnome Exec. summary):n/a

Name:         esound
License:      LGPL v2
Group:        System/Library/GNOME
Version:      0.2.41
Release:      1
Distribution: Java Desktop System
Vendor:       Gnome Community
Summary:      esound - The Enlightened Sound Daemon
Source:       http://ftp.gnome.org/pub/GNOME/sources/esound/0.2/esound-%{version}.tar.bz2
# This patch works with the audiofile-01-uninstalled-config.diff to
# allow esound to be built when audiofile isn't acutally installed on the
# system.
#owner:yippi date:2004-05-07 type:feature
Patch1:       esound-01-esd-config.diff
URL:          http://www.tux.org/~ricdude/overview.html
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on
Requires:     audiofile

%description
The Enlightened Sound Daemon (ESD or EsounD) is the sound server for
Enlightenment and GNOME. It mixes several sound streams into one for output.
It can also manage network-transparent audio.

%prep
%setup -q
%patch1 -p1 -b .orig

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

%if %debug_build
%define debug_opt --enable-debugging
%else
%define debug_opt --disable-debugging
%endif

libtoolize --force
aclocal $ACLOCAL_FLAGS -I .
autoconf
automake -a -c -f
./configure --prefix=%{_prefix}				\
	    --sysconfdir=%{_sysconfdir} 		\
            --with-esd-dir=%{_prefix}/lib		\
            --libdir=%{_libdir}                         \
            --bindir=%{_bindir}                         \
            --libexecdir=%{_prefix}/lib                 \
            --disable-audiofiletest                     \
	    --mandir=%{_mandir} %{debug_opt}
make -j$CPUS


%install
make install DESTDIR=$RPM_BUILD_ROOT

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, root)
%{_bindir}/*
%{_libdir}/*
%{_sysconfdir}/*

%changelog
* Sun Jul 26 2009 - [email protected]
- Bump to 0.2.41.
* Thu Sep 04 2008 - [email protected]
- Bump to 0.2.40.
* Wed Jul 16 2008 - [email protected]
- Bump to 0.2.39.
* Fri May 04 2007 - [email protected]
- Bump to 0.2.38.
* Wed Apr  4 2007 - [email protected]
- convert to new style 64-bit build
* Wed Mar 15 2007 - [email protected]
- Removed adding ccdir to PATH
* Wed Feb 28 2007 - [email protected]
- need to run automake because the maintainer's version is incompatible with
  our version of autoconf
* Wed Feb 28 2007 - [email protected]
- Bump to 0.2.37.
* Sun Feb 18 2007 - [email protected]
- create (split from SUNWgnome-audio.spec)