libgnomeui.spec
author mattk
Thu, 19 Aug 2004 13:02:26 +0000
changeset 3628 cf6118e136d2
parent 3580 39da785696b5
child 3679 a83eeeda363e
permissions -rw-r--r--
Merged from cinnabar-suse91 branch back into HEAD

Name:         libgnomeui 
License:      LGPL
Group:        System/Libraries/GNOME
Version:      2.6.1.1
Release:      16
Distribution: Cinnabar
Vendor:	      Sun Microsystems, Inc.
Summary:      GNOME User Interface Library  
Source:       http://ftp.gnome.org/pub/GNOME/sources/libgnomeui/2.6/libgnomeui-%{version}.tar.bz2
Source1:      libgnomeui-l10n-po-1.3.tar.bz2
Source2:      libgnomeui-2.3.gz
Patch1:       libgnomeui-01-g11n-i18n-ui.diff
Patch2:       libgnomeui-02-g11n-potfiles.diff
Patch3:       libgnomeui-03-druid-sensitivity.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define gtk_doc_version 1.1
%define gtk2_version 2.4.0
%define libbonoboui_version 2.6.0
%define libglade_version 2.3.6
%define libbonobo_version 2.6.0
%define libgnome_version 2.6.0
%define gnome_keyring_version 0.2.0

Requires: gtk2 >= %{gtk2_version}
Requires: libbonoboui >= %{libbonoboui_version}
Requires: libglade >= %{libglade_version}
Requires: gnome-keyring >= %{gnome_keyring_version}
BuildRequires: gtk2-devel >= %{gtk2_version}
BuildRequires: libbonoboui-devel >= %{libbonoboui_version}
BuildRequires: libglade-devel >= %{libglade_version}
BuildRequires: gnome-keyring-devel >= %{gnome_keyring_version}
BuildRequires: gtk-doc >= %{gtk_doc_version}

%description
libgnomeui is the GNOME User Interface Library, containing many widgets and 
convenient API used to developer GNOME applications that is not in GTK+ 
eg. About Dialog, Session Manager support

%package devel
Summary:      GNOME User Interface Development Library
Group:        Development/Libraries/GNOME
Requires:     %{name} = %{version}
Requires:     libgnome-devel >= %{libgnome_version}
Requires:     libbonoboui-devel >= %{libbonoboui_version}

%description devel
libgnomeui is the GNOME User Interface Library, containing many widgets and 
convenient API used to developer GNOME applications that is not in GTK+ 
eg. About Dialog, Session Manager support

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
bzcat %SOURCE1 | tar xf -

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros -I .
autoheader
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"				\
./configure --prefix=%{_prefix}			\
	    --sysconfdir=%{_sysconfdir}		\
	    --mandir=%{_mandir}			\
            --libexecdir=%{_libexecdir}         \
	    --disable-gtk-doc
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
install -d $RPM_BUILD_ROOT%{_mandir}/man3
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man3
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
rm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/filesystems/*.a
rm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/filesystems/*.la
rm $RPM_BUILD_ROOT%{_libdir}/libglade/*/*.a
rm $RPM_BUILD_ROOT%{_libdir}/libglade/*/*.la
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la


%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%{_datadir}/locale/*/LC_MESSAGES/libgnomeui-2.0.mo
%{_datadir}/pixmaps/*.png
%{_libexecdir}/*
%{_libdir}/libglade/2.0/libgnome*so*
%{_libdir}/lib*.so.*
%{_libdir}/gtk-2.0/2.4.0/filesystems/*.so

%files devel
%{_libdir}/pkgconfig/*.pc
%{_includedir}/libgnomeui-2.0/libgnomeui/*.h
%{_includedir}/libgnomeui-2.0/*.h
%{_libdir}/lib*.so
%{_datadir}/gtk-doc/html/libgnomeui
%{_mandir}/man3/*

%changelog
* Wed Jul 28 2004 - [email protected]
- Bump to 2.6.1.1

* Wed Jul 28 2004 - [email protected]
- Add patch to unfocus the widgets on the previous page
  of the GnomeDruid widget. Patch from Eric Zhao.

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to libgnomeui-l10n-po-1.2.tar.bz2

* Thu Jul 08 2004 - [email protected]
- ported to rpm4

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Thu Jun 24 2004 - [email protected]
- Updated libgnomeui-01-g11n-i18n-ui.diff to i18n Filesystem in gtkdialog.
  bugzilla #144529

* Thu Jun 17 2004 - [email protected]
- Added libgnomeui-03-mount-crashed-gedit.diff. The patch is taken from
  HEAD (also included in 2.6.1.1 tarball release). bugzilla id#139063.
  Bugtraq id 5055273. Since we are at Beta, so have to keep this patch
  for the time being and uprev after Beta, this patch can then be removed.

* Tue May 25 2004 - [email protected]
- Added libgnomeui-02-g11n-potfiles.diff

* Wed May 12 2004 - [email protected]
- Updated l10n content to libgnomeui-l10n-po-1.1.tar.bz2

* Wed May 05 2004 - [email protected]
- Add missing gtk file selector plug-in to %files.
  Add gtk2 to requirements

* Wed May 04 2004 - [email protected]
- Remove auth manager patch, it was wrong and rejected in
  bugzilla.

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to libgnomeui-l10n-po-1.0.tar.bz2

* Mon Mar 22 2004 - [email protected]
- Added libgnomeui-02-g11n-i18n-ui.diff to fix 4995208

* Mon Mar 22 2004 - [email protected]
- Bump to 2.6.0 and remove broken file entry patch that doesn't
  fix anything.

* Sun Feb 15 2004 - [email protected]
- Add --libexecdir to the configure options so we get the correct path
  on Solaris

* Mon Feb 02 2004 - [email protected]
- Bump to 2.5.3
- Add ACLOCAL_FLAGS env to aclocal invocation

* Thu Jan 08 2004 - [email protected]
- Update to 2.5.2 to make nautilus build

* Mon Dec 15 2003 - [email protected]
- Update to 2.5.1

* Mon Oct 13 2003 - [email protected]
- added auth manager patch (moved from nautilus)

* Thu Oct 09 2003 - [email protected]
- Updated for 2.4

* Thu Sep 25 2003 - [email protected]
- Fix icon theming for icons with full paths

* Thu Aug 14 2003 - <[email protected]>
- move lib*.so to -devel, remove *.a, *.la

* Thu Aug 07 2003 - [email protected]
- Remove the evil activate signal on file entry 
  browse ok button callback. Stops browse dialog
  being displayed twice, when user selects stuff.

* Thu Aug 07 2003 - [email protected]
- Update tarball, bump version, reset release.

* Thu Jul 10 2003 - [email protected]
- Added .po tarball

* Tue May 13 2003 - [email protected]
- Initial Sun release.