base-specs/enchant.spec
author dcarbery
Thu, 12 Apr 2007 09:05:38 +0000
changeset 9729 d1c8489ce695
parent 9722 b6ef45555846
child 9739 27df7369b7e3
permissions -rw-r--r--
2007-04-12 Damien Carbery <[email protected]> * base-specs/gedit.spec: Bump to 2.18.1. * base-specs/vte.spec: Remove upstream patch, 06-nullptr-check. * patches/vte-06-nullptr-check.diff: Removed, upstream.

#
# spec file for package enchant
#
# Copyright (c) 2006 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: dcarbery
# bugdb: bugzilla.abisource.com
#

Name:     	enchant
License:	LGPL
Version: 	1.3.0
Release:	1
Vendor:		Sun Microsystems, Inc.
Distribution:	Java Desktop System
Copyright:	GPL
BuildRoot:	%{_tmppath}/%{name}-%{version}-build
Docdir:         %{_datadir}/doc
Autoreqprov:    on
URL:		http://www.abisource.com/projects/enchant/
Source:		http://www.abisource.com/downloads/%{name}/%{version}/%{name}-%{version}.tar.gz
# date:2006-12-08 bugzilla:10667 owner:dcarbery type:bug
Patch1:         enchant-01-define_FILE.diff
# date:2007-02-14 owner:jefftsai type:branding bugzilla:10843
Patch2:         enchant-02-uninstalled-pc.diff
# date:2007-04-10 owner:sh162551 type:feature bugzilla:10939
Patch3:         enchant-03-personaldic.diff
Summary:	Generic spell checking library
Group:		Applications/Text

%description
Enchant is a generic spell checking library that presents an API/ABI to 
applications.

%files
%defattr(-, root, root)

%prep
%setup  -q -n %{name}-%{version}
%patch1 -p1
%patch2 -p1
%patch3 -p1


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

aclocal -I ac-helpers $ACLOCAL_FLAGS
autoconf
automake -a -c -f
./configure \
    --prefix=%{_prefix} \
    --sysconfdir=%{_sysconfdir} \
    --mandir=%{_mandir} \
    --infodir=%{_datadir}/info \
    --localstatedir=/var \
	--with-myspell-dir=/usr/lib/thunderbird/dictionaries \
	--disable-aspell \
    --disable-static

make -j $CPUS

%install
make install DESTDIR=$RPM_BUILD_ROOT
rm $RPM_BUILD_ROOT%{_libdir}/*.la
rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
rm $RPM_BUILD_ROOT%{_includedir}/%{name}/enchant++.h

%clean
rm -rf $RPM_BUILD_ROOT

%changelog
* Tue Apr 10 2007 - [email protected]	
- Add patch enchant-02-personaldic.diff to enable personal dictionary support
  of enchant myspell backend and conversion of aspell personal dict to myspell
  format. Fixes bug 6529848 and 6529853.

* Wed Feb 14 2007 - [email protected]
- Make enchant use myspell instead of aspell.
- Add patch enchant-02-uninstalled-pc.diff to enable building in one spec file
  for gnome-spell and enchant.

* Mon Dec 11 2006 - [email protected]
- Remove unnecessary automake call; add autoconf and adjust aclocal calls.

* Fri Dec 08 2006 - [email protected]
- Initial spec.