Solaris/SUNWevolution-libs.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 8565 b102e7809c6e
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package SUNWevolution-libs
#
# includes module(s): libsoup, gtkhtml
#
# Copyright (c) 2004 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: jefftsai
#
%include Solaris.inc
%use libsoup = libsoup.spec
%use gtkhtml = gtkhtml.spec

Name:          SUNWevolution-libs
Summary:       Evolution Email and Calendar - support libraries
Version:       %{default_pkg_version}
SUNW_Category: EVO25,%{default_category}
SUNW_BaseDir:  %{_basedir}
BuildRoot:     %{_tmppath}/%{name}-%{version}-build
%include default-depend.inc
Requires:      SUNWgnome-base-libs
Requires:      SUNWgnome-config
Requires:      SUNWgnome-a11y-base-libs
Requires:      SUNWgnome-print
Requires:      SUNWlxml
Requires:      SUNWzlib
Requires:      SUNWgnutls
Requires: SUNWgnome-component
Requires: SUNWgnome-libs
Requires: SUNWlibgcrypt
Requires: SUNWlibms
BuildRequires: SUNWgnome-component-devel
BuildRequires: SUNWgnome-libs-devel
BuildRequires: SUNWlibgcrypt-devel
BuildRequires: SUNWgnome-base-libs-devel
BuildRequires: SUNWgnome-config-devel
BuildRequires: SUNWgnome-a11y-base-devel
BuildRequires: SUNWgnome-print-devel
BuildRequires: SUNWgnome-component-devel
BuildRequires: SUNWgnutls-devel

%if %build_l10n
%package l10n
Summary:		%{summary} - l10n files
SUNW_BaseDir:		%{_basedir}
%include default-depend.inc
Requires:		%{name}
%endif

%package devel
Summary:		%{summary} - development files
SUNW_BaseDir:		%{_basedir}
%include default-depend.inc
Requires:      SUNWevolution-libs

%prep
rm -rf %name-%version
mkdir -p %name-%version
%libsoup.prep -d %name-%version
%gtkhtml.prep -d %name-%version
cd %{_builddir}/%name-%version
cp gtkhtml-%{gtkhtml.version}/mkinstalldirs libsoup-%{libsoup.version}/

%build
%if %debug_build
# Omit '-xO4 -xspace' from sparc flags as it crashes libgnome-gtkhtml-editor.
# See #6461613.
%else
%ifarch sparc
%define optflags           -i -xstrconst -xarch=v8a -mr
%define cxx_optflags       -i -xarch=v8a -mr -norunpath
%define optflags64	   -i -xstrconst -xarch=v9 -xcode=pic32 -mr
%endif
%endif
export LDFLAGS="%_ldflags -L%{_libdir} -R%{_libdir}"
export CFLAGS="%optflags"
export RPM_OPT_FLAGS="$CFLAGS"
export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
export PKG_CONFIG_PATH=%{_pkg_config_path}
%libsoup.build -d %name-%version
%gtkhtml.build -d %name-%version

%install
%libsoup.install -d %name-%version
%gtkhtml.install -d %name-%version

rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/libsoup
rmdir $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html
rmdir $RPM_BUILD_ROOT%{_datadir}/gtk-doc

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*.so*
%{_libdir}/gtkhtml
%{_libdir}/bonobo
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/gtkhtml-%{gtkhtml.major_version}

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%endif

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*

%changelog
* Tue Aug 22 2006 - [email protected]
- Only change compiler options for non-debug builds.
* Tue Aug 22 2006 - [email protected]
- remove optimization compiler options to fix 6461613.
* Sat Aug 12 2006 - [email protected]
- delete some unnecessary env variables
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Thu May 11 2006 - [email protected]
- Merge -share pkg(s) into the base pkg(s).
- Change %defattr to (-, root, other).
* Tue Apr 04 2006 - [email protected]
- Alter remove .a/.la files part into linux spec. 
* Thu Mar 30 2006 - [email protected]
- Remove all *.a/*.la files.
* Thu Feb 23 2006 - [email protected]
- Use default pkg version to match other pkgs; add EVO25 to default category.
* Mon Feb 20 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Fri Sep 09 2005 - <[email protected]>
- remove unpackaged files
* Wed Aug 31 2005 - [email protected]
- Bump to 2.4.0 for evolution version changed.
* Wed Aug 31 2005 - [email protected]
- Change SUNW_Category and Version for open solaris
* Wed Aug 31 2005 - [email protected]
- Remove the obsoleted libgal.
* Tue Jul 12 2005 - [email protected]
- Correct version numbers in dir names in share package.
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Tue Sep 27 2004 - [email protected]
- changed the version from "2.6.0" to "1.4.6" for consistent with SUNWevolution
* Tue Aug 31 2004 - [email protected]
- Bug 5091588 : Added BuildRequires SUNWgnutls-devel since SUNWgnutils was
  split
* Thu Aug 26 2004 - [email protected]
- changed the spec file name from 'gal.spec' to 'libgal.spec' to keep
  consistent with file name and package name it defines
* Tue Jul 27 2004 - [email protected]
- Add SUNWgnome-component-devel as BuildRequires, for ORBit-2.0.
* Fri Jul 23 2004 - [email protected]
- use evolution-libs-copyright.txt as copyright notice
* Sat Jun 26 2004  [email protected]
- Changed install location to /usr/...
* Wed Jun  2 2004 - [email protected]
- Added %{_datadir}/locale to install l10n messages
* Tue Apr 20 2004 - <[email protected]>
- Add libgnomeprint dependencies
* Thu Mar 11 2004 - <[email protected]>
- initial version created