Solaris/SUNWimagick.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 8565 b102e7809c6e
child 8674 296e4457b05f
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package SUNWimagick
#
# includes module(s): imagemagick
#
# Copyright (c) 2004 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: laca
#
# DO NOT REMOVE NEXT LINE
# PACKAGE NOT ARC REVIEWED BY SUN JDS TEAM
#
%include Solaris.inc

Name:                    SUNWimagick
%define tarball_version  6.2.5
Summary:                 ImageMagick - Image Manipulation Utilities and Libraries %{tarball_version}
Version:                 11.10.1
%define im_rev -5
Source:                  ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick-%{tarball_version}%{im_rev}.tar.bz2
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
%define perl_version 5.8.4
%ifarch sparc
%define perl_dir sun4-solaris-64int
%else
%define perl_dir i86pc-solaris-64int
%endif
%include default-depend.inc
Requires: SUNWbzip
Requires: SUNWfreetype2
Requires: SUNWgscr
Requires: SUNWjpg
Requires: SUNWperl584usr
Requires: SUNWpng
Requires: SUNWTiff
Requires: SUNWzlib
Requires: SUNWlxml
Requires: SUNWlibC
Requires: SUNWlibms
Requires: SUNWxwrtl
BuildRequires: SUNWjpg-devel
BuildRequires: SUNWpng-devel
BuildRequires: SUNWTiff-devel

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: %name

%prep
%setup -q -n ImageMagick-%tarball_version

%build
export CXXFLAGS="%cxx_optflags -lCrun -lCstd"
export LDFLAGS="%_ldflags"
export CFLAGS="%optflags"
./configure --prefix=%{_prefix} \
            --disable-static \
            --mandir=%{_mandir}

%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT

rm -rf $RPM_BUILD_ROOT%{_libdir}/ImageMagick-*/modules*
rm $RPM_BUILD_ROOT%{_libdir}/lib*.la
mv $RPM_BUILD_ROOT/usr/perl5/site_perl $RPM_BUILD_ROOT/usr/perl5/vendor_perl
rm -rf $RPM_BUILD_ROOT/usr/perl5/*/lib

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{tarball_version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*.so*
%{_libdir}/ImageMagick*/config
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/[a-z]*
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/ImageMagick-*
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/man1
%{_mandir}/man1/*
#/usr/perl5/*/man/man3/Image::Magick.3
%dir %attr(0755, root, bin) %{_prefix}/perl5
%{_prefix}/perl5/%{perl_version}/man
%dir %attr(0755, root, bin) %{_prefix}/perl5/vendor_perl
%dir %attr(0755, root, bin) %{_prefix}/perl5/vendor_perl/%{perl_version}
%dir %attr(0755, root, bin) %{_prefix}/perl5/vendor_perl/%{perl_version}/%{perl_dir}
%{_prefix}/perl5/vendor_perl/%{perl_version}/%{perl_dir}/Image
%dir %attr(0755, root, bin) %{_prefix}/perl5/vendor_perl/%{perl_version}/%{perl_dir}/auto
%{_prefix}/perl5/vendor_perl/%{perl_version}/%{perl_dir}/auto/*


%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*-config
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/doc
%{_datadir}/doc/*

%changelog
* Mon Oct 16 2006 - [email protected]
- Remove the '-rf' from the 'rm *.la *.a' lines so that any changes to the
  module source will be seen as a build error and action can be taken.
* Sun Oct 08 2006 - [email protected]
- Unbump because it breaks gnome-themes.
* Sat Oct  7 2006 - [email protected]
- Bump to 6.2.9-8
* Mon Feb 20 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Wed Feb 15 2006 - [email protected]
- Correct perl perms to match those in other packages.
* Thu Dec  8 2005 - [email protected]
- renamed to SUNWimagick
* Thu Dec 08 2005 - [email protected]
- Bump to 6.2.5-5.
* Sat Oct 15 2005 - [email protected]
- created