Solaris/SUNWlibcdio.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 8565 b102e7809c6e
child 8706 f5e00fe9610a
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package SUNWlibcdio
#
# includes module(s): libcdio
#
# Copyright (c) 2004 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: yippi
#
%include Solaris.inc

%use libcdio = libcdio.spec

Name:                    SUNWlibcdio
Summary:                 GNU libcdio
Version:                 %{libcdio.version}
Patch1:                  libcdio-01-usehal.diff
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWlexpt
Requires: SUNWlibC
Requires: SUNWlibmsr
Requires: SUNWgccruntime
Requires: SUNWlibms
Requires: SUNWdbus
Requires: SUNWhal
BuildRequires: SUNWlexpt
BuildRequires: SUNWgcc
BuildRequires: SUNWdbus-devel

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc

%prep
rm -rf %name-%version
mkdir %name-%version
%libcdio.prep -d %name-%version

cd %{_builddir}/%name-%version/libcdio-%{libcdio.version}
%patch1 -p1

# Note, we have to build this with gcc, because Forte cannot handle
# the flexible arrays used in libcdio.  We should move to using Forte
# if this issue is resolved with the Forte compiler.
#
%build
export PKG_CONFIG_PATH=%{_pkg_config_path}
export MSGFMT="/usr/bin/msgfmt"
export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
export PERL5LIB=%{_prefix}/perl5/site_perl/5.6.1/sun4-solaris-64int
export RPM_OPT_FLAGS="$CFLAGS"
export LDFLAGS="%_ldflags -lhal -ldbus-1"
export CC=gcc

%libcdio.build -d %name-%version

%install
%libcdio.install -d %name-%version

rm -rf $RPM_BUILD_ROOT%{_mandir}
rm -rf $RPM_BUILD_ROOT%{_prefix}/share
rm -rf $RPM_BUILD_ROOT%{_prefix}/info

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*.so*

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/cdio

%changelog
* Fri Oct 20 2006 - [email protected]
- Remove %with_hal code as HAL is in snv now.
- Remove SUNWhalh BuildRequires because header files are in SUNWhea in snv_51.
* Mon Sep 18 2006 - [email protected]
- Add SUNWhalh BuildRequires.
* Mon Aug 14 2006 - [email protected]
- Add Build/Requires SUNWhal after check-deps.pl run.
* Fri Aug 11 2006 - [email protected]
- Add Build/Requires SUNWdbus/-devel as LDFLAGS references dbus.
* Fri Jul 28 2006 - [email protected]
- Add patch so that libcdio can find the default CD device when
  vold is not running.  Note that we do not run vold when HAL
  is running, so the /vol/dev/aliases/cdrom0 symlink can't be
  used.  So we use HAL to get the device name for now.  At some
  point in the future a more friendly symlink may be added to
  Nevada which could be used instead.
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Fri May 12 2006 - [email protected]
- Small update to dependency list after check-deps.pl run.
* Thu Mar 30 2006 - [email protected]
- Add SUNWgcc build dependency as it will not build with forte.
* Tue Mar 14 2006 - [email protected]
- Initial spec-file created