Solaris/SUNWlibgtop.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 8565 b102e7809c6e
child 8696 16d3205740f6
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# 
# spec file for package SUNWlibgtop  
#
# includes module(s): libgtop
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: henryz
#
%include Solaris.inc
%use libgtop = libgtop.spec

Name:              SUNWlibgtop
Summary:           Library to get system specific data 
Version:           %{default_pkg_version}
SUNW_BaseDir:      %{_basedir}
BuildRoot:         %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWgnome-component
Requires: SUNWgnome-print
Requires: SUNWgnome-libs
Requires: SUNWjdsrm
Requires: SUNWgnome-config
Requires: SUNWgnome-base-libs
Requires: SUNWlibms
Requires: SUNWlibpopt
Requires: SUNWmlib
BuildRequires: SUNWgnome-config-devel
BuildRequires: SUNWlibpopt-devel
BuildRequires: SUNWgnome-libs-devel
BuildRequires: SUNWgnome-base-libs-devel
BuildRequires: SUNWgnome-print-devel
BuildRequires: SUNWgnome-component-devel
BuildRequires: SUNWgnome-config-devel



%package devel
Summary:           Library to get system specific data - developer files
SUNW_BaseDir:      %{_basedir}
%include default-depend.inc
Requires: %name

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%prep
rm -rf %name-%version
mkdir %name-%version
%libgtop.prep -d %name-%version


%build
export PKG_CONFIG_PATH=%{_pkg_config_path}
export MSGFMT="/usr/bin/msgfmt"
export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
export PERL5LIB=%{_prefix}/perl5/site_perl/5.6.1/sun4-solaris-64int
export CFLAGS="%optflags"
export RPM_OPT_FLAGS="$CFLAGS"
export LDFLAGS="%_ldflags"

%libgtop.build -d %name-%version
export PATH=%{_builddir}/%name-%version:$PATH
export CFLAGS="`echo %optflags | sed -e 's/-xregs=no.frameptr//'`"

%install
%libgtop.install -d %name-%version
# Remove the libgtop2.info file. No other modules install .info files.
rm -rf $RPM_BUILD_ROOT%{_datadir}/info
# delete files don't need
rm -rf $RPM_BUILD_ROOT%{_bindir}

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*.so*


%files devel
%defattr(-, root, bin)
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%dir %attr (0755, root, sys) %{_datadir}

%if %build_l10n
%files l10n
%defattr (-, root, other)
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/locale
%endif

%changelog
* Fri Sep 22 2006 - [email protected]
-  Shorten the summary according to Shirley comments.
-  Delete unuseful binary files from /usr/bin

* Thu Aug 23 2006 - [email protected]
- Remove the %{_datadir}/info dir as no other modules install .info files.

* Thu May 11 2006 - [email protected]
- initial version