at-spi.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 8574 14e0002e1ae5
child 8739 6b048ce3e49c
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package at-spi
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: padraig
#
Name:         at-spi
License:      LGPL
Group:        System/Libraries
Version:      1.7.12
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Assistive Technology Service Provider Interface
Source:       http://ftp.gnome.org/pub/GNOME/sources/at-spi/1.7/%{name}-%{version}.tar.bz2
Source1:      at-spi.3.gz
Source2:      libcspi.3.gz
#owner:padraig date:2006-10-11 type:bug bugster:6457388 bugzilla:361386/369377
Patch1:       at-spi-01-fix-leak.diff
URL:          http://developer.gnome.org/projects/gap/
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on
Prereq:	      /sbin/ldconfig

%define gtk2_version 2.4.0
%define libbonobo_version 2.6.0
%define atk_version 1.7.2
%define gail_version 1.6.3

BuildRequires: gtk2-devel >= %{gtk2_version}
BuildRequires: libbonobo-devel >= %{libbonobo_version}
BuildRequires: gail-devel >= %{gail_version}
Requires:      gtk2 >= %{gtk2_version}
Requires:      libbonobo >= %{libbonobo_version}
Requires:      gail >= %{gail_version}

%description
at-spi allows assistive technologies to access GTK-based
applications. Essentially it exposes the internals of applications for
automation, so tools such as screen readers, magnifiers, or even
scripting interfaces can query and interact with GUI controls.

%package devel
Summary:	Assistive Technology Service Provider Developer Interface
Group:		Development/Libraries/GNOME
Requires:	%{name} = %{version}
Requires:       libbonobo-devel >= %{libbonobo_version}
Requires:       atk-devel >= %{atk_version}

%description devel
at-spi allows assistive technologies to access GTK-based
applications. Essentially it exposes the internals of applications for
automation, so tools such as screen readers, magnifiers, or even
scripting interfaces can query and interact with GUI controls.

%prep
%setup -q
%patch1 -p1


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf
CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}			\
            --sysconfdir=%{_sysconfdir}		\
	    --mandir=%{_mandir}			\
	    --libexecdir=%{_libexecdir}		\
	    %{gtk_doc_option}
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
install -d $RPM_BUILD_ROOT%{_mandir}/man3
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man3
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man3
rm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
rm $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
rm $RPM_BUILD_ROOT%{_libdir}/*.la


%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr(-,root,root)
%{_libdir}/libspi*.so.*
%{_libdir}/libcspi*.so.*
%{_libdir}/libloginhelper*.so.*
%{_libdir}/gtk-2.0/modules/*.so
%{_libdir}/bonobo/servers/*.server
%{_libdir}/orbit-2.0/*.so
%{_libexecdir}/at-spi-registryd
%{_datadir}/locale/*

%files devel
%defattr(-, root, root)
%{_includedir}/at-spi-1.0/cspi/*.h
%{_includedir}/at-spi-1.0/libspi/*.h
%{_includedir}/at-spi-1.0/login-helper/*.h
%{_libdir}/pkgconfig/*.pc
%{_datadir}/gtk-doc/html
%{_datadir}/idl
%{_libdir}/libspi*.so
%{_libdir}/libcspi*.so
%{_libdir}/libloginhelper*.so
%{_mandir}/man3/*

%changelog
* Fri Nov 10 2006 - [email protected]
- Remove patch 01-define-symbols.diff; move patch 02-fix-leak.diff to
  01-fix-leak.diff
* Fri Nov  3 2006 - [email protected]
- use %gtk_doc_option in configure so that it can be disabled using
  --without-gtk-doc
* Wed Oct 11 2006 - [email protected]
- Add patch 02-fix-leak to fix bug 6457388
* Mon Oct 02 2006 - [email protected]
- Bump to 1.7.12.
* Tue Aug 22 2006 - [email protected]
- Bump to 1.7.11.
* Tue Jul 25 2006 - [email protected]
- Bump to 1.7.10.
* Wed Jul 19 2006 - [email protected]
- Bump to 1.7.9
* Mon Apr 01 2006 - [email protected]
- Add patch 01-define-symbols so that gok builds.
* Fri Mar 31 2006 - [email protected]
- Bump to 1.7.7.
* Tue Feb 28 2006 - [email protected]
- Bump to 1.7.6.
* Thu Feb 23 2006 - [email protected]
- Remove 'make clean' hack as 1.7.5 tarball fixed the issue.
* Tue Feb 21 2006 - [email protected]
- Bump to 1.7.5.
* Thu Feb 16 2006 - [email protected]
- Add "make clean" hack to ensure that the bonobo
  registry server file is built with the right
  sysconfdir.
* Tue Jan 31 2006 - [email protected]
- Bump to 1.7.4.
* Tue Jan 31 2006 - [email protected]
- Bump to 1.7.3.
* Fri Jan 20 2006 - [email protected]
- Bump to 1.7.2.
* Thu Sep 08 2005 - [email protected]
- Bump to 1.6.6.
* Mon Sep 05 2005 - [email protected]
- Bump to 1.6.5.
* Tue Aug 23 2005 - [email protected]
- Move CFLAGS setting as it was useless in original location.
* Tue Jun 14 2005 - [email protected]
- Added aclocal/automake/autoconf, needed for Solaris build.
* Mon May 16 2005 - [email protected]
- Bump to 1.6.4 
* Mon May 16 2005 - [email protected]
- Bump to 1.6.3 
* Tue Apr 5 2005 - [email protected]
- Added patch at-spi-01-leakfix.diff to fix leak in bounds-change events.
* Thu Dec 9 2004 - [email protected]
- Revved to 1.6.2, to get fixes for 6192693, 6205004, others.
* Wed Sep 1 2004 - [email protected]
- Bumped to version 1.5.4, to include fixes for 
- activation issues with DISPLAY env, and gnopernicus
- dependencies.
* Tue Aug 31 2004 - [email protected]
- Removed patch since #5088625 has been fixed, and
- the patch is incompatible with the fix.
* Wed Aug 18 2004 - [email protected]
- added patch from Padraig to work around P1/S2 bug #5088625.
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds
* Fri Jun 11 2004 - [email protected]
- add login-helper headers and lib to %files
* Wed Jun 02 2004 - <[email protected]>
- Bump version to 1.5.2
* Fri Apr 30 2004 - <[email protected]>
- Bump version to 1.5.1
* Tue Mar 23 2004 - <[email protected]>
- Remove "patch -p1" from the %prep section since
  the patch was removed, and this is causing an
  error on Solaris build.
* Tue Mar 23 2004 - <[email protected]>
- Bump version to 1.4.0, remove reference to 
  at-spi-01-uninstalled-idldir.diff
* Mon Mar 22 2004 - <[email protected]>
- backport idldir fix in uninstalled.pc files from HEAD
* Tue Mar 16 2004 - <[email protected]>
- Remove the uninstalled-pc patch as it's 
  upstream now.
* Thu Mar 11 2004 - <[email protected]>
- Reset release to 1.
* Wed Mar 10 2004 - <[email protected]>
- Bump to 1.3.15
* Mon Feb 23 2004 - [email protected]
- Add '--libexecdir=%{_libexecdir}' to install files to correct dir on Solaris.
* Wed Feb 18 2004 - [email protected]
- tarball upgrade to 1.3.12, add manpages, update %files
* Wed Dec 16 2003 - [email protected]
- tarball upgrade to 1.3.9
* Fri Oct 10 2003 - [email protected]
- tarball upgrade
* Thu Aug 14 2003 - <[email protected]>
- move *.so to -devel, remove *.a and *.al
* Thu May 08 2003 - [email protected]
- Created new spec file for at-spi