gnome-vfs.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 8565 b102e7809c6e
child 8644 03a152fd5cf6
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package gnome-vfs
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: gheet
#
Name:         gnome-vfs
License:      LGPL
Group:        System/Libraries/GNOME
Version:      2.16.2
Release:      4
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Virtual File System Library for GNOME
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.16/%{name}-%{version}.tar.bz2
Source1:      libgnomevfs-2.3.gz
Source2:      gnomevfs-mkdir.1.gz
Source3:      gnomevfs-cat.1.gz
Source4:      gnomevfs-copy.1.gz
Source5:      gnomevfs-info.1.gz
Source6:      gnomevfs-ls.1.gz
Patch1:       gnome-vfs-01-default-url-handler.diff
Patch2:       gnome-vfs-02-mime-info-file-path.diff
Patch3:       gnome-vfs-03-g11n-i18n-ui.diff
Patch4:       gnome-vfs-04-trash-only-home.diff
Patch5:       gnome-vfs-05-mount-points-fix.diff
Patch6:       gnome-vfs-06-trash-files-from-different-filesystem.diff
Patch7:       gnome-vfs-07-socks-version.diff
Patch8:       gnome-vfs-08-audio-cd-show-icon.diff
Patch9:       gnome-vfs-09-trash-skip-copy.diff
Patch10:      gnome-vfs-10-login_tty.diff
Patch11:      gnome-vfs-11-krb5-config-no-gssapi.diff
Patch12:      gnome-vfs-12-hidden.diff
Patch13:      gnome-vfs-13-acl-permissions.diff

URL:          http://www.gnome.org/
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:	      %{_defaultdocdir}/doc
Autoreqprov:  on
Prereq:       /sbin/ldconfig
Prereq:       GConf

%define libbonobo_version 2.6.0
%define GConf_version 2.6.1
%define gnome_mime_data_version 2.4.1
%define shared_mime_info_version 0.14
%define cdparanoia_version IIIalpha9.8-543
%define libsmbclient_version 3.0.4-1.22
%define gnome_vfs_extra_version 0.99.10

Requires:      libbonobo >= %{libbonobo_version}
Requires:      GConf >= %{GConf_version}
Requires:      gnome-mime-data >= %{gnome_mime_data_version}
Requires:      shared-mime-info >= %{shared_mime_info_version}
Requires:      cdparanoia >= %{cdparanoia_version}
Requires:      libsmbclient >= %{libsmbclient_version}
BuildRequires: libbonobo-devel >= %{libbonobo_version}
BuildRequires: GConf-devel >= %{GConf_version}
BuildRequires: gnome-mime-data >= %{gnome_mime_data_version}
BuildRequires: shared-mime-info >= %{shared_mime_info_version}
BuildRequires: libsmbclient-devel >= %{libsmbclient_version}

Obsoletes:	gnome-vfs-extras <= %{gnome_vfs_extra_version} 
Provides:      gnome-vfs-extras  = %{gnome_vfs_extra_version} 

%description
GNOME VFS is the GNOME virtual file system. It is the foundation of the
Nautilus file manager. It provides a modular architecture and ships with
several modules that implement support for file systems, http, ftp and others.
It provides a URI-based API, a backend supporting asynchronous file operations,
a MIME type manipulation library and other features.

%package devel
Summary:      The development package for the GNOME Virtual File System
Group:        Development/Libraries/GNOME
Requires:     %{name} = %{version}
Requires:     GConf-devel >= %{GConf_version}
Requires:     libbonobo-devel >= %{libbonobo_version}

%description devel
GNOME VFS is the GNOME virtual file system. It is the foundation of the
Nautilus file manager. It provides a modular architecture and ships with
several modules that implement support for file systems, http, ftp and others.
It provides a URI-based API, a backend supporting asynchronous file operations,
a MIME type manipulation library and other features.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
%patch11 -p1
%patch12 -p1
%patch13 -p1
# Fix for 326431. 
cd po
dos2unix -ascii be.po be.po
cd ..

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi
libtoolize --force
glib-gettextize --force
intltoolize -c -f --automake
aclocal $ACLOCAL_FLAGS -I .
gtkdocize
autoheader
automake -a -c -f
autoconf
CFLAGS="$RPM_OPT_FLAGS -DDBUS_API_SUBJECT_TO_CHANGE=1"	\
./configure --prefix=%{_prefix}		\
            --sysconfdir=%{_sysconfdir} \
            --libexecdir=%{_libexecdir} \
            %{gtk_doc_option}
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make DESTDIR=$RPM_BUILD_ROOT install
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install -d $RPM_BUILD_ROOT%{_mandir}/man3
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man3
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE4 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE5 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE6 $RPM_BUILD_ROOT%{_mandir}/man1
rm $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/*.a
rm $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/*.la
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la

#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/

%post
/sbin/ldconfig
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="system_http_proxy.schemas desktop_gnome_url_handlers.schemas desktop_default_applications.schemas system_smb.schemas"
for S in $SCHEMAS; do
  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%postun
/sbin/ldconfig

%clean 
rm -rf $RPM_BUILD_ROOT

%files 
%defattr(-, root, root)
%{_bindir}/*
%{_datadir}/locale/*/LC_MESSAGES/gnome-vfs-2.0.mo
%{_libdir}/bonobo/servers/GNOME_VFS_Moniker_std.server
%{_libdir}/bonobo/servers/GNOME_VFS_Daemon.server
%{_sysconfdir}/gconf/schemas/*.schemas
%config %{_sysconfdir}/gnome-vfs-2.0
%{_libdir}/gnome-vfs-2.0/modules/*.so
%{_libexecdir}/*
%{_libdir}/libgnomevfs-2.so.*

%files devel
%defattr(-, root, root)
%{_libdir}/pkgconfig/gnome-vfs-2.0.pc
%{_libdir}/pkgconfig/gnome-vfs-module-2.0.pc
%{_includedir}/gnome-vfs-2.0
%{_includedir}/gnome-vfs-module-2.0
%{_libdir}/gnome-vfs-2.0/include
%{_libdir}/libgnomevfs-2.so
%{_datadir}/gtk-doc/html/gnome-vfs-2.0
%{_mandir}/man1/*
%{_mandir}/man3/*

%changelog
* Fri Nov 10 2006 - [email protected]
- removed gnome-vfs-01-uri-canonizing.diff, which is a old patch used of 
  vfolder and has consulted laszlo.kovacs.
- removed gnome-vfs-02-gopher-proxy-schema.diff, which is no longer use as 
  firefox doesnot make Solaris changes now.
* Wed Nov 08 2006 - [email protected]
- Bump to 2.16.2.
* Tue Nov  7 2006 - [email protected]
- removed gnome-vfs-02-uninstalled-pc.diff (logged as bugzilla 371610)
* Fri Nov  3 2006 - [email protected]
- use %gtk_doc_option in configure so that it can be disabled using
  --without-gtk-doc
* Mon Oct 23 2006 - [email protected]
- Added intlotoolize to build .po files. Fixes 6484798.
* Mon Oct 02 2006 - [email protected]
- Bump to 2.16.1.
* Mon Sep 04 2006 - [email protected]
- Bump to 2.16.0.
* Tue Seo 4 2006 - [email protected]
- gnome-vfs-16-acl-permissions: Added new patch. Fixes community
  ACL related bug. This patch will be upstream within a few days.
* Tue Aug 29 2006 - [email protected]
- gnome-vfs-12-ftp-show-permissions.diff removed because
  the bug it fixed has been fixed in the latest nautilus.
* Tue Aug 08 2006 - [email protected]
- Bump to 2.15.91.
* Thu Jul 27 2006 - [email protected]
- Remove upstream patch, 17-__FUNCTION__.
* Wed Jul 26 2006 - [email protected]
- Bump to 2.15.90.
* Sat Jul 22 2006 - [email protected]
- define DBUS_API_SUBJECT_TO_CHANGE
- add patch __FUNCTION__.diff
- delete bonobo monikers stuff from %files and %install
* Fri Jul 21 2006 - [email protected]
- Bump to 2.15.3.
* Fri Jun 23 2006 - [email protected]
- Bump to 2.14.2
* Mon May 29 2006 - [email protected]
- Add patch, 17-hidden, to remove G_GNUC_INTERNAL to build.
* Tue May 23 2006 - [email protected]
- remove patch all-linguas.diff, add glib-gettextize instead
* Thu May 11 2006 - [email protected]
- Added patch #17: ACL support
* Tue May 02 2006 - [email protected]
- Add patch, 16-krb5-config-no-gssapi, to update call to krb5-config as the
  gssapi parameter is obsolete.
* Fri Apr 21 2006 - [email protected]
- Add patch 15-all-linguas to replace @ALL_LINGUAS@ in po/Makefile with the
  list of languages. Bugzilla: 339276.
* Thu Apr 20 2006 - [email protected]
- Bump to 2.14.1.
* Thu Apr 13 2006 - [email protected]
- replace sed with dos2unix to work around ^M problem in SVN
* Mon Mar 13 2006 - [email protected]
- Bump to 2.14.0.
* Wed Mar  1 2006 - [email protected]
- use sed instead of dos2unix for converting the po files, because dos2unix
  corrupts some UTF-8 strings
* Mon Feb 27 2006 - [email protected]
- Bump to 2.13.92.
* Mon Feb 21 2006 - [email protected]
- Add patch, 15-be_po, to workaround #332050.
* Mon Feb 13 2006 - [email protected]
- Bump to 2.13.91.
* Thu Jan 19 2006 - [email protected]
- Remove upstream patch (15-nocopy).
* Tue Jan 17 2006 - [email protected]
- Bump to 2.13.4
* Tue Jan 10 2006 - [email protected]
- dos2unix be.po to fix 326431.
* Tue Dec 21 2005 - [email protected]
- Remove upstream patch, 15-forte-build-fix. Add patch, 15-login_tty to skip
  call to a Linux-only function, login_tty.
* Tue Dec 20 2005 - [email protected]
- Bump to 2.13.3.
* Tue Nov 29 2005 - [email protected]
- Bump to 2.12.2.
* Tue Oct 11 2005 - [email protected]
- Bump to 2.12.1.1
* Wed Sep 14 2005 - [email protected]
- Bump to 2.12.0
* Mon Sep 05 2005 - [email protected]
- Bump to 2.11.92.
* Mon Aug 15 2005 - [email protected]
- Bump 2.11.90.
* Sun Aug 07 2005 - [email protected]
- Remove Computer and subfs patches to align better with community code.
  Narayana did the work to decide which bits we need to remove.
* Thu Aug 04 2005 - [email protected]
- add patch18 (nocopy.diff) for bugzilla bug 311591,
  fix by <[email protected]>
* Wed Jul 27 2005 - [email protected]
- Removed patches gnome-vfs-04-nfs-drag-crash.diff (not required as nfs:// 
  method is removed) and gnome-vfs-12-correct-screen-for-folder.diff
  (upstream, fix present in 2.10). Renamed the other patches accordingly.
* Fri Jun 24 2005 - [email protected]
- Added patch gnome-vfs-19-subfs.diff 
- Removed patch gnome-vfs-X-subfs.diff
* Fri May 13 2005 - [email protected]
- Updated the patch gnome-vfs-42-subfs.diff with fix for bug #6257289,
  crashing of nautilus when doing eject from context menu of CD icon.
* Wed May 11 2005 - [email protected]
- Add patch 18 to remove usage of gcc-extension that is not available
  in Forte.
* Fri May 06 2005 - [email protected]
- Updated the patch gnome-vfs-45-smb-browse-fixes.diff with fixes for
  bug #6259956, permissions not followed in smb:///. The changes were
  backported from community CVS HEAD.
* Fri May 06 2005 - [email protected]
- Bump to 2.10.1
* Fri Apr 22 2005 - [email protected]
- Added patch gnome-vfs-53-trash-skip-copy.diff to fix a trash issue.
  Fixes bug #6243507
* Thu Apr 08 2005 - [email protected]
- Updated the patch gnome-vfs-45-smb-browse-fixes.diff with fixes for
  bugs #6247186 (issue of authentication when username is present in URI)
  and #6243484 (server caching issues when authentication details entered
  are wrong first time). Patch for 6243484 has been committed to community
  CVS HEAD (bugzilla bug#171468). And patch for 6247186 has been submitted
  to bugzilla bug#172695.
* Thu Apr 07 2005 - [email protected]
- Added gnome-vfs-52-ftp-auth.diff, which introduces the
  functionality for one time authentication for the user.
* Wed Apr 06 2005 - [email protected]
- Modified patch gnome-vfs-10-this-comp-and-hotplug-names.diff 
  Fixes bug #6242108
* Tue Mar 15 2005 - [email protected]
- Added patch gnome-vfs-51-ftp-show-permissions.diff to show the permissions
  of file/folders in ftp method.
  Fixes bug #6232138
* Fri Mar 11 2005 - [email protected]
- Added patch gnome-vfs-50-audio-cd-show-icon.diff to show the icon for audio
  cd as well. Fixes bug #6228176
* Mon Mar 07 2005 - [email protected]
- Updated the patch gnome-vfs-45-smb-browse-fixes.diff with fix for the 
  bug#6234261. Fixes the issue of domains not appearing in some networks.
  Patch was backported from community CVS HEAD.
* Fri Feb 25 2005 - [email protected]
- Updated gnome-vfs-24-g11n-i18n-ui.diff to localize desktop icons.
  Fixes #6233183
* Mon Feb 11 2005 - [email protected]
- Updated the patch gnome-vfs-45-smb-browse-fixes.diff with community 
  smb method rewrite. Community has re-written smb method authentication
  completely. The patch backports all the changes. It fixes bugs like 
  4961385, 6203800 in an elegant way.
* Fri Feb 11 2005 - [email protected]
- Added gnome-vfs-49-socks-version.diff to add a new gconf key for
  SOCKS version. Fixes #4951431.
* Thu Feb 10 2005 - [email protected]
- Added patch gnome-vfs-48-trash-files-from-different-filesystem.diff
  to allow moving items to trash for a filesystem other than the one the users
  home directory resides on.  Fixes 6200485
* Tue Feb 01 2005 - [email protected]
- Obsoletes gnome-vfs-extra.
* Tue Feb 01 2005 - [email protected]
- Added patch gnome-vfs-47-mime-type-case-insensitive.diff to make mime type
  detection case insensitive.
  Fixes bug #5068327
* Mon Jan 17 2005 - [email protected]
- Added patch gnome-vfs-45-smb-browse-fixes.diff to fix smb:// browsing
  issues. Fixes the bugs: 6199915, 6203800 and 6215115.
  Part of the patch which is applicable to community smb-method is given
  to community as part of bugzilla bug#132933. And community maintainer
  committed the the changes to HEAD branch.
* Fri Dec 17 2004 - [email protected]
- Added patch gnome-vfs-44-.Z-association.diff to fix the problem of
  .Z file not associated with default application. Fixes #6205707.
* Mon Dec 06 2004 - [email protected]
- Added patch 43 to ignore rootfs file system.
  Fixes bug# 6192112
* Mon Nov 29 2004 - [email protected]
- Patch #42 applies only in linux. Added ifos.
* Tue Nov 23 2004 - [email protected]
- Add the rewrite of gnome-vfs-38-mount-points-fix.diff
  Fixes #6190753
* Tue Nov 23 2004 - [email protected]
- Added path 42. Fixes #6195964
* Tue Nov 17 2004 - [email protected]
- Source entry fixed
* Tue Nov 16 2004 - [email protected]
- Backing out gnome-vfs-41-potfiles.diff patch
* Tue Nov 16 2004 - [email protected]
- Added gnome-vfs-41-potfiles.diff to update POTFILES.in 
* Wed Nov 10 2004 - [email protected]
- Added gnome-vfs-40-fork-off.diff. Fixes bug 6182789. Backport of 
  bugzilla #151026. Patch approved by Stephen Browne. Reuses forked
  process when get unix devices of volumes instead of seperately
  forking for each volume.
* Wed Nov 10 2004 - [email protected]
- Commenting out Patch 38 (gnome-vfs-38-mount-points-fix.diff) because
  it needs to be rewritten to make performance acceptable.
* Wed Nov 10 2004 - [email protected]
- Added patch gnome-vfs-39-correct-screen-for-folder.diff to make sure
  that a folder is created on the correct screen. Fixes bug#6176070.
  Patch given by [email protected]. 
* Tue Nov 09 2004 - [email protected]
- Added patch gnome-vfs-38-mount-points-fix.diff 
  Fixes bug #6190753.
* Fri Nov 05 2004 - [email protected]
- Added patch gnome-vfs-37-sftp.diff.
  Part of the fix goes to libgnomeui.
  Fixes bug# 5088520.
* Thu Nov 04 2004 - [email protected]
- Added gnome-vfs-36-g11n-potfiles.diff to update POTFILES.in
* Fri Oct 29 2004 - [email protected]
- Added patch gnome-vfs-35-trash-only-home.diff to treat only user's home 
  directory as trash volume. Don't look at all the mount points in the 
  system for trash. Fix bugtraq bugs#5105006 and 5070031
* Thu Oct 28 2004 - [email protected]
- Add gnomevfs-cat.1, gnomevfs-copy.1, gnomevfs-info.1, gnomevfs-ls.1,
  gnomevfs-mkdir.1 man pages
* Thu Oct 14 2004 - [email protected]
- Added Requires/BuildRequires of libsmbclient so that smb:/// is built
  properly.
* Wed Oct 13 2004 - [email protected]
- Forward port the panel polling patch from GNOME 2.0.2 to JDS
* Wed Sep 22 2004 - [email protected]
- Added patch gnome-vfs-33-volume-free-space-fix.diff to fix incorrect
  free space returned by gnome-vfs volume manager. Fixes bugtraq
  bug#5092286
* Wed Sep 22 2004 - [email protected]
- Avoid installation of nfs.desktop file.
* Wed Sep 22 2004 - [email protected]
- Removed NFS Module (i.e patch `gnome-vfs-03-nfs-module.diff`) 
  from Gnome-vfs. Renamed rest of the patches accordingly.
* Sat Sep 18 2004 - [email protected]
- Backported patch from gnome-vfs HEAD to prefer suffix to sniffing for
  xml files.
* Wed Sep 08 2004 - [email protected]
- Modified gnome-vfs-07-preference-menu-reorder.diff to remove duplicate
  menu items for "Printer Preferences".
* Mon Aug 30 2004 - [email protected]
- Set default url handler for "https".
* Mon Aug 23 2004 - [email protected]
- remove JDS_CBE_PREFIX definition
* Wed Aug 18 2004 - [email protected]
- added --enable-gtk-doc
* Wed Aug 11 2004 - [email protected]
- Added patch 30 for gnome-printinfo
* Fri Jul 16 2004 - [email protected]
- Added patch 29 for Network Places
* Wed Jul 14 2004 - [email protected]
- Added patch -28 to fix bugtraq #5052453
* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gnome-vfs-l10n-po-1.2.tar.bz2
* Wed Jul 07 2004 - [email protected]
- Ported to rpm4
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds
* Fri Jun 25 2004 - [email protected]
- Added patch gnome-vfs-27-sftp-exit-fix.diff to fix nautilus exit when
  using sftp:// method. Fixes bugtraq bug:5067878. The patch is a backport
  from community CVS HEAD.
* Fri Jun 25 2004 - [email protected]
- Added patch gnome-vfs-26-ftp-hostname-crash.diff to fix nautilus crash
  while using ftp:// method without specifying host name in the URL.
  Fixes bugtraq bug:5067212.
* Thu Jun 24 2004 - [email protected]
- Add gnome-vfs-25-g11n-i18n-ui.diff to translate open dialog. bugzilla #144902
* Wed Jun 09 2004 - [email protected]
- Add patch gnome-vfs-24-ftp-crash.diff
  Fixes bug# 5057615
* Tue Jun 08 2004 - [email protected]
- Remove  gnome-vfs-20-remove-gnome-20-menus.diff. We should
  have /usr/share/applications in path
* Wed Jun 02 2004 - [email protected]
- Added patch gnome-vfs-24-eject-solaris-rmm.diff to supress pointless
  error message when media is ejected.
* Mon May 31 2004 - [email protected]
- Added patch gnome-vfs-23-ftp-upload-crash.diff to fix nautilus crash
  while uploading a file to ftp server. Fixes bugtraq bug#5053735. 
  Submitted the patcht to bugzilla bug#143320 also.
* Wed May 26 2004 - [email protected]
- Added patch gnome-vfs-21-unix-device-type.diff to fix bug#5040516.
* Mon May 24 2004 - [email protected]
- Added patch gnome-vfs-21-ftp-data-loss.diff to fix data loss while
  transefering files through ftp:// method. Fixes bugtraq bug#5025035.
  The patch is backported from HEAD. This should be removed once the 
  latest tarball is picked up from community.
* Mon May 17 2004 - [email protected]
- Add patch to ignore old gnome-2.0 menu items on Solaris.
* Wed May 12 2004 - [email protected]
- Updated l10n content to gnome-vfs-l10n-po-1.1.tar.bz2
* Tue May 11 2004 - [email protected]
- jdshelp schema change
* Mon May 10 2004 - [email protected]
- Add <install_prefix>/share to XDG_DATA_DIRS path. 
  Fixes bug #5030813.
* Fri Apr 16 2004 - [email protected]
- Set mozilla as the default url handler for http.
* Fri Apr 16 2004 - [email protected]
  Correcting the typo in schemas (system_smb.schemas).
* Wed Apr 14 2004 - [email protected]
- Change in spec file. Added desktop_default_applications.schemas and
  system_smb.schemas for gconftool-2.
  Fixes bug# 5014775
* Tue Apr 06 2004 - [email protected]
- jdshelp schema patch
* Mon Mar 29 2004 - [email protected]
- Updated l10n content to gnome-vfs-l10n-po-1.0.tar.bz2
* Mon Mar 29 2004 - [email protected]
- Ported a patch for bug 136748 from HEAD. The problem is that nautilus could
  crash if staroffice mime data is found in user's own application mime.
  Since this fix goes in after the version of 2.6.0 tarball has been created,
  so create this patch, gnome-vfs-16-nautilus-crash-136748-from-head.diff for 
  cinnabar. For Vermillion, this patch can be dropped.
* Thu Mar 29 2004 - <[email protected]>
- Updated patch gnome-vfs-03-nfs-module.diff to fix NFS method related
  problems like file removal, move, rename, replace etc. for bugs:
  5014972 and 5015739, 5009330. Also updated it with fix for nfs
  rename crash (for bug#4981011) from [email protected]
* Thu Mar 25 2004 - [email protected]
- bumped to 2.6.0, updated dependency versions and
  added a dependency on shared-mime-info
* Thu Mar 11 2004 - [email protected]
- added gnome-vfs-15-g11n-potfiles.diff
* Tue Mar 09 2004 - <[email protected]>
- Added patch to define gopher proxy schemas
* Thu Mar 04 2004 - <[email protected]>
- Added patch gnome-vfs-13-nfs-drag-crash.diff to fix
  nautilus crash when a file/folder is dragged onto
  nfs:// location.
* Thu Feb 26 2004 - [email protected]
- activated ported patch gnome-vfs-02-ftp-authn-keyring.diff
* Wed Feb 25 2004 - [email protected]
- add patch 12 for uninstalled .pc files
* Wed Feb 25 2004 - [email protected]
- remove unnecessary %{_datadir}/aclocal arg from aclocal line.
* Tue Feb 24 2004 - [email protected]
- build with the JDS_CBE auto tools and set ACLOCAL_FLAGS
  to pick up JDS_CBE aclocal macros (on linux) and Build
  Requirements accordingly.
* Mon Feb 23 2004 - [email protected]
- reactivate ported patches 05 and 11
* Mon Feb 23 2004 - [email protected]
- reactivate ported patch 03 
* Mon Feb 23 2004 - [email protected]
- uprev to 2.5.7, disable patches that need porting
* Mon Feb 16 2004 - [email protected]
- Add icons to This Computer view and get decent names for hotplug devices
* Mon Feb 09 2004 - [email protected]
- include vfs daemon server file 
* Thu Feb 05 2004 - [email protected]
- Mismatch tag in gnome-vfs-01-menu-stripe.diff causing
  gnome-panel to fail
* Wed Feb 04 2004 - [email protected]
- ftp authn patch ported
* Tue Jan 06 2004 - [email protected]
- Previous changelog entry had wrong year.
* Mon Jan 05 2004 - [email protected]
- Bump to 2.5.4.1. Add gtkdocize to prep stage to
  build broken tarball.
* Mon Dec 15 2003 - [email protected]
- Bump to 2.5.3
* Fri Oct 31 2003 - [email protected]
- Remove the extras menu. Remove Sun Supported 
  from vfolder description file.
* Wed Oct 08 2003 - [email protected]
- Updated to 2.4 for quicksilver
* Thu Aug 20 2003 - [email protected]
- Modified patch 15 to remove network-neighboorhood
  and replaced it with network-places instead.
  also updated nfs.desktop.in to refer to
  Categories=X-NetworkPlaces
* Wed Aug 20 2003 - [email protected]
- Added patch 21 (not the one Stephen removed :)
  Fixes broken nfs write method.
* Tue Aug 19 2003 - [email protected]
- Removed patch 21 its totally broken
* Thu Aug 14 2003 - <[email protected]>
- move lib*.so to -devel, remove *.a, *.la
* Tue Aug 05 2003 - [email protected]
- Remove dups from devices:///
* Fri Aug 01 2003 - [email protected]
- New extras:///. Woo.
* Wed Jul 30 2003 - [email protected]
- New tarball. Bump version, reset release.
* Fri Jul 25 2003 - [email protected]
- add missing cdparanoia dependencies
* Wed Jul 23 2003 - [email protected]
- Getting system-settings:/// in order.
* Wed Jul 23 2003 - [email protected]
- Make vfolder stuff useful by editing permissions of 
  autogenerated folders.
* Mon Jul 21 2003 - [email protected]
- Add quick-start:/// uri for panel items above. This is 
  mostly on crack.
* Mon Jul 21 2003 - [email protected]
- Changed preferences:/// for new menu setup.
* Fri Jul 18 2003 - [email protected]
- added gnome-vfs-20-vfolder-no-core-items.diff to remove the
  help, home and network neighborhood from the application menu
* Wed Jul 16 2003 - [email protected]
- added gnome-vfs-19-vfolder-network-neighborhood.diff
* Wed Jul 09 2003 - <[email protected]>
- add in sun po files
* Wed Jul 9 2003 - [email protected]
- gnome-vfs-17-vfolder-non-existent-file-monitor.diff added
  adds support for registering monitors for non-existent
  vfolder elements; extensive comments about some
  limitations are in patch
* Fri Jul 4 2003 - [email protected]
- added gnome-vfs-16-network-all-users-support.diff
* Wed Jul 2 2003 - [email protected]
- added patches gnome-vfs-15-uri-canonizing.diff
and gnome-vfs-14-network-vfolder-etc.diff
* Tue Jul 1 2003 - [email protected]
- Correct icon for applications:/// view
* Tue Jul 1 2003 - [email protected]
- Added rmmdevice monitor for devices:/// uri support
* Tue Jul 1 2003  - [email protected]
- Added .desktop file for network servers
* Fri Jun 30 2003 - [email protected]
- add patch to exlude star.desktop that we use in favorites:/// uri
* Fri Jun 8 2003 - [email protected]
- fix access to authn cache in http module (gnome-vfs-06-http-fix-authn-cache-access.diff)
* Thu Jun 5 2003 - [email protected]
- open root as default folder in the ftp module (gnome-vfs-03-ftp-open-root-as-default.diff)
- port fix for pathname containg %2F from HEAD (gnome-vfs-04-%2F-fix.diff)
- add authorization callback to ftp module (gnome-vfs-05-ftp-authn-callback.diff)
* Fri May 30 2003 - [email protected]
- Make favorites:// include Mozilla and Evolution by default.
* Tue May 13 2003 - [email protected]
- initial Sun Package for GNOME 2.2 platform