libart_lgpl.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 8564 df62c23d2955
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package libart_lgpl
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: harrylu
#
Name:			libart_lgpl
License:		LGPL
Group:			System/Libraries/GNOME
Version:		2.3.17
Release:		1
Distribution:		Java Desktop System
Vendor:			Sun Microsystems, Inc.
Summary:		Libart is a library for high-performace 2D graphics
Source:			http://ftp.gnome.org/pub/GNOME/sources/libart_lgpl/2.3/libart_lgpl-%{version}.tar.bz2
Source1:                libart_lgpl_2.3.gz
URL:			http://www.levien.com/libart
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
Docdir:			%{_defaultdocdir}/doc
Autoreqprov:		on
Prereq:			/sbin/ldconfig

%description
Libart is a library for high-performace 2d graphics. It
is currently being used as the anti-aliased rendering
engine for the GNOME Canvas.


%package devel
Summary:		Libart is a library for high-performace 2D graphics
Group:			System/Libraries/GNOME
Requires:		%{name} = %{version}

%description devel
Libart is a library for high-performace 2d graphics. It
is currently being used as the anti-aliased rendering
engine for the GNOME Canvas.

%prep
%setup -q


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS -I .
autoheader
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"	\
./configure --prefix=%{_prefix}
make -j $CPUS

%install
make install DESTDIR=$RPM_BUILD_ROOT
install -d $RPM_BUILD_ROOT/usr/share/man/man3
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT/usr/share/man/man3
rm $RPM_BUILD_ROOT%{_libdir}/*.la
rm $RPM_BUILD_ROOT%{_libdir}/*.a

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%{_libdir}/*.so.*

%files devel
%defattr(-,root,root)
%{_bindir}/libart2-config
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%{_includedir}/libart-2.0
%{_mandir}/man3/*

%changelog
* Fri May 06 2005 - [email protected]
- Bump to 2.3.17
* Tue Aug 24 2004 - [email protected]
- Added libart2-config back
* Fri Aug 20 2004 - [email protected]
- packaging fixes for rpm4
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds
* Fri Feb 20 2004 - <[email protected]>
- Update Distro
* Fri Feb 06 2004 - <[email protected]>
- small patch typo: missing "-"p1
* Fri Feb 06 2004 - <[email protected]>
- add patch for -uninstalled pkgconfig file
- autotoolize
* Fri Oct 06 2003 - <[email protected]>
- Created Quicksilver build.
* Thu Aug 14 2003 - <[email protected]>
- move lib*.so to -devel, remove *.a, *.la
* Sun Jul 26 2003 - <[email protected]> 2.3.13
- Initial spec file