nautilus-cd-burner.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 19079 4ca5c7d71b85
child 8711 1d9419afd79e
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package nautilus-cd-burner
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: stephen
#
Name:         nautilus-cd-burner
License:      LGPL
Group:        System/Libraries/GNOME
Version:      2.17.2
Release:      2
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      nautilus-cd-burner is an extension to Nautilus that makes it easy to write files to a CD burner.
Source:       http://ftp.gnome.org/pub/GNOME/sources/nautilus-cd-burner/2.17/nautilus-cd-burner-%{version}.tar.bz2
Source1:      nautilus-cd-burner.1.gz
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/doc
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define nautilus_version 2.6.1
%define libglade_version 2.3.6
%define gnome_vfs_version 2.6.0
%define cdrecord_version 2.01
%define mkisofs_version 2.01

BuildRequires: nautilus-devel >= %{nautilus_version}
BuildRequires: gnome-vfs-devel >= %{gnome_vfs_version}
BuildRequires: libglade-devel >= %{libglade_version}
Requires: nautilus >= %{nautilus_version}
Requires: gnome-vfs >= %{gnome_vfs_version}
Requires: libglade >= %{libglade_version}
Requires: cdrecord >= %{cdrecord_version}
Requires: mkisofs >= %{mkisofs_version}

%description
This packages adds basic, easy to use CD writing features to nautilus.
The user drags any files or folders to be written to the CD into the 
burn:/// URI view in a nautilus window and clicks on the write to cd
button to write them to the CD.

%prep
%setup -q

for po in po/*.po; do
  dos2unix -ascii $po $po
done

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
glib-gettextize -f
aclocal $ACLOCAL_FLAGS -I .
autoheader
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}		\
	    --datadir=%{_datadir}       \
	    --sysconfdir=%{_sysconfdir} \
	    --libexecdir=%{_libexecdir}
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make DESTDIR=$RPM_BUILD_ROOT install
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1
#Clean up unpackaged files
rm $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/*.la
rm $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-1.0/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="ncb.schemas"
for S in $SCHEMAS; do
  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%postun
/sbin/ldconfig

%files
%defattr(-, root, root)
%{_datadir}/locale/*/LC_MESSAGES/*
%{_datadir}/nautilus-cd-burner
%{_datadir}/applications/*
%{_bindir}/nautilus-cd-burner
%{_libexecdir}/*
%{_libdir}/gnome-vfs-*/modules/*.so
%{_libdir}/nautilus/extensions-1.0/*.so*
%{_sysconfdir}/*
%{_mandir}/man1/*
%{_includedir}/libnautilus-burn
%{_libdir}/libnautilus-burn.*
%{_libdir}/pkgconfig/libnautilus-burn.pc

%changelog
* Thu Nov 23 2006 - [email protected]
- Bump to 2.17.2.
* Tue Oct 03 2006 - [email protected]
- Bump to 2.16.1. Remove all patches as they are upstream.
* Mon Sep 18 2006 - [email protected]
- Add back nautilus-cd-burner-05-solarishal.diff patch to make sound-juicer
  work with Solaris HAL, where the raw device name must be used.
* Fri Sep 15 2006 - [email protected]
- Add patch 04-handle-eof.diff from maintainer to fix 6472085.
* Tue Sep 05 2006 - [email protected]
- Bump to 2.16.0.
* Tue Aug 08 2006 - [email protected]
- Bump to 2.15.6.
* Tue Jul 25 2006 - [email protected]
- Bump to 2.15.5.
* Thu Jul 20 2006 - [email protected]
- Bump to 2.15.4. Remove obsolete patch, 04-solarishal.
* Wed Jun 21 2006 - [email protected]
- Bump to 2.14.2.  Remove intltoolize call - just use glib-gettextize.
* Fri Apr 28 2006 - [email protected]
- add patch to make nautilus-cd-burner work with Solaris HAL.
* Thu Apr 13 2006 - [email protected]
- replace sed with dos2unix to work around ^M problem in SVN
* Mon Apr 10 2006 - [email protected]
- Bump to 2.14.1.
* Wed Mar 15 2006 - [email protected]
- Bump to 2.14.0.2.
* Tue Mar 14 2006 - [email protected]
- Bump to 2.14.0.1.
* Mon Mar 13 2006 - [email protected]
- Bump to 2.14.0.
* Wed Mar  1 2006 - [email protected]
- use sed instead of dos2unix for converting the po files, because dos2unix
  corrupts some UTF-8 strings
* Tue Feb 28 2006 - [email protected]
- Bump to 2.13.92.
* Tue Feb 14 2006 - [email protected]
- Bump to 2.13.91.
* Tue Jan 31 2006 - [email protected]
- Bump to 2.13.90.
* Tue Jan 17 2006 - [email protected]
- Bump to 2.13.5
* Sun Jan 15 2006 - [email protected]
- Bump to 2.13.4
* Tue Dec 20 2005 - [email protected]
- Bump to 2.13.3
* Tue Nov 29 2005 - [email protected]
- Bump to 2.12.2.
* Thu Oct 13 2005 - [email protected]
- Remove upstream patch 05. Fix patch 04.
* Tue Oct 11 2005 - [email protected]
- Bump to 2.12.1
* Sat Sep 17 2005 - [email protected]
- Bump to 2.12.0
* Mon Sep 05 2005 - [email protected]
- Bump to 2.11.7.
* Tue Aug 16 2005 - [email protected]
- Bump to 2.11.6.
* Tue May 24 2005 - [email protected]
- Fix building.
* Fri May 20 2005 - [email protected]
- Bump to 2.10.1
* Tue Apr 05 2005 - [email protected]
- Added nautilus-cd-burner-07-data-size.diff, throws error
  dialog if the data size exceeds CD capacity.
* Thu Mar 24 2005 - [email protected]
- Added nautilus-cd-burner-06-no-files-selected.diff, which throws
  error dialog if no files selected to burn.
* Thu Mar 24 2005 - [email protected]
- Re-commiting nautilus-cd-burner-05-menuitem.diff patch
  which takes care of multiple devices attached to M/c.
* Fri Mar 11 2005 - [email protected]
- Added nautilus-cd-burner-05-menuitem.diff, allows
  Write to CD... menu item to apprear depending upon
  the availablity of CD Writers.
* Fri Mar 11 2005 - [email protected]
- Added nautilus-cd-burner-04-help.diff patch so
  that help comes up for CD creator. Fixes #6238724.
* Fri Nov 05 2004 - [email protected]
- Updated the patch nautilus-cd-burner-03-mkdtemp-sun-fix.diff
  so that cd creator functions in solaris. Fixes bug #5094522.
* Thu Oct 28 2004 - [email protected]
- Add nautilus-cd-burner.1 man page
* Thu Jul 08 2004 - [email protected]
- Updated l10n content to nautilus-cd-burner-l10n-po-1.2.tar.bz2
* Wed Jul 07 2004 - [email protected]
- ported to rpm4
* Wed May 12 2004 - [email protected]
- Updated l10n content to nautilus-cd-burner-l10n-po-1.1.tar.bz2
* Fri Apr 16 2004 - [email protected]
- Add --libexecdir to configure line to support building on
  Solaris.
* Mon Mar 29 2004 - [email protected]
- Updated l10n content to nautilus-cd-burner-l10n-po-1.0.tar.bz2
* Wed Mar 24 2004 - [email protected]
- Bump to 2.6.0.
* Wed Mar 10 2004 - [email protected]
- Bump to 0.6.6, fix files map.
* Wed Feb 18 2004 - [email protected]
- Bump to 0.6.5, update files section
* Tue Oct 14 2003 - [email protected]
- updating to 0.5 to correspond with gnome-2.4 desktop
* Tue Sep 23 2003 - [email protected]
- adding runtime dependency on mkisofs, can't do
  much useful without it :-)
* Thu Jul 03 2003 - [email protected]
- initial Sun release.