nautilus.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 19078 a6e7d195f684
child 8644 03a152fd5cf6
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package nautilus
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner:stephen

Name:         nautilus
License:      GPL
Group:        Productivity/File utilities
Version:      2.16.2
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      The GNOME Filemanager
URL:          http://www.gnome.org
Source:       http://ftp.gnome.org/pub/GNOME/sources/nautilus/2.16/nautilus-%{version}.tar.bz2
Source1:      nautilus.1.gz
Source2:      nautilus-file-management-properties.1.gz
Source3:      nautilus-acl-icons-0.2.tar.bz2 
#owner:stephen date:2004-10-29 type:bug bugster:5105006,5070031 bugzilla:137282
Patch1:       nautilus-01-trash-only-home.diff
#I'm still figuring out the following two patches but they dont look good to me
Patch2:       nautilus-02-nonlocalized-history-fix.diff
Patch3:       nautilus-03-nonlocalized-templates.diff
#owner:stephen date:2005-02-25 type:bug bugster:5011528
Patch4:       nautilus-04-desktop-cluttered-icons.diff
#owner:stephen date:2005-05-07 type:bug bugster:6238031 bugzilla:170761
Patch5:       nautilus-05-ftp-rename.diff
#owner:stephen date:2004-11-10 type:bug bugster:6174222
Patch6:      nautilus-06-execute-shellscript.diff
#owner:stephen date:2005-06-17 type:branding
Patch7:      nautilus-07-context-menu.diff
#owner:stephen date:2005-05-20 type:feature bugster:6211279
Patch8:      nautilus-08-frame-buffer.diff
#owner:stephen date:2004-02-19 type:feature
Patch9:      nautilus-09-lockdown.diff
#owner:gman date:2005-10-17 type:branding
Patch10:      nautilus-10-uninstalled-pc.diff
#owner:gman date:2006-04-25 type:branding
Patch11:      nautilus-11-interface-changes.diff
#owner:alo date:2006-05-11 type:feature
Patch12:      nautilus-12-acl.diff
#owner:stephen date:2006-07-12 type:feature
Patch13:      nautilus-13-trusted-extensions.diff
#owner:stephen date:2006-11-17 type:bug bugzilla:373895 bugster:6493510
Patch14:      nautilus-14-desktop-icon-placement.diff
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/nautilus2
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define fam_version  2.6.10
%define glib2_version 2.4.0
%define pango_version 1.4.0
%define gtk2_version 2.4.0
%define libgnomeui_version 2.6.0
%define eel_version 2.6.1
%define gnome_icon_theme_version 1.2.0
%define libxml2_version 2.6.7
%define eog_version 2.6.1
%define gail_version 1.6.3
%define gnome_desktop_version 2.6.1
%define gnome_vfs_version 2.6.0
%define startup_notification_version 0.5
%define libgnomecups_version 0.1.6
%define gnome_cups_manager_version 0.17
%define scrollkeeper_version 0.3.14
%define libgnomeprint_version 2.6.0
%define libgnomeprintui_version 2.6.0
%define esound_version 0.2.27
%define gettext_version 0.14.0

Requires:	fam >= %{fam_version}
Requires:       gnome-vfs >= %{gnome_vfs_version}
Requires:       eel >= %{eel_version}
Requires:       gnome-icon-theme >= %{gnome_icon_theme_version}
Requires:       libgnomecups >= %{libgnomecups_version}
Requires:       libgnomeprint >= %{libgnomeprint_version}
Requires:       libgnomeprintui >= %{libgnomeprintui_version}

BuildRequires:  fam-devel >= %{fam_version}
BuildRequires:	scrollkeeper >= %{scrollkeeper_version}
BuildRequires:	glib2-devel >= %{glib2_version}
BuildRequires:	pango-devel >= %{pango_version}
BuildRequires:	gtk2-devel >= %{gtk2_version}
BuildRequires:	libgnomeui-devel >= %{libgnomeui_version}
BuildRequires:	libxml2-devel >= %{libxml2_version}
BuildRequires:  eel-devel >= %{eel_version}
BuildRequires:  gail-devel >= %{gail_version}
BuildRequires:  gnome-icon-theme >= %{gnome_icon_theme_version}
BuildRequires:  gnome-desktop-devel >= %{gnome_desktop_version}
BuildRequires:  gnome-vfs-devel >= %{gnome_vfs_version}
BuildRequires:  startup-notification-devel >= %{startup_notification_version}
BuildRequires:  librsvg >= 2.2.4
BuildRequires:  intltool >= 0.25
BuildRequires:  XFree86-devel >= 4.3.0
BuildRequires:  libgnomecups-devel >= %{libgnomecups_version}
BuildRequires:  libgnomeprint-devel >= %{libgnomeprint_version}
BuildRequires:  libgnomeprintui-devel >= %{libgnomeprintui_version}
BuildRequires:  esound-devel >= %{esound_version}
BuildRequires:  gettext >= %{gettext_version}

%description
This package contains Nautilus, the advanced filemanager for the GNOME platform.


%package devel
Summary:      Development package for Nautilus
Group:        Development/Libraries/GNOME
Requires:     %name = %version-%release

%description devel
This package contains all files needed to develop programs that use the features of the Nautilus filemanager.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch10 -p1 
%patch11 -p1 
%patch12 -p1 
%patch13 -p1
%patch14 -p1

for po in po/*.po; do
  dos2unix -ascii $po $po
done

bzcat %SOURCE3 | tar xf -

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

# FIXME: remove most locale files as they break the build
# something weird going on here...
# the error message looks like this:
#: /var/tmp/SUNWgnome-file-mgr-2.13.3-build//etc/gconf/schemas/apps_nautilus_preferences.schemas:61: parser error : Input is not proper UTF-8, indicate encoding !
#: Bytes: 0xC8 0xED 0x20 0x61
#:          <long>Se est<C8><ED> activado, os ficheiros agochados ser<C8><ED>n amosados no xest
#:                      ^

LC_ALL=
LANG=
export LANG LC_ALL
libtoolize --force --copy
intltoolize --force --copy
aclocal $ACLOCAL_FLAGS -I .
autoheader
automake -a -c -f
autoconf
CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
	--prefix=%{_prefix} \
    	--datadir=%{_datadir}       \
	--sysconfdir=%{_sysconfdir} \
        --libexecdir=%{_libexecdir} \
	--disable-update-mimedb \
	--localstatedir=/var/lib

make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 
make install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL

install -d $RPM_BUILD_ROOT/usr/share/man/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT/usr/share/man/man1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT/usr/share/man/man1
rm $RPM_BUILD_ROOT%{_libdir}/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="apps_nautilus_preferences.schemas"
for S in $SCHEMAS; do
  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%postun
/sbin/ldconfig

%files
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog NEWS README
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/applications/*
%{_datadir}/pixmaps/*
%{_datadir}/nautilus
%{_datadir}/mime/packages/*
%{_libdir}/*.so.*
%{_bindir}/*
%{_libdir}/bonobo/servers/Nautilus_shell.server
%{_sysconfdir}/gconf/schemas/*.schemas
%{_mandir}/man1/*

%files devel
%defattr(-,root,root)
%{_libdir}/*.so
%{_includedir}/nautilus
%{_libdir}/pkgconfig/*.pc

%changelog
* Wed Nov 08 2006 - [email protected]
- Bump to 2.16.2.
- remove upstream patches
* Tue Oct 31 2006 - [email protected]
- Add nautilus-20-properties-relations.diff to fix bug 6458330, bugzilla 356124
* Fri Oct 06 2006 - [email protected]
- Add nautilus-19-add-relations.diff to fix bug 6458338.
* Mon Oct 02 2006 - [email protected]
- Bump to 2.16.1.
* Fri Sep 15 2006 - [email protected]
- Bug : 6470306, remove patch-19, problem was actually within patch 
  11-frame-buffer.diff
* Thu Sep 14 2006 - [email protected]
- Bug : 6470306, metadata read fail causing crash
* Mon Sep 04 2006 - [email protected]
- Bump to 2.16.0.
* Tue Aug 22 2006 - [email protected]
- Bump to 2.15.92.1.
* Tue Aug 22 2006 - [email protected]
- Bump to 2.15.92.
* Tue Aug 08 2006 - [email protected]
- Delete nautilus-09-floppy.diff
  Rework nautilus-11-frame-buffer.diff
* Tue Aug 08 2006 - [email protected]
- Bump to 2.15.91.
* Wed Jul 26 2006 - [email protected]
- Bump to 2.15.90.
* Wed Jul 20 2006 - [email protected]
- Bump to 2.15.4.
  Remove patch #19
* Tue May 23 2006 - [email protected]
- remove linguas.diff: not needed.
* Thu May 11 2006 - [email protected]
- Added patch #18: ACL support
* Wed May 03 2006 - [email protected]
- Update LINGUAS file so all languages are on one line, becuase this is causing
  problems building with the latest intltool.
* Thu Apr 13 2006 - [email protected]
- replace sed with dos2unix to work around ^M problem in SVN
* Tue Apr 11 2006 - [email protected]
- Bump to 2.14.1.
* Mon Mar 13 2006 - [email protected]
- Bump to 2.14.0.
* Wed Mar  1 2006 - [email protected]
- use sed instead of dos2unix for converting the po files, because dos2unix
  corrupts some UTF-8 strings
* Tue Feb 28 2006 - [email protected]
- Bump to 2.13.92.
* Mon Feb 13 2006 - [email protected]
- Bump to 2.13.91.
* Tue Jan 31 2006 - [email protected]
- Bump to 2.13.90.
* Wed Jan 18 2006 - [email protected]
- Add intltoolize call.
* Tue Jan 17 2006 - [email protected]
- Bump to 2.13.4
* Thu Jan 12 2006 - [email protected]
- Add patch to change to browser mode by default.
* Tue Jan 03 2006 - [email protected]
- Bump to 2.13.3.
* Tue Nov 29 2005 - [email protected]
- Bump to 2.12.2.
* Mon Oct 17 2005 - [email protected]
- Add uninstalled pc file for nautilus
* Fri Oct 14 2005 - [email protected]
- add patch locale.h.diff to fix the build
* Tue Oct 11 2005 - [email protected]
- Bump to 2.12.1
* Sat Sep 17 2005 - [email protected]
- Bump to 2.12.0
* Mon Sep 05 2005 - [email protected]
- Bump to 2.11.92.
* Tue Aug 16 2005 - [email protected]
- Bump to 2.11.91.
* Fri Jun 17 2005 - [email protected]
- Added patch nautilus-14-floppy.diff for bug #5078858.
  Added nautilus-15-context-menu.diff.
* Fri Jun 17 2005 - [email protected]
- Added patch nautilus-13-subfs.diff
  Patch taken for bug #6195964 and #6193864.
* Fri Jun 17 2005 - [email protected]
- Added patch nautilus-12-execute-shellscript.diff
  Patch taken for bug #6174222
* Thu Jun 02 2005 - [email protected]
- Cleaned up so it builds.
* Thu May 26 2005 - [email protected]
- Move patch nautilus-01-lockdown.diff to nautilus-X-lockdown.diff:
* Thu May 26 2005 - [email protected]
- Bump to 2.10.1
* Fri May 20 2005 - [email protected]
- Added patch nautilus-47-frame-buffer.diff to fix problem of icons not
  appearing on the magnified screen while working with dummy frame buffer.
  The patch fixes one SUN specific a11y requirement. Its not accepted in
  community. Bugtraq bug#6211279
* Fri May 06 2005 - [email protected]
- Added nautilus-46-upgrade-icons-missing.diff to make nautilus draw the 
  staroffice and Desktop Overview icons for an old user when machine is
  upgraded from QS to cinnabar.
  Fixes bug# 6257246
* Wed May 04 2005 - [email protected]
- Added nautilus-45-security-warning.diff to avoid security warning on
  double click of StarOffice 7 template. Fixes bug #6262830.
* Mon May 02 2005 - [email protected]
- Added nautilus-44-ctrl-space-crash.diff to prevent nautilus from 
  crashing on press of Ctrl+space. Fixes bug #6261299.
* Mon Apr 25 2005 - [email protected]
- Added nautilus-43-smb-domain-name.diff to allow domain name to be
  entered along with username in smb.
  Fixes bug #6247186
* Fri Apr 22 2005 - [email protected]
- Added  nautilus-42-trash-skip-copy.diff to fix a trash issue.
  Fixes bug #6243507
* Fri Apr 22 2005 - [email protected]
- Added nautilus-41-anonymous-ftp-error.diff to launch the 
  appropriate error dialog when anonymous ftp is not supported.
  Fixes bug #6254481.
* Wed Apr 20 2005 - [email protected]
- Added nautilus-40-icon-view-crash.diff. Fixes bug #6234894 
* Thu Apr 07 2005 - [email protected]
- Added nautilus-39-ftp-rename.diff to fix nautilus not allowing
  the opening or renaming of folders after the deletion of a 
  bookmarked folder. Fixes bug 6238031.
* Thu Mar 31 2005 - [email protected]
- Added nautilus-38-g11n-filename.diff to handle localized
  background filenames. Fixes bug 6247833
* Fri Feb 25 2005 - [email protected]
- Added patch #37 nautilus-37-desktop-cluttered-icons.diff
  Fixes bug #5011528
* Fri Feb 22 2005 - [email protected]
- Removed "Obsoltes: epiphany" headers.
* Fri Feb 11 2005 - [email protected]
- Added patch #36 nautilus-36-max-zoom-level.diff to set the max zoom
  level correctly.
* Fri Feb 04 2005 - [email protected]
- Added patch #35 nautilus-35-printer-mnemonics.diff
  Included mnemonics for some menu items in context menu for
  printer.Fixes bug #4917219.  
* Thu Feb 03 2005 - [email protected]
- Added patch #33 nautilus-33-add-network-place-mnemonics.diff
  Changed the shortcut for connect button in Add Network Place.
* Fri Jan 21 2005 - [email protected]
- Added patch #32 nautilus-32-move-trash-dup.diff
  Fixes bug #6212062
* Mon Jan 17 2005 - [email protected]
- Added patch #31 nautilus-31-bookmarks-fix.diff
  Fixes bookmarks crash.
* Fri Dec 24 2004 - [email protected]
- Added patch #30 nautilus-30-unescape-filename-to-print.diff
  Fixes print not working with spaced filename.
* Wed Dec 22 2004 - [email protected]
- Added patch #29 nautilus-29-nonlocalized-history-fix.diff
* Mon Dec 13 2004 - [email protected]
- Added patch #28 to fix crash when accessibility is enabled.
* Fri Dec 10 2004 - [email protected]
- Fixed brokenness in patch #21 (trash handling). Change operation
  to a standard move to work across filesystem boundaries.
* Mon Dec 06 2004 - [email protected]
- Added patch #27 to prevent nautilus crash when we right click
  print on floppy icon and select print. Fixes bug #6200498.
* Wed Dec 01 2004 - [email protected]
- Added patch #27 to integrate fsexam into nautilus context menu.
  And only applied in Linux.
* Wed Nov 23 2004 - [email protected]
- Patch #26 is only applied in Linux by the moment: so10 code freeze
  and problems with the prev. patch. This has to be fixed to keep only
  one source tree.
* Wed Nov 23 2004 - [email protected]
- Added patch 26 to fix some problems about Subfs. Fixes #6195964
* Wed Nov 10 2004 - [email protected]
- Added patch 25 to support formatting floppy disks on Solaris and to
  fix Nautilus so it properly unmounts floppy disks on Solaris.
* Wed Nov 10 2004 - [email protected]
- Added patch nautilus-24-execute-shellscripts.diff so that it throws up
  dialog asking whether to execute the file or open with come application
  for shell scripts.
* Tue Nov 09 2004 - [email protected]
- Added nautilus-23-click-cur-crash.diff to fixes crash when double click
  on .cur file. Fixes bug #6183952.
* Tue Nov 09 2004 - [email protected]
- Updated the patch nautilus-02-default-setup.diff to enable startup
  notification for Desktop Overview desktop file.
* Thu Nov 04 2004 - [email protected]
- Added patch nautilus-22-create-archive-work.diff to make right click
  create archive option function. Fixes bug #6186537.
* Fri Oct 29 2004 - [email protected]
- Added patch nautilus-21-trash-only-home.diff to treat only user's 
  home directory as trash volume. Don't look at all the mount points 
  in the system for trash. Fix bugtraq bugs#5105006 and 5070031
* Thu Oct 28 2004 - [email protected]
- Add nautilus-file-management-properties.1 man page
* Wed Oct 27 2004 - [email protected]
- Removed nautilus-21-desktop-startup-notification.diff as the patch
  should be rolled into the original nautilus-02-default-setup.diff patch. 
* Wed Oct 27 2004 - [email protected]
- Added nautilus-21-desktop-startup-notification.diff to enable 
  startup notification for Desktop Overview desktop file.
  Fixes the bugtraq bug#6180411.
* Mon Oct 18 2004 - [email protected]
- Added esound-devel and gettext dependencies
- "Source" entry updated
* Tue Aug 31 2004 - [email protected]
- Modified patch nautilus-18-add-network-place.diff to provide help
  innvocation.
* Mon Aug 30 2004 - [email protected]
- Updated nautilus-04-g11n-potfiles.diff
* Mon Aug 30 2004 - [email protected]
- Added patch nautilus-19-computer-size-sort-crash.diff to fix nautilus
  crash when sort is done on size in computer view. Fixes bugtraq
  bug#5093170. Submitted the fix to bugzilla also. Bugzilla bug#151228
* Wed Aug 18 2004 - [email protected]
- removed --disable-gtk-doc since this isn't an option this module's
  configure takes.
* Thu Jul 22 2004 - [email protected]
- Modified patch nautilus-08-printing.diff to hide Print menu item 
  in Solaris, as there is no CUPS support available. Fixes bugtraq
  bug#5076500
* Fri Jul 16 2004 - [email protected]
- Added patch 18 for Network Places
* Wed Jul 14 2004 - [email protected]
- Added patch nautilus-17-add-nfs-mime.diff to add x-directory/nfs-mount 
  and x-directory/nfs-share mimes under supported mime types for 
  Icon and List views. Fixes bugtraq bug#5034725.
* Tue Jul 13 2004 - [email protected]
- Updated patch nautilus-16-use-default-action-for-files.diff to fix
  issue with printers:/// location. Fixes bugtraq bug#5069536.
* Thu Jul 08 2004 - [email protected]
- Updated l10n content to nautilus-l10n-po-1.2.tar.bz2
* Thu Jul 08 2004 - [email protected]
- ported to rpm4/suse91
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds
* Fri Jun 25 2004 - [email protected]
- Added patch nautilus-16-use-default-action-for-files to fix
  butraq bug: 5064649
* Fri Jun 25 2004 - [email protected]
- Added patch nautilus-15-host-name-crash.diff to fix nautilus crash
  when it tries to display host name in an error message for Solaris.
  Fixes bugtraq bug:5067212
* Wed Jun 09 2004 - [email protected]
- Add patch nautilus-14-help-contents-link.diff to fix the 
  Help->Contents.
* Mon May 31 2004 - [email protected]
- Add patch nautilus-13-deselect.diff to backport fix for bugzilla
  bug #140827.
* Thu May 20 2004 - [email protected]
- Reverting back the previous change. Moving #include <config.h> alone
  solves the problem
* Thu May 20 2004 - [email protected]
- Modified nautilus-01-printers.diff, to define HAVE_LIBGNOMECUPSUI 
  using AC_DEFINE_UNQUOTED instead of AC_DEFINE. Fixes bug #5042415
* Thu May 13 2004 - [email protected]
- Added patch nautilus-12-view-as-image.diff to fix nautilus crash
  in solaris while browsing to a location with image files.
  Fixes bugtraq bug#5043908.
* Wed May 12 2004 - [email protected]
- Updated l10n content to nautilus-l10n-po-1.1.tar.bz2
* Thu May 12 2004 - [email protected]
- replaced jds-help.sh with jdshelp
* Thu May 06 2004 - [email protected]
- add jds-help.sh to second patch
* Thu May 06 2004 - [email protected]
- auto*-jds it
* Wed May 05 2004 - [email protected]
- Sort out patches. Dump share/mount patch, rewrite print from
  nautilus patch
* Fri Apr 30 2004 - [email protected]
- patch #02 no longer requires "%ifos" evil
* Tue Apr 27 2004 - [email protected]
- Added patch nautilus-15-preference-tabs-help-links.diff to fix 
  help links for 'Behavior' and 'List Columns' tabs.
* Mon Apr 26 2004 - [email protected]
- patched nautilus-13-printing.diff correctly for 2.6.1
* Mon Apr 26 2004 - [email protected]
- Updated tarball to 2.6.1
* Wed Apr 21 2004 - [email protected]
- Updated tarball to 2.6.0
* Mon Mar 29 2004 - [email protected]
- Updated l10n content to nautilus-l10n-po-1.0.tar.bz2
* Fri Mar 26 2004 - [email protected]
- added --libexecdir to configure args
* Mon Mar 15 2004 - [email protected]
- Updated nautilus-03-this-computer-and-documents.diff to fix 4938606
- Replaced nautilus-06-potfiles-update.diff with nautilus-06-g11n-potfiles.diff
- Replaced nautilus-08-schemas-chinese.diff with nautilus-08-g11n-schemas.diff
* Tue Mar 09 2004 - <[email protected]>
- Updated nautilus-13-printing.diff to fix the incorrectly placed
  Print menu item in fm-directory-view-ui.xml. Should be under the Selection
  popup section instead of background section.
* Thu Mar 04 2004 - <[email protected]>
- Updated the patch nautilus-07-mount-nfs-share-options.diff to 
  port fixes from quicksilver to cinnabar for bugs:4968376, 4966836, 
  4997201, 4981761, 4966812
* Tue Feb 24 2004 - [email protected]
- ported nautilus-13-printing.diff and make it lnux only ATM.
  since no cups supports by default on SOlaris.
* Fri Feb 20 2004 - [email protected]
- ported cd reaonly emblem patch
* Thu Feb 19 2004 - [email protected]
- more patch munging :)
* Thu Feb 19 2004 - [email protected]
- readded gestures patch
* Thu Feb 19 2004 - [email protected]
- SO Desktop icon patch from QS
* Thu Feb 19 2004 - [email protected]
- two more patches 9 + 10 ported
* Wed Feb 18 2004 - [email protected]
- patches ported up to #6 more to go :/
* Wed Feb 18 2004 - [email protected]
- added nautilus-list-view-ui.xml to %files
- added %{_includedir}/nautilus to %files devel
* Wed Feb 18 2004 - [email protected]
- commented out nautlius-tree-view elements from files as not built anymore
* Wed Feb 18 2004 - [email protected]
- Updated some versions
* Thu Feb 12 2004 - [email protected]
- added ACLOCAL_FLAGS to aclocal invocation
- only apply patch 02 (printers) on linux
* Mon Feb 09 2004 - [email protected]
- ported Network Places patch
* Mon Jan 26 2004 - [email protected]
- uprevved the l10n source tarball to 0.6
* Tue Jan 13 2004 - [email protected]
- added a couple of new ui xml files from latest version
* Thu Jan 08 2004 - [email protected]
- New patch #14 to build against gtk+-2.3.x
- Minimum libgnomeui version of 2.5.2 required
- New version 2.5.4. Most patches are commented out just
  to make it build for now.
- comment out "%{sysconfdir}/gnome-vfs-2.0" from %files
  (was necessarey for the my-computer view patch)
* Mon Nov 02 2003 - [email protected]
- Add Applications to system:///
* Tue Oct 21 2003 - [email protected]
- Added nautilus-11-printing.diff patch to allow printing in nautilus.
  bug#4938054.
* Tue Oct 21 2003 - [email protected]
- Reactvated the patches and the printers rpm
* Mon Oct 13 2003 - [email protected]
- New version 2.4.0, temporarily commented out patches and
  branding and related post-install scripts.
* Fri Sep 05 2003 - [email protected]
- Add nautilus-12-schemas-chinese.diff to fix font sizes.
  Fixes bug 4915643.
* Tue Aug 19 2003 - [email protected]
- added nautilus-11-network-places-crash-4904221.diff
* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la
* Tue Aug 12 2003 - [email protected]
- cleaned up patches bug time,
  s/my computer/this comuter
  s/my documents/documents
* Wed Aug 06 2003 - [email protected]
- add toplevel help to desktop window
* Tue Aug 05 2003 - [email protected]
- add bmp previews
* Tue Aug 05 2003 - [email protected]
- add nautilus-26-network-place-shortcut-name.diff
* Tue Aug 05 2003 - [email protected]
- fix crash when viewing remote files
* Tue Aug 05 2003 - [email protected]
- added nautilus-24-network-dialog-tree-rewrite.diff
* Fri Aug 01 2003 - [email protected]
- Add menu entry categorization.
* Thu Jul 31 2003 - [email protected]
- Move the gnome-cups-manager more explict.
* Mon Jul 28 2003 - [email protected]
- Make nautilus-mount use usermode
* Fri Jul 25 2003 - [email protected]
- Add quick-start location to the icon lookup.
* Thu Jul 24 2003 - [email protected]
- Fly away Home Come back My Documents
* Wed Jul 23 2003 - [email protected]
- Fix inconsistent Wastebasket naming in en_GB
* Mon Jul 21 2003 - [email protected]
- Let's give the file manager preferences a window icon
* Thu Jul 17 2003 - [email protected]
- Make sure that we install the file management preferences desktop
* Thu Jul 17 2003 - [email protected]
- added nautilus-18-network-place-window-icon.diff
* Wed Jul 16 2003 - [email protected]
- added nautilus-17-network-directory-file.diff
* Tue Jul 15 2003 - [email protected]
- Added printers desktop into control-center-2.0 for preferences:///
* Tue Jul 15 2003 - [email protected]
- added nautilus-15-server-connect-async-dir-load.diff
* Sun Jul 14 2003 - [email protected]
- added patch 14-mount-nfs-share-options.diff
* Thu Jul 10 2003 - [email protected]
- added patch nautilus-13
* Thu Jul 10 2003 - [email protected]
- Added .po tarball
* Wed Jul 09 2003 - [email protected]
- nautilus-12-priniters-icon.diff added
* Wed Jul 09 2003 - [email protected]
- nautilus-11-pref-defaults.diff added
* Thu Jul 03 2003 - Laszlo. [email protected]
- nautilus-09-restore-desktop-item-save-method.diff added
* Thu Jul 03 2003 - Laszlo. [email protected]
- added nautilus-08-add-network-place-label.diff
* Thu Jul 03 2003 - [email protected]
- version 2.2.4 - contains fix for long desktop icon labels getting left clipped
- added nautilus-07-cdburn.diff to integrate cd burning menu items etc.
* Tue Jul 01 2003 - [email protected]
- added my computer/system vfolder support
* Tue Jul 01 2003 - [email protected]
- added new sun branded throbber
* Fri Jun 27 2003 - [email protected]
- added the printers patch to show printers:// view in nautilus
* Tue Jun 10 2003 - [email protected]
- added %{datadir}/gnome to %files
* Thu Jun 5 2003 - Laszlo [email protected]
- fill user name in password dialog if passed in URI (nautilus-01-fill-user-in-passwd-dialog.diff)
* Thu May 01 2003 - [email protected]
- Initial Sun release