pygobject.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 19073 09f5bf6611e6
child 8644 03a152fd5cf6
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package pygobject
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: laca
#
Name:			pygobject
License:		LGPL	
Group:			System/Library
# Bump ver number in pygtk2-02-pygobject-xsl-dir.diff to match.
Version:		2.12.2
Release:		2
Distribution:		Java Desktop System
Vendor:			Sun Microsystems, Inc.
Summary:		Python bindings for GObject
Source:			http://ftp.gnome.org/pub/GNOME/sources/pygobject/2.12/pygobject-%{version}.tar.bz2	
URL:			http://www.gnome.org
# date:2006-04-05 owner:dcarbery type:bug
Patch1:                 pygobject-01-uninstalled.pc.diff
# date:2006-07-27 owner:dcarbery type:bug
# FIXME: upstreamable
Patch2:                 pygobject-02-void-return.diff
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
Docdir:			%{_defaultdocdir}/doc
Autoreqprov:		on

%define libglade_version 2.4.0
%define glib2_version 2.6.0
%define gtk2_version 2.6.0
%define atk_version 1.8.0
%define pango_version 1.8.0
%define python_version 2.4

Requires:		libglade >= %{libglade_version}
Requires:		gtk2 >= %{gtk2_version}
Requires:		glib2 >= %{glib2_version}
Requires:		atk >= %{atk_version}
Requires:		pango >= %{pango_version}
Requires:		python >= %{python_version}
BuildRequires: 		gtk2-devel >= %{gtk2_version}
BuildRequires:		libglade-devel >= %{libglade_version}
BuildRequires:		glib2-devel >= %{glib2_version}
BuildRequires:		atk-devel >= %{atk_version}
BuildRequires:		pango-devel >= %{pango_version}

%description
PyGObject is an extension module for python that gives you access to GObject

%package devel
Summary: files needed to build wrappers for GObject libraries
Group: Development/Languages
Requires: %{name} = %{version}

%description devel
This package contains files required to build wrappers for GObject
libraries so that they interoperate with pygobject.

%prep
%setup -q -n pygobject-%{version}
%patch1 -p1
%patch2 -p1

%build
aclocal -I ./m4 $ACLOCAL_FLAGS
autoconf
automake -a -c -f
%ifos solaris
# Disable optimizations on x86 to workaround compiler bug 6382078.
%ifarch sparc
CFLAGS="$RPM_OPT_FLAGS"				\
%else
CFLAGS="$RPM_OPT_FLAGS -xO0"			\
%endif
%endif
./configure 	--prefix=%{_prefix}		\
	    	--sysconfdir=%{_sysconfdir}
make

%install
make install DESTDIR=$RPM_BUILD_ROOT \
    pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
    pythondir=%{_libdir}/python%{python_version}/vendor-packages
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'

%clean
rm -rf $RPM_BUILD_ROOT

%post

%postun

%files
%defattr(-, root, root)
%{_libdir}/python?.?/vendor-packages/*

%files devel
%defattr(-, root, root)
%doc examples
%doc AUTHORS NEWS README MAPPING ChangeLog
%{_bindir}/*
%{_includedir}/*
%{_libdir}/pkgconfig/*
%{_libdir}/pygobject/*
%{_datadir}/pygobject/*

%changelog -n pygobject
* Sat Oct 07 2006 - [email protected]
- Add aclocal and automake calls.

* Wed Oct 04 2006 - [email protected]
- Bump to 2.12.2.

* Tue Sep 05 2006 - [email protected]
- Bump to 2.12.1.

* Mon Aug 28 2006 - [email protected]
- Bump to 2.11.4.

* Tue Aug 22 2006 - [email protected]
- Bump to 2.11.3.

* Tue Aug 08 2006 - [email protected]
- Bump to 2.11.2.

* Mon Aug 07 2006 - [email protected]
- Bump to 2.11.1.

* Fri Jul 21 2006 - [email protected]
- Bump to 2.11.0.

* Tue Apr 11 2006 - [email protected]
- Bump to 2.10.1.

* Wed Apr  5 2006 - [email protected]
- Initial Sun release.